Disabling AppArmor from the command line

How can I disable AppArmor from the command line? Neither Yast2 GUI nor the Yast2 ncurses inteface can disable it. I’m runnig openSUSE 12.1 x86-64.

On 2012-02-18 21:26, nlovric wrote:
>
> How can I disable AppArmor from the command line? Neither Yast2 GUI nor
> the Yast2 ncurses inteface can disable it. I’m runnig openSUSE 12.1
> x86-64.

It is a reported bug. You are very welcome to add your comments to the
report here:

<https://bugzilla.novell.com/show_bug.cgi?id=746506>


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

****. I added a comment about Yast2.

Ok, so how can I disable it?

On 2012-03-19 18:06, nlovric wrote:
>
> Ok, so how can I disable it?

I don’t know of a method that works. Ping the bugzilla. Alternative method
would be to try YaST, and if not, remove the package.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

(1) It can be disabled through the interactive Yast ncurses interface, but it is only listed when in ‘expert mode’. Mode selection is listed at the very top of the screen when editing runlevels.

(2) It can also be disabled from the command line, using yast.

To disable it (preventing it from being loaded on boot), do:

yast runlevel delete service=boot.apparmor

To stop it, try:

service boot.apparmor stop

To re-enable it, do:

yast runlevel add service=boot.apparmor