Disable sleep/hibernate/suspend(?) on login screen

Hello,
I recently installed the latest version of tumbleweed (release 20220421) in 30+ computers in my school’s computer lab.
I have one big problem - when I am on login screen after couple of minutes screen turns black, i don’t know if operating system goes to sleep etc.
I would like to prevent system from suspending/sleeping/hibernating while on login screen.
Do you have any ideas that might solve my problem?

Regards.

You could start with telling us what display manager you are using.

Sorry, forgot to mention that.
I’m using GNOME.

I’m mostly using KDE, but I do use GDM.

At one time, I used this:

sudo -u gdm dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'nothing'

I don’t know whether that still works. Gnome has changed a lot since I used that.

After entering above command system asks me for gdm’s user password which I don’t know.

But when I entered this command:

su - gdm -s /bin/sh

and then typed your code in the console I got:

No schema "org.gnome.settings.daemon.plugins.power

It looks like there is no schema for user gdm, when I entered your command for different user there was no such error.

This is settings**-daemon, not settings.**​daemon

When this is about the graphical login screen turning black after a few minutes when not used, this is simply energy saving, no suspending/sleeping/hibernating. Every touch of the keyboard brings it to live again.
So when you have to push the power button it is suspending/sleeping/hibernating, when it lights up when you start typing, it is not.

Just to help looking for a solution in the correct direction.

My bad, got rid of a typo but no effects, screen still goes black.

Thank you for clarifying that, of course the screen goes black because of energy saving, touch of keyboard works for waking it up.

Do you have any other ideas to prevent system from energy saving?

Try

gsettings set org.gnome.desktop.session idle-delay 0

Still nothing
I’ve also tried:

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

and

gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

Also didn’t work

Are you sure you actually set the value? Show full protocol of (as root)

su -l -s /bin/sh gdm
DCONF_PROFILE=gdm dconf dump /org/gnome/desktop/session/

It most certainly works for me (after setting idle-delay to 5 it blanks after 5 seconds and setting to 0 prevents blanking).

This is whole output:

administrator@localhost:~> sudo su
[sudo] password for root: 
localhost:/home/administrator # su -l -s /bin/sh gdm
gdm@localhost.localdomain:/var/lib/gdm> gsettings set org.gnome.desktop.session idle-delay 0
gdm@localhost.localdomain:/var/lib/gdm> DCONF_PROFILE=gdm dconf dump /org/gnome/desktop/session
error: dconf dir must end with a slash

Usage:
  dconf dump DIR 

Dump an entire subpath to stdout

Arguments:
  DIR         A directory path (starting and ending with '/')

gdm@localhost.localdomain:/var/lib/gdm> DCONF_PROFILE=gdm dconf dump /org/gnome/desktop/session/
/]
session-name='gnome-login'
gdm@localhost.localdomain:/var/lib/gdm> 


sudo su

What is the idea of this monster?

Anfd then continuing with

su -l .....

You want to be 300% certain your are running as root???

If I hadn’t login as root, I couldn’t use the code written below:


su -l -s /bin/sh gdm

because system was expecting a gdm’s user password which I don’t know.

And when it comes to the monster - i don’t know why :cry: Yeah i’m not a Linux specialist

So as expected the first command did not actually set any value at all. Dconf writes via D-Bus service, so dbus-launch in this post was absolutely necessary.

Where do you see root in “su -l -s /bin/sh gdm”?

Ok, it is only two times “becoming root” (and without root’s environment :().

But I am flabbergasted nevertheless. As I said elsewhere: sudo is a fast spreading decease.

I finally managed to get it done.
You are right, when I was testing it for the second time, I forgot about

dbus-launch

I used code listed below (as root):

su -l -s /bin/sh gdm
dbus-launch gsettings set org.gnome.desktop.session idle-delay 0

I then checked whether something happened or not by typing:

DCONF_PROFILE=gdm dconf dump /org/gnome/desktop/session/

and got this as a result:
/]

idle-delay=uint32 0
session-name='gnome-login'

Screen doesn’t turn black since about 30+ minutes so I think it worked!

Thank you all for your help and patience!

Greetings.