Disable RPATH check?

I have a package failing with the brp-rpath check.

ERROR: RPATH “/usr/local/freeswitch/lib” on /var/tmp/sipx-freeswitch-1.0.5-14580-root-abuild/usr/local/freeswitch/mod/ozmod_skel.so is not allowed

I’ve tried setting export NO_BRP_CHECK_RPATH=“true” in the spec file and that did not work.

There is not a --disable-rpath flag in the configure script. I even tried using sed -i ‘s|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g’ libtool
sed -i ‘s|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g’ libtool

And adding chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so to the install portion of the make file.

Any other ideas? Once again this only affects the Suse builds as centos and fedora build just fine…make we want to stop trying to make this work on suse.

Why not set it to the correct location with %{_prefix} in the configure
so it doesn’t go into /usr/local but /usr/lib{64} AFAIK /usr/local
isn’t allowed.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 13 days 7:10, 4 users, load average: 0.24, 0.67, 0.56
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15

Déjà vu?

./configure Permission Denied - openSUSE Forums](http://forums.opensuse.org/development/opensuse-build-service-obs/437611-configure-permission-denied.html)

NEVER use /usr/local, NEVER.