Disable Fake Raid?

When Ubuntu 9.10 landed, I installed it and saw the partitioner listed my drives in a weird fashion. I have 4 drives in my system - two 500gb drives, two 250gb drives. The 250s appear as nvidia-mapper-device, or something like that. I was told this was fake raid. Since Ubuntu 9.10 gave me a lot of trouble, I used 9.04 and never “fixed” this issue.

I installed OpenSuSE 11.2 today and the installer did the same thing. I asked in the IRC chat and somebody told me I need to disable something RAID related in my BIOS, however my board doesn’t support RAID to begin with.

What can I do to get my drives working again? I want to be able to choose where to mount them. I just want them to act like normal hard drives.

Additionally, where can I edit the entries to specify what drives I want mounted where upon system boot?