Devede Problem

Ok i’m running opensuse 11.1 KDE 4.3
so the problem is devede since the last update it hasent worked properly i can load up the video i want to convert and setup my settings but when it is time to covert the video and i click the foward button nothing happens i’ve used devede in the past alot so i saw an update for it today well still the same problem so i got to thinking i will run it in console to see what message i get well here it is
glib.GError: /usr/share/devede/wprogress.ui: required gtk+ version 2.16, current version is 2.14
so i went looking at the gtk packages well it is right to a point cause i do have this
gtk2 Version:2.14.4-8.7.1
but i also have this
gtk2-engines Version:2.16.1-4.1
So the problem is the first one gtk2 version 2.14 how do i get 2.16 cause my system is up to date with the latest updates
any help would be appreciated

Report the issue to Packman via their web site.

i looked on there site PackMan :: home and don’t see any place to report problems is there any other site by them that i might be able to report the issue

Go to the package and click on the packager name (It should be a link) it should open a email client, if your sys is set to allow that
otherwise get the email address out of the link
and send a copy to packman too

Ok thanks for the info

you have two ways to get the new version of devede

install from source(but i guess that you like repositories better :))

add this repository to your package management
Index of /repositories/GNOME:/STABLE:/2.26/openSUSE_11.1
this repository has the gtk2 new version and fixes your problem

an updated version has been posted on the packman website an hour ago

PackMan :: Package details for devede

i will give that a shot thanks for the suggestion

yeah i got this message from the packager from packman

the version 3.13.1 is withdrawn and replaced with the former version 3.12c.

so where will be no further updates for devede, as the needed libraries are
not available. Perhaps in openSuSE-11.2 :slight_smile:

and i also got this one but i don’t speak or read german rotfl!
Ich habe heute von Packman das devede rpm auf mein SuSE 11.1 gezogen. Auf
den ersten Blick läuft’s ok.
Wenn man aber auf gewisse Knöpfe klickt, gibt’s folgende Fehlermeldung wegen
falscher gtk+ Version:

Traceback (most recent call last):
File “/usr/share/devede/”, line 599, in
w =
File “/usr/share/devede/”, line 36, in init

File “/usr/share/devede/”, line 406, in create_tree
glib.GError: /usr/share/devede/wtitle_properties_dialog.ui: required gtk+
version 2.16, current version is 2.14

Das Vorgehen, um den Trace zu provozieren:

  1. devede starten
  2. VideoDVD erzeugen
  3. Beim Titel 1 auf Eigenschaften klicken.


  1. devede starten
  2. VideoDVD erzeugen
  3. Datei hinzufügen
  4. Button “Vor” drücken.

Könntet ihr das rpm fixen, dass es mit gtk+ 2.14 läuft, oder muss ich mir
die 2.16er irgendow besorgen?

Viele Grüsse, Markus

Google Translation:

I voted today by the devede packman rpm on my SuSE 11.1 withdrawn. On
first glance, is how it ok.
But if you click on some buttons, there’s the following error message due to
false gtk + version:

Traceback (most recent call last):
File “/ usr / share / devede /”, line 599, in
w =
devede_title_properties.title_properties (self.glad efile, self.structure, title)
File “/ usr / share / devede /”, line 36, in init

self.tree = devede_other.create_tree (self, “wtitle_pr operties_dialog” gladefile, False)
File “/ usr / share / devede /”, line 406, in create_tree
tree.add_from_file (os.path.join (builderpath, filena + me. “ui”))
glib.GError: / usr / share / devede / wtitle_properties_dialog.ui: required gtk +
Version 2.16, current version is 2:14

The approach, in order to provoke the trace:

  1. devede start
  2. VideoDVD generate
  3. When Title 1 click Properties.


  1. devede start
  2. VideoDVD generate
  3. Add File
  4. Button “Next” button.

Could you fix the rpm that it runs gtk + 2.14, or must I
the 2.16er irgendow care?