devede have no idea how to get around this...

ok, I am having a problem with devede, I installed it with yast and when I clicked on the program in the program menu nothing would happen.

I opened a terminal and tried to run it from there and it said:
> devede
Traceback (most recent call last):
File “/usr/bin/devede”, line 25, in ?
import pygtk # for testing GTK version number
ImportError: No module named pygtk

then, I downloaded a tarball and decompressed it and ran python install and I got this
/devede-3.11> python install
Traceback (most recent call last):
File “”, line 25, in ?
import pygtk # for testing GTK version number
ImportError: No module named pygtk

after doing that about 800 times I accidentally hit tab twice after typing python and saw this:

/devede-3.11> python
python python2.6 python3.0-config
python2 python2.6-config python-config
python2.4 python3.0 pythonpoint

I installed some python versions to try and get hellanzb working right which I sort of did, it works but with a few errors that don’t matter I guess…anyway.

Having only used linux maybe a week I didn’t know what to do so I just typed python2.6 install and to my amazement the program started to run but it didn’t install I don’t think? it just ran from console…

devede-3.11> python2.6 install
DeVeDe 3.11b
Locale: en_US.UTF-8
Using package-installed files GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated,domain=“devede”)
Temp Directory is: /var/tmp
home load: /home/myhome/.devede
linea: video_format:pal

linea: temp_folder:/var/tmp/

linea: multicore:1

Launching program: ‘mplayer’, ‘-identify’, ‘-ao’, ‘null’, ‘-vo’, ‘null’, ‘-frames’, ‘0’, ‘/usr/share/devede/silence.mp3’]

elemento: /usr/bin
Longitud sonido: 39
Cores: 4
Launching program: ‘mplayer’, ‘-identify’, ‘-ao’, ‘null’, ‘-vo’, ‘null’, ‘-frames’, ‘0’, ‘/usr/share/devede/silence.mp3’]

elemento: /usr/bin
Longitud sonido: 39
Calculating size for disk :dvd
Calculating size for disk :dvd

The program gui came up and asked me what kind of dvd I wanted to make I clicked video DVD or something like that and the program works perfectly fine as far as I can tell if I start it that weird way.

I don’t have a clue why this works, but is this enough info for someone who knows what they’re doing to help me fully install from tarball or help me get the one already installed from yast to load?

any help is appreciated

i use devede all the time and have never had that problem you describe
what version of suse you running?
are you useing kde3,kde4,gnome? or other?
did you do a search with yast for pygtk?

thanks for the reply, I’m using opensuse 11.1 gnome
I tried installing pygtk with yast but it’s already installed and I reinstalled it and uninstalled and reinstalled it with no luck.

I think it’s trying to use the wrong version or python but I don’t know how to make it use the right one. When I type python2.6 install the devede program actually runs from the terminal but if I click the icon in applications it gets that error or when I just type devede in terminal it gets that error.

thats odd im running python 2.6 also but im running kde4.2
do you have kde3 or 4 installed?
if not try that cause i haven’t ever tryed it in gnome