desktop when I boot it is fast and responsive, after one day staying on is slow and laggy

my pc desktop: CPU (Processor):Intel Core i5-7400 4x3.00GHz 7th Kaby Lake, Mainboard:B250M MSI Pro-VDH (7A70-003R), Video Card (VGA Card) onBoard Graphic, System Memory (RAM):8GB Kingston DDR4-2400, SSD:240GB Western Digital WD Green M.2
running leap 42.3 with KDE when I boot it is fast and responsive, after one day staying on and with no operations by a user it becames slow and laggy, mouse is slow, selection is slow ecc, only reboot solve, and after reboot it start again to be responsive. I think 8Gb is ok, could it be the SSD managing by leap42.3??
I can I solve this problem??
many thanks, :slight_smile: ciao

and have you looked at cpu usage and memory allocation?

something like top??

here is top: in a slow situation

Tasks: 218 total,   2 running, 216 sleeping,   0 stopped,   0 zombie
%Cpu(s): 26.0 us, 28.9 sy,  0.0 ni, 43.0 id,  0.1 wa,  0.0 hi,  2.0 si,  0.0 st
KiB Mem:   8065988 total,  7928520 used,   137468 free,    78788 buffers
KiB Swap:  2104316 total,   293436 used,  1810880 free.  7084752 cached Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                  
 1953 procuste  20   0 4635296 425188  46028 S 149.7 5.271   1853:33 plasmashell                                              
 1613 root      20   0  313100 106056  16816 R 77.33 1.315 866:57.76 X                                                        
 1252 nscd      20   0 1077040   2724   2284 S 1.667 0.034   3:48.56 nscd                                                     
 2303 procuste  20   0 1623712  64184  28500 S 0.667 0.796  19:56.19 ktorrent                                                 
    3 root      20   0       0      0      0 S 0.333 0.000   0:04.33 ksoftirqd/0                                              
 1937 procuste  20   0 3272192  59916  36116 S 0.333 0.743   7:13.82 kwin_x11                                                 
 2053 procuste  20   0    9856   1948   1672 S 0.333 0.024   2:11.60 ksysguardd                                               
    1 root      20   0  185300   5440   3936 S 0.000 0.067   0:06.66 systemd

not that familiar with top but at the instant plasmashell looks to be high consumer. check any rouge widgets installed you have installed. [ps there used to be a bug in plasmashell whereby any animation in task bar would slow system - e.g. copy file animation] but this has been fixed ages ago though leap i suppose is on old version.

Do you use modesetting driver for graphics? I have slowdowns after some time using it on my Broadwell. Slowdowns dissapear after update to latest Xorg/Mesa.

I’ve read some bug reports about plasmashell exhibiting this behavior in some other scenarios too: when a background slideshow changes wallpaper, and with two monitors (I think when you switch monitors or something like that).

manythanks guys, I will try first to remove slideshow (and I have only one monitor :slight_smile: )

If the slideshow wallpaper is the culprit, which is quite likely, you can apply a patch to “/usr/share/plasma/wallpapers/org.kde.slideshow/contents/ui/main.qml” as outlined in this bug report:

it seems that the slideshow isn’t the culprit, I set wallpaper as a single color and rebooted but after 1day the slow mouse and lag exist again
I’ll try to apply the patch anyway… :slight_smile:

If changing to a static image made no difference then I doubt applying that patch will help, although you’ve nothing to lose by trying. :slight_smile:

There’s a generic bug report for high CPU utilisation: … all rather vague, but there may be something of relevance in amongst it.

As a temporary “fix” you could periodically restart plasma shell, that will probably restore things for a while without the need for a complete re-boot.

Use Alt-F2 and enter the command:

kquitapp5 plasmashell && kstart plasmashell

First create a new user, login as that user ans see if the issue exists for that user. If not, the issue is in your homedir

I had similar issues on 42.3 with latest KDE from

I changed Compositor settings to xRender and it does not become slaggy to soon. Unfortunately it is a work pc so I reboot it every night (logging off also works) and do not have time to troubleshoot.

It is annoying either way…

ps I have two monitors

manythanks, as “temporary fix” it works lol!

Manythanks, It seems you are right Knurpht !!!
with a new user after e couple of days the lag and slow disappear!!
…what do you suggest to reset my culprit homedir as if I was a new user without losing all other settings and passwords??

Whether you’re using your PC to get work done or have fun, a slow computer can make life way more frustrating than it needs to be. Laggy performance speed can render your computer pretty much useless – especially when you can barely open a window, load a website or even start up your system.

If you’ve been suffering lately, now’s the perfect time to take a few minutes to go through some of the tried-and-true troubleshooting steps. You can make it so much easier to use your PC. You can give yourself a temporary reprieve from saying bad things about your computer under your breath. Better yet, you can do all of it for free. Apart form this if you want to learn something new then Aws Devops Course is prepared for beginners who want to learn how Amazon Web Services works to provide reliable, flexible, and cost-effective cloud computing services.