Desktop very laggy and/or unusable

The system is almost unresponsive on startup. If it is somewhat responsive, the frame rate is extremely low. Mouse movement is jittery, and if anything is trying to update at a high framerate, the system locks up (except for TTYs, which seem to work fine)


  • Using a Huawei Matebook X
  • The integrated graphics is Inter Alder Lake-P

Using KDE Plasma, experiencing this issue on:

  • Greeter
  • X11
  • Wayland
  • Also experienced this on the installation process

Some things I figured out:

  • nomodeset has no issues, but also the integrated graphics stops being used
  • Installing the xf86-video-intel package causes instant freezing and doesn’t help

On GRUB boot screen, before countdown reaches 0, press “E” and try this parameters (first alone each and as last resort, both).

acpi=off (Disable ACPI support)
noapic ( No logical APIC)

To know how to edit and try those (session only) changes, look at

Execute this two commands and paste the result here:

$ inxi -Gxx
$ xrandr --listproviders

Install inxi if necessary.

Can’t do xrandr due to the desktop environment being unusable.

  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Huawei driver: i915 v: kernel
    arch: Gen-12.2 ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0
    chip-ID: 8086:46a6
  Device-2: Luxvisions Innotech USB Camera type: USB driver: uvcvideo bus-ID: 2-7:3
    chip-ID: 30c9:0041
  Display: x11 server: v: with: Xwayland v: 22.1.8 compositor: kwin_wayland
    driver: X: loaded: modesetting unloaded: fbdev,vesa alternate: intel dri: iris gpu: i915
    tty: 260x94
  Monitor-1: eDP-1 model-id: TMX 0x1422 res: 3120x2080 dpi: 264 diag: 361mm (14.2")
  API: OpenGL Message: GL data unavailable in console for root.

acpi=off: hangs (tried 3 times, once with recovery mode which hangs on “UEFI Secure Boot is enabled”, twice normal)
noapic: nothing different
both: with recovery mode, hangs on “UEFI Secure Boot is enabled”

You are running a wayland compositor / Xwayland. Can you select X11 as the session to start when you login?

I saw that too. For sure he forgot to select again Xorg after trying to see if Wayland resolved his issue.

Show us output of cat /proc/cmdline (without “nomodeset”) and meanwhile we try to see more options, you can do sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old and reboot.

the reason I can’t do xrandr is that the system locks up going into X11, so my only option is a TTY

BOOT_IMAGE=/boot/vmlinuz-6.2.2-1-default root=/dev/mapper/system-root splash=silent resume=/dev/system/swap mitigations=auto quiet security=apparmor

that file doesn’t exist.
also, this issue is the same on Wayland and on the greeter when it doesn’t lock up for a few seconds.

Well, nothing strange in that line. I had a similar issue some years ago, with a DELL PC. I tried these options in this order, till one of them solved my issue:
• pci=routeirq → Do IRQ routing for all PCI devices. This is normally done in pci_enable-device(), and is a temporary workaround for broken drivers which don’t call it.
• pci=noacpi → Do not use ACPI for IRQ routing or PCI scanning.
• acpi=off → Completely disable ACPI support (you tried this yet)
• irqpoll → This may be a work around for an “irqXX: nobody cared . . .” error, which basically means the interrupt has not been handled by any driver. This boot option will make the kernel poll for interrupts, in order to try to work around this issue. However, this does not help diagnose the root cause, nor should it be a permanent fix.
• noapic → Don’t use I/O APICs present in the system (you tried this yet)
• pci=biosirq → Use PCI BIOS calls to retrieve the IRQ routing table

We should check too output from these commands while DESKTOP is running (so log in Plasma and let it stuttering and then “Ctrl + Alt + F1” to change to real console. Then, execute
sudo dmesg -T --color=always --level alert,crit,err,warn | more


tail -f /var/log/Xorg.0.log | xargs -IL date +"%Y%m%d_%H%M%S:L"

And more questions:

  • Does it happen only when you are interacting with desktop (moving mouse pointer or using keyboard) or it happens always periodically?
  • Can play a video and it happens while video is playing too?
  • Does it happen only when you are interacting with desktop (moving mouse pointer or using keyboard) or it happens always periodically?

Yes. If the screen is updating then it starts stuttering

  • Can play a video and it happens while video is playing too?

Can’t test. Tested sl though before this and it made the desktop freeze until it ended

I’m thinking something is causing the refresh rate to drop

  • pci=routeirq → freezes at the login/bulb screen, can’t access TTY
  • pci=noacpi → doesn’t boot, hangs on UEFI Secure Boot is enabled
  • acpi=off → doesn’t boot, hangs on UEFI Secure Boot is enabled (already tried)
  • irqpoll → doesn’t boot, hangs on “Welcome to openSUSE Tumbleweed!”, flashing caps lock
  • noapic → no difference, will need to send output (already tried)
  • pci=biosirq → no change, PCI: Unknown option ‘biosirq’, pastes

Only a shot into the dark: The Matebook X has some fancy key-combos. Did you check them? Not that some manufacturer special stuff interferes here…

Performancemode (Hotkeys: Fn + P)

Switch refresh rate (Hotkey: Fn + R)

not helpful… I feel like the integrated graphics probably aren’t used

Can you log in over network in this case? Without at least kernel log it is rather hard to guess what happens.

Users many times think system is locked when only desktop GUI is really locked, it’s a typical error. I bet this is such case. I asked you about output from two commands and I’m not able to see your answer about here, maybe you were not able to access console. You should try:

  • On login screen or when logged, Ctrl + Alt + F1 to get access to console.
  • If that doesn’t work, press “Caps lock” key and see if the LED light of that key in your keyboard switch on and off each time you press it. Usually, if that light responds, means you could access to your system thru SSH to get information (if you enabled previously SSH server).

Before trying all I wrote you, try this adding this argument to your boot line:

1 Like
  1. I need to manually connect it to Wi-Fi after startup
  2. When I said it locked up on the login screen, I couldn’t enter the TTY either.