Desktop cursor

How to set the desktop cursor? Changes via systemsettings seem to affect only application cursors, not desktop.

What desktop manager are you using ?
Gnonme ?
or other ?

KDE. (Why won’t forum support a 3-character reply?)

I assume that belongs to the anti-spam, anti-bot and the like precautions.

And of course you would not have needed a three character answer at all when you would have said something like:

Sorry for forgetting that most important information, I use KDE.


In kde, start “system settings”. In system settings search box, search for “cursors”. Select “cursors” from the listed choices. In my kde there are 16 choices of cursor sets.

tom kosvic

Thanks for your suggestion. But as stated in my original post, cursors selected in systemsettings apply to the cursors used in applications. Using stemsettings as you suggest has no effect on the cursor shown on the desktop.


I am sure you are seeing something of that kind (else you would not ask), but I do not see that. The cursor is the when it is on the background of the desktop as it is inside application windows. Exception to this is a pure character application like Konsole, where it shows as a character cursor.

I must add that I use 15.3, so maybe in 15.4 it is different.

Nope. Size of the cursor on the desktop depends:

  1. on the background always same size, on menu bar and icons size is determined by systemsettings
  2. when context menu is opened size everywhere is determined by systemsettings

Running “kquitapp5 plasmashell; kstart5 plasmashell” changes background size.

Thank you, that solves the problem. Would be nice if systemsettings provided this option in an obvious way!