Desktop Cube Animation setup

I’m having a hard time setting up the desktop cube. (Leap / Plasma 5.8.6)

I saw a demo at some point where during the switch between desktops, you could see a hollow cube which rotated horizontally between 3 or 4 desktops, and it looked really good.

But in system settings setup there are only options for setting up number of rows, not sides. And it flips vertically (with 2 desktops). How does one setup 3 or 4 desktops which one switches right and left?

Adding a third seems to have a sideways flip, but it happens too quickly to be sure. What’s a good recommended setting for duration? And is there still a way to see the whole cube in the animation of the switch?

The demo I saw looked beautiful. Any links to setup help would be great. I’m not finding much on my own…

Configure desktop - Desktop Behavior - Virtual desk tops increase to 4 then Desktop effects to configure the cube or cylinder . Use edges to set hot spots if wanted

Actually you can use any number of desktops, from 2 on. With 2 you get a flat two-sided rectangle, with three a triangular prism, with 4 a “cube” (actually a square cuboid), etc.

More esoteric yet are the cylinder and sphere formats. It’s worth experimenting with. There are also settings for speed, background and top/bottom image, at least in oS 13.2.

One capability lost since Leap is showing different desktop wallpapers in the cube, as different widgets per desktop is not supported anymore - the wallpaper changer hack for Leap shows the current desktop wallpaper on all cube faces.

Still, it’s a “wow” factor for windows users seeing it for the first time :slight_smile:

I haven’t seen cylinder / sphere settings in KDE / Plasma. Where can I find them?

Shame about the wallpaper, that was actually pretty important to me.

As well, what I’d like to see is the cube from a farther distance away. Currently, it’s as if the cube rotates through the camera, if you understand what I mean. The demo I saw was smaller, between 1/2 and 2/3 of the screen. And yes, it was a ‘wow,’ impression.

The look of the desktop is very important to me.

There’s also a zoom setting. Here’s a link to a screenshot of my desktop (2 monitors), with background and bottom reflection. It could do with a bit of zooming out for show-off purposes…

http://susepaste.org/71145644

Here in oS 12.3: system-settings > Desktop Effects > All Effects > roll down to Desktop Cube, click the setting button (a spanner icon). This gives me two config windows:

SUSE Paste

QUOTE=dcnblues;2827344]The look of the desktop is very important to me.[/QUOTE]

Yes, I like my bling too, as long as it doesn’t interfere with workflow.

Yes, I like my bling too, as long as it doesn’t interfere with workflow.[/QUOTE]

openSUSE 12.3 is a completely different beast than Leap. You’re talking about KDE4, Leap is about KDE Plasma 5.

I’m aware of that, as I’ve noted it on two of the posts above. I haven’t fiddled much with KDE5 yet.

I thought that even if my posts refer to oS 13.2 the may be of help to the OP. Or should I keep mum?

Oh, and I just looked at a Leap 42.1 install I have here, and guess what: it has pretty much the same options the OP asked for.

Of course, before someone jumps in to state the obvious, this is on Leap 42.1 Plasma 5.5.5 Qt 5.5.1 kernel 4.1.39-56-default. Leap 42.2 behavior may be different.

Works fine here 42.2 as I mentioned all the areas needed to configure in my previous post.

Only diff I can see from previous in the settings are no longer a wrench but what looks to be a stylized control panel. But that may have to do with selected theme??? Any way easy to figure out

For sphere and cylinder you can set your own hot keys or use the screen edge hot spots to call them up

Yeah, I found the setup locations, thank you. It’s just that they are not working.

I’m having a panels issue in this thread https://forums.opensuse.org/showthread.php/525541-hidden-buried-panel?p=2827450#post2827450 and my best guess is that it’s preventing the settings changes from taking effect.

To be clear, specifically, the zoom and background color adjustments have zero effect.

Zoom works here you do have to apply the change before it takes effect. Never played with back ground color but the wall paper option works fine. Just check color also works fine. Just be sure you hit the apply button before testing

Okay, CTRL F11 is now getting a cube which I can grab and rotate, and the zoom out seems to work. But the switching between desktops seems unrelated to this, and is unchanged. Also, I forgot to mention I have a dual monitor setup (I don’t know if this is a factor).

So Ctrl F11 gets a static cube in the middle of the dual monitors. However, all my hotkeys for switching between desktops show the old cube animation (not zoomed out) duplicated on each screen. Very much as if they are two different processes.

Maybe

Rotate to the desk you want and right click to change. You can also set the desktop switch using the pager on the panel (if installed) to do so by cube rotation animation.

Thank you for the help. I am slowly figuring it out.

It’s a shame that in the system settings / workspace / desktop behavior / virtual desktops / switching tab / window you have two options neither of which are quite right:

-In the shortcuts / action options, most of the actions have the duration of the switch customizable, and it’s nice to tune it just right. However, they don’t seem to use the other settings for customizing your cube animation (zoom in particular).

-‘walk through desktop list’ seems to be the only one that lets you set up and customize the look of the animation (I can manipulate the zoom, and see the reflections and the logo on the top and bottom of cube), but the transition happens fairly instantly upon pressing your hotkey, and you don’t really get to see the cube animation.