Desktop cannot find music CD

Using SuSE 11.1. When inserting a program CD, Dolphin automatically opens the file. When inserting a music CD, Dolphin doesn’t see the file. Hence, Amarok, KsCD and other programs are unable to play a music CD. Any help would be appreciated.

There was an old post that suggested modifying the user account by adding cdrom and disk groups, using YaST. I tried, and it didn’t work.

CDs with programs still automatically pop up with Dolphin. CDs with music cannot be accessed with Dolphin, My Computer, Amarok, etc.

I’ve just tested Dolphin (KDE4.2.3) with audio CD. I get an xmms_audio_cd entry added. Of course there is not a browsable file system as such, so I don’t see any files as such. Using Amarok, I can select

Engage -> Play Audio CD

After the playlist is populated, I can then select the track I wish to play.

I also have:

dean@linux:~> ls -l /dev/cdrom
lrwxrwxrwx 1 root root 3 2009-05-13 07:37 /dev/cdrom -> sr0

There is something weired and strange about the way SUSE handles audio CD’s now. To be honest it kind of sucks. But then again, I never play music from a CD anyway, but rip it and add it to MyMusic.
I tried KsCD and it picks up any audio cd and will play it no problem.

There is something weired and strange about the way SUSE handles audio CD’s now. To be honest it kind of sucks.

It looks as if audio CD handling is unimplemented presently, but hopefully this will be corrected in future KDE4 versions. I note that if I use konqueror (4.2.2), the audiocd:/ KIO slave works ok and I can navigate an audio CD without any problems.

I wonder if any notification widgets for audio cds are available yet? Anyone able to offer info on this?

If its any consolation though, lots of similar threads from many distros using KDE4.X…

No notifications upon audio CD insert - Page 1

[kde] Issues with Audio CD on KDE4 (Intepid) [Archive] - Ubuntu Forums](

I’ve just been playing around with Dolphin. Up until now, I didn’t realise there was a loaction bar available. (Pressing CTRL-L brings this up). Entering ‘audiocd:/’ worked fine, and I can now see the audio CD contents (in several different formats), and play from there.

Thanks for the help. This is curious.
Using Dolphin KDE 4.2.2: audocd:/ listed the tracks, and did not allow any moves or copy. Clicking on the oog files started Amarok, and did not play.
The KsCD was able to list the tracks in the audio CD, and unable to play the tracks.

I installed SuSE 11.1 retooled with KDE4.2 on a laptop, with similar results.

Lets hope this gets fixed in KDE4.3.

I suggest you try k3b to rip the audio

Make sure VLC repo (if you have it) is disabled and do unconditional update in Packman
Also check
Multi-media and Restricted Format Installation Guide - openSUSE Forums