Dell XPS 13 (9360): Backlight (brightness) not adjustable

Hi,

I’ve just installed Leap 42.2 on a new XPS 13 (model 9360), all working fine, except screen backlight / brightness is not working when pressing F11/F12. I did some investigation and found:

  • out-of-the-box install, there’s nothing in /sys/class/backlight
  • unless I add acpi_backlight=vendor as kernel parameter, then there’s /sys/class/backlight/dell_backlight/ and the relevant files. In this case, the screen brightness logo appears when pressing F11/F12, the files in /sys/class/backlight/dell_backlight get changed with other values, but the actual screen brightness does not change
  • if on top of that I add acpi_osi=Linux, then initially brightness actually adjusts, but laptop crashes (really locks itself).

So no luck so far to get this working. I suspect kernel/driver compatibilty. On a sidenote: the laptop came installed with Ubuntu 16.04 (this is an option at Dell for this laptop), but I didn’t like it much, although backlight was working on this distribution, so there seems to be a workaround. Any suggestions I could try further?

Please let me know if you need more info.

A starting point:


uname -r
4.4.36-8-default


sudo hwinfo --gfxcard
08: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.378]
  Unique ID: _Znp.ui44m+Vs3s8
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Device Name: "Onboard IGD"
  Model: "Intel VGA compatible controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x5916 
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x075b 
  Revision: 0x02
  Memory Range: 0xdb000000-0xdbffffff (rw,non-prefetchable)
  Memory Range: 0x90000000-0x9fffffff (ro,non-prefetchable)
  I/O Ports: 0xf000-0xf03f (rw)
  IRQ: 11 (no events)
  Module Alias: "pci:v00008086d00005916sv00001028sd0000075Bbc03sc00i00"
  Config Status: cfg=no, avail=yes, need=no, active=unknown

Primary display adapter: #8

Update from my part.
Two links on the subject here:

  1. https://wiki.ubuntu.com/Kernel/Debugging/Backlight
  2. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1007765

Adding

acpi_osi=

as kernel parameter also works some time, but still crashes my system. In that case, there’s no /sys/class/backlight/… directories. However, doing

echo 0 >/proc/sys/kernel/nmi_watchdog

as well, seems to give better results (some brief freezes from time to time).

Reading the posts mentioned above, it looks like this is a vendor specific issue, but wonder how to get this fix (as far as it is stable enough) back into a working solution for XPS users in OpenSuse.

Hi, you apparently run a KabyLake fresh out of the press… (pci 0x8086:0x5916).
While "acpi_osi= " should fix the backlight problem as in other laptops (including mine), maybe you have a video driver problem.
You might need the “i915.preliminary_hw_support=1” boot parameter on 4.4.x kernels, or try a newer kernel (but with caution, current 4.9.3 kernels might have other issues…).

Thanks for the suggestion. Tried it, no luck though, still crashed without the nmi_watchdog setting. Kernel of the Day did not yield different results. So your suggestion is possible, so it’s possibly not a specific Dell issue, but in the broader sense just new Intel graphics hardware which is used in other brands as well. I guess it’s just a matter of waiting for kernel / drivers to catch up.

I have a similar problem that I have been searching and saving url links. You might try:

https://wiki.archlinux.org/index.php/backlight
which shows a number of different approaches,
and
http://askubuntu.com/questions/471847/brightness-fn-key-shortcut-doesnt-work-on-asus-laptop
also has some good info, near the bottom of that page is a post on openSUSE that shows promise ( which I am going to try)
and the one following too!

Google “Arch backlight” there is a wealth of info.

Good luck!

Here is some good reading on the subject IMHO:

http://hansdegoede.livejournal.com/13889.html

I am on my iPad & could not paste that URL in the URL tool.

Since I have a solution that works - see above, I’m sticking to that right now. Feel free to report on your progress finding another one ;). Main thing is actually that Dell has a working solution in Ubuntu that works better; I guess this is done by a newer driver.

For what it is worth, with my Asus laptop:
in the SysTray click on Power
on the right of “Enable Power Management”, click on the small context icon
then, energy saving or screen brightness
I had a backlight slider and a “dim” button
Turn that “Dim” button off & check your Fn+ Bright up/down keys
if they are working, save/apply out of that & logout/in to save the config

Works on reboot for me.

Good that you also found a solution for your Asus! Sound less invasive than mine. For me though, your solution did not work as I don’t have the “Enable Power Management” / brightness configuration. My guess is you’re on KDE insted of Gnome3.

Other suggestions still welcome :slight_smile: