Dell XPA 15 9569: Gnome ALT + CTLR + F keys do nothing (no switch to console)


after solving some problems i managed to install the current opensuse Tumbleweed snapshot on my new Dell XPS 15 laptop. I am using Gnome as GUI. But i noticed that i cannot switch to a console when using Gnome via pressing ALT + CNTRL + F1 or any other of the F keys.

Maybe this is related to the fact that the Fn keys have a second function when pressing or locking the Fn key/mode, also there is a BIOS option to reverse the Fn-mode. But i tested all options an nothing works.

Maybe the dell_wmi module isn’t running?

lsmod |grep dell

Do the brightness etc keys work?

I did not tested the brightness keys but the volume controls and mute where working. And before login switching via ALT + CNTRL + Fn works also. Jest when logged into gnome it is not working anymore! It is not even working with a pluged in a full size external usb keyboard!

The problem is still there but i noticed that after a reinstall the keys work, but after a reboot they do not work anymore. Maybe this changes every reboot?
I also noticed that the right click is also not working, maybe this is related?

Anyway, this is the output of lsmod | grep dell

dell_wmi               16384  0
dell_laptop            24576  0
dell_smbios_wmi        16384  0
dell_smbios_smm        16384  0
dell_smbios            16384  4 dell_wmi,dell_laptop,dell_smbios_wmi,dell_smbios_smm
dcdbas                 16384  1 dell_smbios_smm
rfkill                 28672  9 bluetooth,dell_laptop,cfg80211
dell_smm_hwmon         16384  0
dell_wmi_descriptor    16384  2 dell_wmi,dell_smbios_wmi
sparse_keymap          16384  2 dell_wmi,intel_hid
wmi                    28672  7 dell_wmi,wmi_bmof,intel_wmi_thunderbolt,dell_wmi_descriptor,mxm_wmi,nouveau,dell_smbios_wmi
video                  45056  4 dell_wmi,dell_laptop,nouveau,i915

I would guess it’s somehow related to the dual graphics setup… worthy of a bug report…
openSUSE:Submitting bug reports - openSUSE

Could be, currently it works again, i just removed the “nomodeset” kernel parameter (but kept “nouveau.modeset=0”) maybe that was the solution. I will see what happens the next reboots, because right after installation the keys worked too, but “nomodeset” was used also.