DELL Latitude D620 (NVS110M )install Nvidia G02 drivers and black screen

Dell D620 T2300 3G NVS110M(Geforce 7300) ;
I installed G02 Nvidia x11 after reboot , into command line screen :“login name:”.
I have tried “startx” failed,
Xorg -configure failed too,
and
cp the xorg.conf.install xorg.conf can’t use the nvidia driver.

Below is my log file(I removed the xorg.conf):

1318.779]
X.Org X Server 1.10.4
Release Date: 2011-08-19
1318.779] X Protocol Version 11, Revision 0
1318.779] Build Operating System: openSUSE SUSE LINUX
1318.779] Current Operating System: Linux linux-iotp.site 3.1.0-1.2-desktop #1 SMP PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) i686
1318.779] Kernel command line: root=/dev/disk/by-id/ata-WDC_WD5000BPVT-00HXZT1_WD-WXM1E60VJ018-part1 resume=/dev/disk/by-id/ata-WDC_WD5000BPVT-00HXZT1_WD-WXM1E60VJ018-part5 splash=silent quiet vga=0x317
1318.779] Build Date: 10 November 2011 03:34:02PM
1318.779]
1318.779] Current version of pixman: 0.22.0
1318.779] Before reporting problems, check X.Org Wiki - Home
to make sure that you have the latest version.
1318.779] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
1318.780] (==) Log file: “/var/log/Xorg.0.log”, Time: Wed Dec 14 20:33:08 2011
1318.780] (==) Using config directory: “/etc/X11/xorg.conf.d”
1318.780] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
1318.781] (==) No Layout section. Using the first Screen section.
1318.781] (==) No screen section available. Using defaults.
1318.781] (
) |–>Screen “Default Screen Section” (0)
1318.781] (**) | |–>Monitor “<default monitor>”
1318.781] (==) No monitor specified for screen “Default Screen Section”.
Using a default monitor configuration.
1318.781] (==) Automatically adding devices
1318.781] (==) Automatically enabling devices
1318.781] (==) FontPath set to:
/usr/share/fonts/misc:unscaled,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/URW/,
/usr/share/fonts/cyrillic:unscaled,
/usr/share/fonts/truetype/,
built-ins
1318.781] (==) ModulePath set to “/usr/lib/xorg/modules/updates,/usr/lib/xorg/modules”
1318.781] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
1318.781] (II) Loader magic: 0x8233d40
1318.782] (II) Module ABI versions:
1318.782] X.Org ANSI C Emulation: 0.4
1318.782] X.Org Video Driver: 10.0
1318.782] X.Org XInput driver : 12.2
1318.782] X.Org Server Extension : 5.0
1318.783] (–) PCI:*(0:1:0:0) 10de:01d7:1028:01c2 rev 161, Mem @ 0xed000000/16777216, 0xd0000000/268435456, 0xee000000/16777216, BIOS @ 0x???/131072
1318.783] (II) Open ACPI successful (/var/run/acpid.socket)
1318.783] (II) LoadModule: “extmod”
1318.784] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
1318.784] (II) Module extmod: vendor=“X.Org Foundation”
1318.784] compiled for 1.10.4, module version = 1.0.0
1318.784] Module class: X.Org Server Extension
1318.785] ABI class: X.Org Server Extension, version 5.0
1318.785] (II) Loading extension MIT-SCREEN-SAVER
1318.785] (II) Loading extension XFree86-VidModeExtension
1318.785] (II) Loading extension XFree86-DGA
1318.785] (II) Loading extension DPMS
1318.785] (II) Loading extension XVideo
1318.785] (II) Loading extension XVideo-MotionCompensation
1318.785] (II) Loading extension X-Resource
1318.785] (II) LoadModule: “dbe”
1318.785] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
1318.785] (II) Module dbe: vendor=“X.Org Foundation”
1318.785] compiled for 1.10.4, module version = 1.0.0
1318.785] Module class: X.Org Server Extension
1318.785] ABI class: X.Org Server Extension, version 5.0
1318.785] (II) Loading extension DOUBLE-BUFFER
1318.786] (II) LoadModule: “glx”
1318.786] (II) Loading /usr/lib/xorg/modules/updates/extensions/libglx.so
1318.833] (II) Module glx: vendor=“NVIDIA Corporation”
1318.833] compiled for 4.0.2, module version = 1.0.0
1318.833] Module class: X.Org Server Extension
1318.833] (II) NVIDIA GLX Module 290.10 Wed Nov 16 19:49:02 PST 2011
1318.833] (II) Loading extension GLX
1318.833] (II) LoadModule: “record”
1318.834] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
1318.834] (II) Module record: vendor=“X.Org Foundation”
1318.834] compiled for 1.10.4, module version = 1.13.0
1318.834] Module class: X.Org Server Extension
1318.834] ABI class: X.Org Server Extension, version 5.0
1318.834] (II) Loading extension RECORD
1318.834] (II) LoadModule: “dri”
1318.835] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
1318.835] (II) Module dri: vendor=“X.Org Foundation”
1318.835] compiled for 1.10.4, module version = 1.0.0
1318.835] ABI class: X.Org Server Extension, version 5.0
1318.835] (II) Loading extension XFree86-DRI
1318.835] (II) LoadModule: “dri2”
1318.836] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
1318.836] (II) Module dri2: vendor=“X.Org Foundation”
1318.836] compiled for 1.10.4, module version = 1.2.0
1318.836] ABI class: X.Org Server Extension, version 5.0
1318.836] (II) Loading extension DRI2
1318.836] (==) Matched nvidia as autoconfigured driver 0
1318.836] (==) Matched nouveau as autoconfigured driver 1
1318.836] (==) Matched nv as autoconfigured driver 2
1318.836] (==) Matched fbdev as autoconfigured driver 3
1318.836] (==) Matched vesa as autoconfigured driver 4
1318.836] (==) Assigned the driver to the xf86ConfigLayout
1318.836] (II) LoadModule: “nvidia”
1318.836] (II) Loading /usr/lib/xorg/modules/updates/drivers/nvidia_drv.so
1318.837] (II) Module nvidia: vendor=“NVIDIA Corporation”
1318.837] compiled for 4.0.2, module version = 1.0.0
1318.837] Module class: X.Org Video Driver
1318.837] (II) LoadModule: “nouveau”
1318.838] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
1318.838] (II) Module nouveau: vendor=“X.Org Foundation”
1318.838] compiled for 1.10.4, module version = 0.0.16
1318.839] Module class: X.Org Video Driver
1318.839] ABI class: X.Org Video Driver, version 10.0
1318.839] (II) LoadModule: “nv”
1318.839] (II) Loading /usr/lib/xorg/modules/drivers/nv_drv.so
1318.839] (II) Module nv: vendor=“X.Org Foundation”
1318.839] compiled for 1.10.4, module version = 2.1.18
1318.839] Module class: X.Org Video Driver
1318.839] ABI class: X.Org Video Driver, version 10.0
1318.839] (II) LoadModule: “fbdev”
1318.840] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
1318.840] (II) Module fbdev: vendor=“X.Org Foundation”
1318.840] compiled for 1.10.4, module version = 0.4.2
1318.840] ABI class: X.Org Video Driver, version 10.0
1318.840] (II) LoadModule: “vesa”
1318.841] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
1318.841] (II) Module vesa: vendor=“X.Org Foundation”
1318.841] compiled for 1.10.4, module version = 2.3.0
1318.841] Module class: X.Org Video Driver
1318.841] ABI class: X.Org Video Driver, version 10.0
1318.841] (II) NVIDIA dlloader X Driver 290.10 Wed Nov 16 19:29:07 PST 2011
1318.841] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
1318.841] (II) NOUVEAU driver
1318.841] (II) NOUVEAU driver for NVIDIA chipset families :
1318.841] RIVA TNT (NV04)
1318.841] RIVA TNT2 (NV05)
1318.841] GeForce 256 (NV10)
1318.841] GeForce 2 (NV11, NV15)
1318.841] GeForce 4MX (NV17, NV18)
1318.841] GeForce 3 (NV20)
1318.841] GeForce 4Ti (NV25, NV28)
1318.841] GeForce FX (NV3x)
1318.841] GeForce 6 (NV4x)
1318.841] GeForce 7 (G7x)
1318.841] GeForce 8 (G8x)
1318.841] GeForce GTX 200 (NVA0)
1318.841] GeForce GTX 400 (NVC0)
1318.841] (II) NOUVEAU driver
1318.841] (II) NOUVEAU driver for NVIDIA chipset families :
1318.841] RIVA TNT (NV04)
1318.841] RIVA TNT2 (NV05)
1318.841] GeForce 256 (NV10)
1318.841] GeForce 2 (NV11, NV15)
1318.841] GeForce 4MX (NV17, NV18)
1318.841] GeForce 3 (NV20)
1318.841] GeForce 4Ti (NV25, NV28)
1318.842] GeForce FX (NV3x)
1318.842] GeForce 6 (NV4x)
1318.842] GeForce 7 (G7x)
1318.842] GeForce 8 (G8x)
1318.842] GeForce GTX 200 (NVA0)
1318.842] GeForce GTX 400 (NVC0)
1318.842] (II) FBDEV: driver for framebuffer: fbdev
1318.842] (II) VESA: driver for VESA chipsets: vesa
1318.851] (–) using VT number 2

1318.890] (II) Loading sub module “fb”
1318.890] (II) LoadModule: “fb”
1318.891] (II) Loading /usr/lib/xorg/modules/libfb.so
1318.891] (II) Module fb: vendor=“X.Org Foundation”
1318.891] compiled for 1.10.4, module version = 1.0.0
1318.891] ABI class: X.Org ANSI C Emulation, version 0.4
1318.891] (II) Loading sub module “wfb”
1318.891] (II) LoadModule: “wfb”
1318.892] (II) Loading /usr/lib/xorg/modules/libwfb.so
1318.893] (II) Module wfb: vendor=“X.Org Foundation”
1318.893] compiled for 1.10.4, module version = 1.0.0
1318.893] ABI class: X.Org ANSI C Emulation, version 0.4
1318.893] (II) Loading sub module “ramdac”
1318.893] (II) LoadModule: “ramdac”
1318.893] (II) Module “ramdac” already built-in
1318.893] (II) Loading /usr/lib/xorg/modules/updates/drivers/nvidia_drv.so
1318.893] (II) Loading /usr/lib/xorg/modules/libwfb.so
1318.893] (II) Loading /usr/lib/xorg/modules/libfb.so
1318.893] (WW) Falling back to old probe method for fbdev
1318.893] (II) Loading sub module “fbdevhw”
1318.893] (II) LoadModule: “fbdevhw”
1318.894] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
1318.894] (II) Module fbdevhw: vendor=“X.Org Foundation”
1318.894] compiled for 1.10.4, module version = 0.0.2
1318.894] ABI class: X.Org Video Driver, version 10.0
1318.894] (WW) Falling back to old probe method for vesa
1318.894] (II) NVIDIA(0): Creating default Display subsection in Screen section
“Default Screen Section” for depth/fbbpp 24/32
1318.894] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
1318.894] (==) NVIDIA(0): RGB weight 888
1318.894] (==) NVIDIA(0): Default visual is TrueColor
1318.894] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
1318.895] (**) NVIDIA(0): Enabling 2D acceleration
1320.249] (EE) NVIDIA(0): Failed to get supported display device(s)
1320.271] (WW) NVIDIA(GPU-0): Failed to query OR info 0x24
1320.273] (II) NVIDIA(0): NVIDIA GPU GeForce Go 7300 (G72) at PCI:1:0:0 (GPU-0)
1320.273] (–) NVIDIA(0): Memory: 262144 kBytes
1320.273] (–) NVIDIA(0): VideoBIOS: 05.72.22.21.fc
1320.273] (II) NVIDIA(0): Detected PCI Express Link width: 16X
1320.273] (–) NVIDIA(0): Interlaced video modes are supported on this GPU
1320.273] (–) NVIDIA(0): Connected display device(s) on GeForce Go 7300 at PCI:1:0:0
1320.273] (–) NVIDIA(0): none
1320.274] (EE) NVIDIA(0): No display devices found for this X screen.
1320.564] (II) UnloadModule: “nvidia”
1320.564] (II) Unloading nvidia
1320.564] (II) UnloadModule: “wfb”
1320.564] (II) Unloading wfb
1320.564] (II) UnloadModule: “fb”
1320.564] (II) Unloading fb
1320.564] (EE) Screen(s) found, but none have a usable configuration.
1320.564]
Fatal server error:
1320.564] no screens found
1320.564]
Please consult the The X.Org Foundation support
at X.Org Wiki - Home
for help.
1320.564] Please also check the log file at “/var/log/Xorg.0.log” for additional information.
1320.565]

And I installed the openSUSE 12.1 met the problem

I had a similar issue, and I installed the G01 driver and it worked for me. D820 w/ Nvidia card.

You might try and see if that works for you too…

Thanks, I have install the Nvidia driver manully, but not the 290.10 edition, I tried form the latest edition 290.10;285;280; until 275.43 it worked. Maybe the 290.10 doesn’t support the old way to configure the graphic card.