Dell Latitude 3500 Dual Boot

Hello, Suse Friends! Long time, no post. Has anyone had good luck installing OpenSuse on one of these, Dual Boot (I still need Windows for some software for work)?

I just received a new Dell Latitude 3500, i3 processor, 8G of RAM, 1T of hard drive. No DVD drive and according to Dell, no way to install one. I could attach an external drive, but it refuses (as delivered) to boot from any external drive. It has Windows 10 installed.

I note that Dell adds some custom drivers as well, but that’s an aside. (No OpenGL in my Windows 10.)

I think I’m going to try the procedure described here: this guy got Fedora to work on a Windows 10 Dell Inspiron.

Gracias, thanks, hope everyone is doing well here.

I don’t have a Dell Latitude. But the Dell computers that I do have can be booted from a USB (either flash drive or hard drive). I normally hit F12 during boot to get the BIOS boot menu.

First thing I tried. The USB stick doesn’t even appear in the choices. This is some new thing that Dell has recently added to ensure security. Or something like that.

If I figure it out, I’ll post my experience here in detail.

Have you checked through the BIOS? It’s not a 32bit UEFI implementation?

…according to page 24 there is an option to add boot options.

I don’t have that new machines and don’t know the current BIOS options.

I can disable drives completely in the BIOS (older Latitudes), if I want to boot from USB or eSATA (without adding this drive to the grub options after an update)…

When I bought fresh from Dell I never used the install that came with the machine, but formatted and start fresh from the scratch :wink:

I do the same, wipe and start fresh, easy to do with WinX since it’s a free download and if system already activated your good to go (Note for those on Win7, you can download and upgrade still…)

I also note on that page default disk setup is RAID, likely the real issue… wipe, switch to ahci, configure the disk how you want it for dual boot, install WinX, install openSUSE and enjoy :slight_smile:

Hah! I ought not to talk to you until you bring back Grover! :wink:

It’s 64 bit, UEFI boot only, legacy boot “is unavailable on this device.”

The problem is the “secure boot” feature. I’ll have to turn that off. I don’t think this particular Latitude uses the RAID, but I’m gonna re-check that. (The article that I linked to said that was the big problem there.) Secure boot requires that there is actually a signed, secure boot “keyfile” for each accepted method.

Anyway. What’s life without a challenge? Like I said, I’ll post my experience here when I’m done, maybe it’ll help someone else out in the future.

“Adding an option,” in this case, means to add a secure boot keyfile/info.

Dell is apparently serious about you sticking with Windows on this laptop. They don’t make it easy.

True, but before I do that, I need to confirm that I can at least boot onto a USB stick. Remember, this doesn’t have a DVD/CD reader.

I didn’t order this machine, by the way. It was provided by my job.

I used (on old) Dell Precision M notebooks RAID 1 configurations with Win 7 and TW in the past (legacy boot…). But apparently they make it harder to use any (non-MS) OS not installed from the beginning. Although Dell sells selected notebooks and workstations with RHEL preinstalled.

Tonight’s update: I was finally able to create a USB 3.0 stick with Rufus. (This laptop will not even try to read USB 2.0 devices.) The BIOS at least saw it; in the F12-> boot options screen, it magically appeared. YAY! I booted …and got stuck in some kind of weird loop. ACPI errors, then it appeared to restart the init task over and over.

I tried a Safe Mode boot; same thing. Died before it ever got to the desktop.

I wasn’t happy with a couple of errors I got while Rufus was building the Live stick, so I downloaded the full DVD image and burned that with Rufus. Same thing: bootup seems to be working, but then I land in an emergency terminal. I can’t remember the errors now, I’m too tired. (Sorry.)

I’m gonna try some more tomorrow, but here’s what I think. Dell is using some custom drivers and BIOS code. As mentioned above, for example, Intel supplies an excellent driver for the graphics, but Dell is using their own. From what I’ve gathered after lots of googlin’, Dell does some strange things with the BIOS, too. It may be that I’m just out of luck with this particular laptop model.

The final clue for that is this: Dell DOES offer this same laptop, the Latitude 3500, with Ubuntu pre-installed. But Canonical warns that the stock Ubuntu or Kubuntu won’t work on this laptop. You must use Dell’s magic distro, because Dell adds and changes some things.

Given that it’s the holiday, I won’t be contacting Dell until Tuesday. I’ll try a few more things tomorrow.

If it is a graphics issue, try adding “nomodeset” to the boot command line.

If this is UEFI, then hit ‘e’ on the grub menu item (for Installation), and the scroll down to find the line that starts “linuxefi”. Hit the END key to get to the end of the line, then append " nomodeset". Hit CTRL-X to resume booting.

Ubuntu. Aha. No other FOSS would have accepted that? Maybe it’s time to look for a new hardware dealer. Something with Libre/Coreboot, maybe?

Well, don’t ask me why, don’t ask me how, but it installed this morning. I should have been clear: yesterday, the errors I were getting were on the Live CD (iso on a USB stick) and the full DVD install (also USB), but I was selecting the “verify media” option. In the past, I’ve always verified (I once had a bad download burn me for a couple of hours).

Just for kicks this morning, I booted into the full install USB stick and said, “what the heck, let’s try a straight installation.” It worked.

So, to recap:

  1. I have “Secure Boot” turned off in the BIOS. Not sure that’s necessary, but I ain’t touching it.

  2. Build the USB stick with Rufus, select UEFI/GPT.

  3. Just install, hoping that the media is OK. :slight_smile:

  4. You love long time, OpenSuse is happy and yours! So far, everything seems to be working. I have some more config to do, but it’s usable.

Only thing now is, I may take an ice pick to this horrible touchpad and use an external mouse … (just as bad under Windows, it’s not a Suse thing).

I’m a certified touchpad hater. If you are using KDE, then there’s a nice feature to disable the touchpad if a mouse is plugged in.

I’m glad you succeeded in getting openSUSE installed.