dell Latiitude E5520


I recently got a dell E5520 laptop with all the latest and greatest. Firstly, I’d say I’m greatly disappointed with the quality of construction since I had D830 before and I was very happy with it. This one I feel they are cutting corners are ever step of the way, but that’s beside the point here.

I got a Seagate hybrid drive (Seagate-Momentus-7200RPM-Hybrid-ST95005620AS) on the side and 8 GB of ram and installed openSuse 11.4 64bit. At first I was very happy with it, but soon the system started crashing (as in caps lock light not responding), then I realized I was unable to ever shut it down properly. It would always hang before the actual shutdown. I have a side monitor and as I attached it, it crashed continuously. When I kept off the monitor, it kinda ran OK, but when I tried running Virtual Box, I get crashes at every stage of windows boot and if it made it into running state, it would crash after a minute or two.

I updated everything to the latest of course. Now I have Kubuntu 11.04 on it and it seems to be running alright, but it also refuses to shutdown properly, and I’m getting terrible battery life.

This is my work laptop, so I don’t have time to do much trouble shooting with it, but if someone could give me a hint on what to do, I’d like to find out if I can get openSuse on this again. Been using it for 3 years and don’t see myself switching.

Beside these problems, I also had no webcam working, and the touchpad was recognised as a PS/2 mouse, so no scrolling.


I suspect your Dell has an Sandybridge Intel® HD Graphics 2000/3000 (used in 2nd Generation Intel® Core™ i7/i5/i3 processor family), in which case you likely just need to wait until the both the GNU/Linux kernel and Intel driver is stable for the Sandy Bridge graphic hardware. Its been a hit and miss with that driver with various regressions.

Phoronix tend to have a reasonable overall assessment of the state of newer graphic hardware. For example, here is a Phoronix article noting that Sandy Bridge still struggles on Ubuntu-11.04

That article notes that performance poor on the Sandy Bridge the “out of the box” experience with distributions of the time (e.g. Ubuntu 10.10) was poor with 3D acceleration failing, and it was not until:

In early March, though a simple patch dramatically improved the Linux driver’s performance within the Mesa code-base for the yet-to-be-released Mesa 7.11. This patch increased the VS thread count to 60 for Intel “Gen 6” Sandy Bridge hardware. The performance became rather nice with Mesa 7.11-devel and Linux 2.6.38 and was only further enhanced in the Linux 2.6.39 kernel via the LLC caching patch-set.

that patch was NOT in time for openSUSE-11.4 which has the 2.6.37 kernel and an older Mesa version.

Another recent Phoronix article claims Fedora-15 performance may be good with the Sandy Bridge graphic hardware. Note Fedora 15 is using Linux 2.6.38 and Mesa 7.11-devel, with various back-ports by Red Hat’s engineers. The purported downside is that the OpenGL performance for Sandy Bridge on Fedora 15 is not most optimal compared to the latest upstream code (but that is not the fault of Fedora, but rather is simple timing). Purportedly the hope is that with the latest Mesa 7.11 and Linux 2.6.39 kernel the situation will be better.

Unfortunately Phoronix went on to report of a regression in Sandy Bridge in the latest stable 2.6.39 kernel where the Intel graphic driver just regressed hard in their Sandy Bridge support for the Linux 2.6.39 kernel just before it was released (ie between 2.6.39-rc6 and 2.6.39-rc7 and ergo is present in bad shape in the 2.6.39 kernel). The Phornix article notes that the 2.6.39 regression indicated that

the dmesg filled up with i915_hangcheck_ring_idle errors from the Intel DRM driver. This at least signaled it being a kernel problem and also a definite regression since this i915_hangcheck_ring_idle problem was corrected earlier on in the Linux 2.6.39 cycle.
The Mesa 7.11 release (scheduled for around June or July) may help address this, but it may not. If it does address this, then you need to find a GNU/Linux distribution that has this latest fix.

I know you won’t want to hear this, but I think I need to say it: For a work laptop, going with such a relatively new state of the art machine on GNU/Linux is not a good idea. Please no insult intended, its just my private view which is consistent with my experience since I first moved to using GNU/Linux full time at home since 1998.

IMHO you will now need to wait until a distribution (any distribution) is updated in a timely manner after the appropriate upstream graphic fixes are ready for use downstream.

That is a big disappointment to me, but I probably should have expected it. I know from when I installed openSuse 10.2 on my Latitude D830 (intel 965 chipset) that it took months till I had a stable system.

This is an i72620 @ 2.7 GHz. Kubuntu is working good enough to use, but I was really hoping to stay on an rpm based distro. I tried Fedora 15, but maybe my burn was bad as I could not even get a proper live boot.

Thanks for your detailed reply.

If its any consolation, I ‘feel for you’. The Sandy Bridge hardware has so much promise, and to see a crippled Linux driver, that only worked briefly in an early RC version of the 2.6.39 kernel (and then had a major regression in the 2.6.39 RC7 kernel version, which remained) MUST be very disappointing and annoyng.

I wish I had a magical solution … but other than to have one’s own copies of the various kernels (which I don’t) and copies of the various Mesa versions (which I don’t have), and then to do a brave and hazardous update/experimentation (which I myself would be reluctant to try/attempt), I don’t have an immediate openSUSE proposal.

openSUSE-12.1 will likely have the 3.0 kernel with the latest Mesa and latest Intel drivers and there is hope that it will solve your problem. But I think we are looking at November for 12.1’s GM version, and likely it won’t be until late September or early October that you will have a stable late-milestone or early Release Candidate version of 12.1 which hopefully will address the Sandy Bridge Intel driver problem.

You could try to ‘influence’ openSUSE to ensure it gets the latest packages for openSUSE-12.1 by burning liveCDs for each of the 12.1 milestone releases, and then write/update bug report(s) on the Sandy Bridge Intel hardware with 12.1. That won’t provide an immediate solution, but it might influence the openSUSE distribution to head in the right direction for your hardware.

You could try Fedora-15 again, and seek help on the Fedora forum. I like Fedora as a distribution (although obviously my preference is for openSUSE).

I wish I could offer more ideas, and maybe someone else with Sandy Bridge hardware who has experienced what you have encountered knows of work arounds.

Again, my sympathy for what must be disappointing and annoying.

Best wishes !

Thanks a lot oldcpu. Help like this is invaluable. I will try and update if I get Fedora working. I have an extra HD I’ll try it on. If successful, I’ll reformat my Kubuntu partition.

I just want to report back some new findings. I still cannot get a boot on Fedora 15, either with live or install. Even get a crash on memtest.

I went to Distrowatch and looked a distro with the most updated kernel - AV Linux (kernel - a debian based distro for audio/video. Smooth boot, and everything seemed to work. Will try install that sometime soon to see how it works installed with VirtualBox and some other programs I need.

Hmmm … thats interesting …

When you get the opportunity over the next few months, you could continue to try the openSUSE-12.1 milestone release live CDs, writing bug reports on these releases (so as to ensure they get the appropriate Mesa and kernel versions).

I note openSUSE-11.4 Tumbleweed has the kernel. One can from a text mode easily update to Tumbleweed (with average openSUSE knowledge). BUT I also note openSUSE-11.4 Tumbleweed ONLY has Mesa-7.10.2-7.3.1 and I do not know if that is ‘new enough’ to address your Sandy Bridge hiccups. My research suggested Mesa 7.11 is needed.

Wrt Mesa-7.10.2-7.3.1, according to it change history the Jan-03-2011 update to Mesa by openSUSE (to pre-7.10 state (git 96685a6)) was supposed to address two screen saver GPU crashes on SandbyBridge, … but I think there are more problems still wrt Sandy Bridge and Mesa-7.11 is needed. I would be curious as to what Mesa patches AV Linux has in place.

Unfortunately I can’t help you figure that out as I do not know the commands for .deb to obtain version information (assuming the change-history information is not obscured like Red Hat like to do).

In openSUSE, for Mesa, to get its change history one can type:

rpm -q Mesa --changelog

and if that scrolls by too fast one can redirect the output to a text file by typing:

rpm -q Mesa --changelog > mesa-changelog.txt

and open up mesa-changelog.txt with a text editor to see the change.

If an rpm “some-application.x86_64.rpm” is not installed on one’s PC, one can download the rpm to one’s hard drive, and type:

rpm -qp some-application.x86_64.rpm --changelog

and that should give the change log of the downloaded (but not installed) rpm.

Of course if an rpm distribution, like Red Hat, decides to go contrary to the philosophy of the GPL and hide the content of their patches (kernel) then its MUCH more difficult to figure out what patches are in place to make an application function, where other distros fail.

I have also noted this thread on the Sandy Bridge : [Phoronix] Intel SNB Linux Driver Can Out Run Windows Driver](

where Phoronix used the boot code " i915.semaphores=1 " .

When it comes to custom updating one’s GNU/Linux Phoronix have this caution :

I’m coming back to this now that 12.1 MS5 is out, but I’m quite disappointed. I have a spare drive so I installed it, and installations went smooth, but after a new boot, I had no wi-fi, and my mouse was still not recognised as a touchpad.

I’m ready to do some bug reports, but this is the first time, so I’m not sure where to go or how to start. Can anyone point me in the right direction? What to try before reporting?

I have a full lspci -v and lspci -vv ready.

Since you’re playing with a Milestone release, I really think you should start a new thread here:


or contribute to this one

Just in case someone is still wondering if the final released version of openSUSE 12.1 works with the Dell Latitude E5520, I can confirm that it does, although it does require you to be there. The installer is grumpy about the partitioning done for the pre-installed Windows 7 and fails to shrink it enough. The disk management tools of Windows 7 wouldn’t let me shrink Windows below 150 GB citing “unmovable files”. I used a third party tool “Partition Wizard” (bootable CD) to shrink Windows to my satisfaction before installing 12.1. The laptop comes with one of the so called “advanced format” hard drives, and I read and followed the advice in Linux on 4KB-sector disks: Practical advice .

But then the installation proceeded smoothly and it set up my 1920x1080 screen and most of the other hardware correctly. There was nothing to complain about as far as appearance goes: good font size despite the high resolution screen, desktop with 3D effects switched on from the beginning. But Wifi with the Broadcom DW1530 card did not work at first. It required downloading the driver from Broadcom’s site : - 802.11 Linux STA driver . The README file on that page explains what you need to do, and it worked, except that the Makefile they provide had to be corrected on a minor detail (The “if” statements deciding on whether it should use cfg80211 API incorrectly judge that kernel version number 3.1.2 is smaller than 2.6.32). Suspend to RAM and resume, webcam, microphone, speakers etc all work out of the box. The system with openSUSE 12.1 and KDE 4.7.2 is quite obviously considerably faster than the other laptops I own, including a Lenovo Thinkpad T61 from about 5 years ago. But I have no measurements to make precise claims.