Dell firmware update on Tumbleweed

Discover today suggested me a firmware update as shown on the screenshot , however pressing Update All does nothing and the update is still listed as available. Is this a bug? I tried searching how to do it via terminal but couldn’t find anything.

I’m always overly cautious when presented with a desktop or laptop firmware (BIOS type) update.

I especially stay away from a 3rd party tool updating the firmware. If I absolutely need a firmware update, I’ll use the native tools from the vendor (like Dell or ASUS or Lenovo, etc).

In the long time past, it took a week’s time to recover from a catastrophic failure of a firmware update … so I ONLY update if I’m having an issue that the firmware update promises to fix.

It’s worth repeating (for me anyway :slightly_smiling_face: ) … from that experience, I strongly consider if I really need the update - if all is running fine, I move on to other things

Your opinion might be different :+1:

The provider of the update in this case is supposed to be Dell, so that is that and I did not want to reboot to pre-installed Windows for that, but I might have to. The update comes from Linux Vendor Firmware Service so it should be legit. Given how many versions it offers me to update I thought it’s useful, and besides my Bluetooth is not working very reliably, so I thought it could help.

1 Like

On the command line, you would use:

fwupdmgr update

However, when I tried reinstalling my current bios, I got this error:

sudo fwupdmgr reinstall
Selected device: System Firmware
β•‘ Reinstall System Firmware to 1.10.0? β•‘
β•‘ Fixes and Enhancements: Firmware updates to address security β•‘
β•‘ vulnerabilities including (Common Vulnerabilities and Exposures - CVE) β•‘
β•‘ β•‘
β•‘ Inspiron 15 3525 must remain plugged into a power source for the duration β•‘
β•‘ of the update to avoid damage. β•‘
Perform operation? [Y|n]: y
Downloading… [***************************************]
checksum invalid, expected 0a6e14ae8e8aae287609112d7b2f16165614e57b3ff83f895d79bd5412d2dbc6 got 87f88b6db07b5b3fab01fb3bfa00c6a4e05fde353f4956396d3c7c10f0ce4ea7

You might try filing a bug report against fwupd if you get a similar message for:

fwupdmgr update


I noticed something odd with Discover.

  1. I open Discover I find a UEFI dbx as an available update (13 β†’ 2?? don’t recall the exact version)
  2. I run sudo fwupdmgr update && sudo fwupdmgr get-updates and there are no updateable devices
  3. Reopen Discover and there’s no more available UEFI dbx updates

You could be experiencing the same thing.

sudo fwupdmgr get-devices also shows an incorrect version for System Firmware in my system. I can get the correct version with inxi -M.