Deja-dub: missing duplicity

Hi everyone!

I have an issue with backup: I’ve been using deja-dub (the Gnome default) for years; without any trouble so far. Now, if I run it, it will tell me it misses duplicity.

That’s weird, and it is wrong. zypper se duplicity tells me the package is installed in the latest version, and also hitting the “Install” button in the window will tell me “The packages are already all installed”.

I already tried uninstalling and reinstalling deja-dub & duplicity, but with no success.

Does any Geeko know what could be the cause of this or how I can cope with the problem? Given that it affects my backup, I am not very happy to try out a lot of things (I have a second, redundant backup, but nonetheless, I try being conservative on that end).

See bug

1 Like

Ah, super. Danke für den Hinweis.
Ich probier’s die Tage mal aus.

Ok for the record: What works for me as an ugly workaround:

  1. Uninstall PackageKit (must be done even though I don’t really get why):
    sudo zypper rm gnome-packagekit
  2. Also remove duplicity: sudo rpm -e --nodeps duplicity
  3. Start Déja Dub and click on “Back Up Now…” (or run deja-dup --backup from the CLI)
  4. After ~2 seconds, when the “Install Packages” dialogue is presented, hit “Install”, enter the Admin Password in the next dialogue (probably only works this way on a pretty default-ish Gnome enviroment)
  5. The backup will be executed. Takes some time of course…
  6. Now, a dialogue like the one from the beginning is shown to me, asking to install duplicity again
  7. …go back to a terminal, and uninstall duplicity again first, then…
  8. hit “Install” again in the dialogue, enter password, re-install.
  9. The “verify backup” task is executed. After that, Déja Dub closes if ran from CLI or shows “Last backup was today.” in the GUI.