Default text editor

I really don’t understand why when I click on a .txt file while running PcManFM it opens with notepad a WinDoze application running under wine. Does it imply that there are no Linux simple text editors?

Any suggestions on getting rid of it would be appreciated.

There’s probably a setting for that.

In KDE, the default is “kate”, but there is a setting to change that.

I mostly use the unix shell as my file manager, so I don’t try changing it. But “vi” (really “vim”) is my preferred text editor.

I’m sure there must be but I haven’t found it yet. It’s still a brand new OS version for me. As for vim, while I like working in a console I really don’t feel like learning vi’s complicated commands. I tend to use nano.

Anything here:

of help?

Many thanks. A lot of reading, but excellent result.

Just add to your shell source eg ~/.bashrc

export EDITOR='nano'
export VISUAL='nano'

Save and source it…

. .bashrc

IMO the following article describes what you want, which is to disable/remove the WINE file associations allowing your default PCManFM file associations to work.