Dead microphone -- Dell 1525

I have a Dell 1525 laptop running Suse 11.0. I tried to
install Skype, but discovered that I could not “talk”.
The built-in microphone appears to be “dead”.

The computer has a “stereo” microphone built in and an
external microphone jack. I have not tried the jack as I
really want to get the built in working

I also tried "arecord -d 10 test.wav. I get a file from
the command, but it appears to contain no sound (at least
I hear nothing when I “play” it.

Looking at previous posts I see that there are requests for
the following:

rpm -qa | grep alsa


rpm -qa | grep pulse


rpm -q libasound2


uname -a

Linux frodo #1 SMP 2008-12-12 20:30:38 +0100 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel
options snd-hda-intel model=3stack

u1Nb.VhUtPypIg0D:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

There was also a request to run /usr/sbin/,
but I don’t have anything by that name currently in /usr/sbin.

I have a similar Dell Laptop (Studio 15). The internal mic has never worked. I note Ubuntu, Fedora, Debian, Mandriva, and other Linux distribution users are complaining of same problem.

I’ve also read of Windows users complaining of the poor quality of that mic.

I recommend you change your assumptions and go for an external mic.

That script was introduced with openSUSE-11.1’s version 1.0.17 of alsa.

With your PC connected to the internet, you can run the script as follows:

wget -O && bash

But its a mute point as I do not know how to get the internal mic to work on that laptop.

Well, just for completeness, here’s the result, but it looks
like this is going to be a dead end. Thanks anyway.

My apologies reference that discouraging quote. The internal mic does work on my laptop. … or at least it started working for the first time this afternoon after I spent some time on it.

Some time back, I read a post of a user who claimed to have it working (I think a ubuntu or debian user) and I copied the content of their post to a text file, and saved the text file on my Dell Studio 15 laptop. Others in the thread claimed the solution did not work for them, so I did not give much importance to the post, and I was also very busy at the time.

I forgot about the file. Today I had to do some things on the Laptop, and I saw the file, and remembered your post asking for help. So I applied the solution suggested and it worked. My internal mics do work on my Dell Studio 15 under openSUSE-11.1. BUT the quality is very very bad.

Thanks. Take a look at your mixer:

!!Amixer output

!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xfe9fc000 irq 21’
Mixer name : ‘SigmaTel STAC9228’
Simple mixer control ‘Mic as Output’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback off]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 14
Front Left: Capture 10 [71%] [15.00dB] off]
Front Right: Capture 10 [71%] [15.00dB] off]
Simple mixer control ‘Capture’,1
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 14
Front Left: Capture 10 [71%] [15.00dB] off]
Front Right: Capture 10 [71%] [15.00dB] off]
Simple mixer control ‘Capture’,2
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 14
Front Left: Capture 10 [71%] [15.00dB] off]
Front Right: Capture 10 [71%] [15.00dB] off]
Simple mixer control ‘Input Source’,0
Capabilities: cenum
Items: ‘Mic’ ‘Front Mic’ ‘Line’
Item0: ‘Front Mic
Simple mixer control ‘Input Source’,1
Capabilities: cenum
Items: ‘Mic’ ‘Front Mic’ ‘Line’
Item0: ‘Mic
Simple mixer control ‘Input Source’,2
Capabilities: cenum
Items: ‘Mic’ ‘Front Mic’ ‘Line’
Item0: ‘Mic

You may wish to change the items I marked in red, and take a serious look at the items marked in orange (as the items in orange to not appear to be consistent to me).

Here is what I had copied and pasted in a text file from the debian or Ubuntu forum, … you may find it somewhat confusing …

You can get the right result with these three easy amixer lines:

amixer sset 'Mic Mixer' 80% cap
amixer sset 'Capture' 80% cap
amixer sset 'Digital' 80%

Now, there's a switch to change from internal mic (the ones on the bezel next to the webcam) to the external Mic JACK (you need more hardware, like an external mike for that to work!), it's called 'Digital Input Source' (index=0)

andrea@nb-andrea:~/progetti/dell/studio15$ amixer sget  'Digital Input Source'
Simple mixer control 'Digital Input Source',0
  Capabilities: enum
  Items: 'Analog Inputs' 'CD' 'Digital Mic 1' 'Digital Mic 2'
  Item0: 'Digital Mic 1'

If you want to get the input from the embedded internal Mic next to webcam, you'll give:

amixer sset 'Digital Input Source' 'Digital Mic 1'

If you want to get the input from the External Mic Jack, you'll give:

amixer sset 'Digital Input Source'  'Analog Inputs'
That's all for now. We finally have:

    * Internal speaker working
    * Headphone working (together or alone)
    * Decent audio max volume (had to patch back from this commit)
    * Recording from embedded mic
    * Recording from Mic Jack Port.

P.S … Larry1019, thanks for motivating me to look at this (and hence get my Laptop’s Integrated Mic functioning). :slight_smile:

I played with the record levels, and managed to improve the Integrated Mic record quality a bit. Its not as good as an external mic, but the voice recording can be understood, despite the back ground noise.

Hmmm-- I seem to be flailing around here. Some things that
might be progress and some not. Still doesn’t work properly though.

  1. I tried the commands in the file you included. “amixer”
    doesn’t seem to recognize anything that has “Digital Input
    Source” in the command line.

  2. I seem to have turned on Capture 0 (but not 1 or 2).
    Previously they were all off (the ones you put in red).
    alsamixer allows me to adjust the levels for all three,
    although I can’t seem to turn them on or off in alsamixer.

  3. Using alsamixer, I can toggle Input Source 0,1,2 to
    Mic, Front Mic, or Line. These are the ones
    you indicated in orange.

With some combinations, I have managed to record something
but it was very noisy and unrecognizable.

So, at this point I still have several questions:

Which Capture(s) are supposed to be on? And if I need 1 or
2, how do I turn them on?

What should I be setting the Input Sources (0,1,2) to?

There are various possibilities. …

  • Your mixer could be configured wrong - that is the thrust of our checks;
  • Your alsa could be configured wrong - we have not checked that. Do you have any dmesg errors? You can check that by “dmesg > dmesg.txt” and open dmesg.txt with a text editor. DO NOT POST DMESG CONTENT HERE !! Should you be using a special model option in /etc/modprobe.d/sound file to force your audio to a specific model setup ?
  • Your alsa version may need updating to the latest 1.0.20
  • Its possible you need openSUSE-11.1 and this function does not work under 11.0

Which ones are supposed to be one? I assume its one capture for each mic. There are two mics are there not? One on each side of the web cam on top of the screen (its a rather important fact that I don’t recall you mentioning, if I did not have a similar laptop I would not have guessed that)

You turn them on in your mixer. Or with amixer. What desktop do you have ? KDE ? Gnome? If kde it should be kmix. If gnome alsamixer.

< sigh > I tell you what. Take a look at my mixer settings from a few minutes ago, with a functioning integrated internal mic:




Like I noted, this could also be because you need to force alsa to a specific model, or update your alsa, or update your openSUSE.

Sorry about the hardware config – I think I did say I had
a stereo microphone in the laptop and an extrernal microphone
plug at the start of all this.

So, I now have figured out how to bring up the capture
and input source displays in kmix (they were not displayed initially).

Using kmix, I have turned on capture, capture2 and capture3
and tried setting the input source (again in kmix) to “mic”
(all three) and then to “front mic” (again all three) but I
still don’t hear anything legible. Is it obvious which of
the three “capture” sliders and/or three “input switches”
goes with which microphone inputs?

My mixer is posted above. There are no more additional settings in my mixer. Note I am using KDE-3.5.10 on openSUSE-11.1 with alsa-1.0.19 on a Dell Studio 15.

If I look at the output of amixer on my laptop, I see

  • "Simple mixer control’ Capture’,0 is ON at 53% for front left and front right (possibly because I backed off on the levels to avoid distortion).
  • “Simple mixer control ‘Capture’ 1” I note it has capture ON at 0%. I can not see an equivalent for that in my mixer.
  • "Simple mixer control ‘Digital’,0 " I note it has capture for both Front Right and Front Left at 74%

I am beginning to think that the mic works in the 1.0.16 version of alsa, that you have installed.

I note you are using 3stack in your /etc/modprobe.d/sound file. Did you try any other settings? The possible settings in 1.0.16 of alsa are:

	  ref		Reference board
	  3stack	D965 3stack
	  5stack	D965 5stack + SPDIF
	  dell-3stack	Dell Dimension E520

If you tried each of those, and none of them help, why not try updating to 1.0.20 of alsa. If that does not work, you can always roll back to 1.0.16.

To update to 1.0.16 I recommend you remove the line “options snd-hda-intel model=3stack” from your /etc/modprobe.d/sound file. Then I recommend you open a kde konsole or a gnome terminal, and type “su” (no quotes - enter root password) to get root permissions, and then with your laptop connected to the internet copy and paste the following six zypper commands one at a time, executing them in sequence:

zypper ar multimedia
zypper install alsa-oss alsa-utils alsa-tools alsa-plugins alsa-plugins-pulse
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

Then restart, test your sound and your mixer. If you still have no success, then please keep the new version of alsa, and rerun the script:

wget -O && bash

and post here the output URL.

Ok – but you are getting well beyond my knowledge level…

  1. You suggest changing 3stack in the modprobe.d/sound file.
    I see this is just an edit. Do I need to reboot to make the

  2. Last time I posted the output of the wget command, it
    seemed to have a … in the middle of the url. Were you able
    to read it or is there something special I need to do to
    post such a long URL?

I can’t post attachements, but my KDEMix shows three capture
bars (labelled Capture, Capture 2 and Capture 3). All are
set at about 75%. None show a L or R. There are also pulldown
menus for Input Source, Input Source 2, and Input Source 3.
They can be selected to be “Mic”, Front Mic" or “Line”.
Currently, all are Mic.

I’ll probably have to wait on trying to install the new
version of alsa to sometime this weekend.

Thanks for the help so far…

Thats an excellent question. You do need to restart the alsa sound module. One way to do that is to reboot. Another, quicker way, is after each edit to send the command: su -c ‘rcalsasound restart’ enter root password when prompted for a password. And after alsa is restarted, you will need to restart your mixer (kmix in kde and alsamixer in gnome). Reference the edit, you just change ‘3stack’ with ‘dell-3stack’ or another entry, and restart alsa after each change. Since you need root permissions to edit the file, you can open the file for editing

  • in Gnome with: gnomesu gedit /etc/modprobe.d/sound
  • in KDE with: kdesu kwrite /etc/modprobe.d/sound

You need to post the long URL. The forum software to try reduce the size of a post will display a " … " in the middle of a link, but if you look at the actual link, there is no such " … "

On my laptop, I believe “Mic” is the input jack for my external Mic, and “Front mic” is my integrated internal Mic. But this could vary from PC to PC, and I do not think my Dell Studio 15, which is a Studio 1537, is identical to your 1525.

Sure, no worries. I believe it is your best bet.

When I first obtain my Dell Studio 15, it had problems with both the headset. I ended up writing report on it, and the openSUSE/Alsa dev quickly fixed it. In case you are curious, the thread is here: Dell studio 15 sound problems - openSUSE Forums

and my first bug report here: Access Denied

deleted - mistaken double post.


The /etc/modprobe.d/sound option dell-3stack adds an additional
pulldown menu in KMIX which is not there in 3stack or 5stack. The
menu is “Digital Input Source” and the options are “analog inputs”,
“digital mic 1” and “digial mic 2”. Choosing “digital mic 1”
makes the microphone work properly. Thanks very much for the

Great ! Congratulations. Thanks for sharing your solution (and thanks also for motivating me to getting mine to work also).