cups password

when i try modifying or adding a network printer it tells me that i need a username and password… when i tried my username and pass or my root and pass im still locked out… wtf… can anyone offer any help… thanks…

If it does not work with your root password you can change the password or add another user with lppasswd. man lppasswd explains its usage quite well.

thanks for the tip - but lppasswd didnt work… it says that access to the password file is denied (and i did it thru root)… any ideas what should i try next?

what exactly did you type ?
1 ) open a console
2 ) type su & press enter
3 ) enter root’s password
4 ) type lppasswd -a username & press enter ( replace username with yours )
5 ) enter password when asked
6 ) re-enter when asked
7 ) job done


hey andy… i did just that… exactly as you said step by step and after i enter the password the 2nd time it then tells me this:

lppasswd: Unable to open password file: Permission denied

i was thinking that maybe i had to chmod the file but i cant find it (passwd.md5 or something like that which was referred to in the man page)

any ideas on how to proceed from here…


Hmmm, strange.try this

sudo lppasswd -g sys -a root.


same error…


have a read of this Cups lppasswd problems in 11.0 - openSUSE Forums might help


thanks for your help andy… i will read thru that and see if i can find out the problem… thanks again…


On Thu October 9 2008 12:46 pm, al-bee wrote:

> thanks for your help andy… i will read thru that and see if i can find
> out the problem… thanks again…
> albee
A few thoughts:

  1. You might want to look in /etc/cups/cupsd.conf to make sure you are allowing
    admin changes. Remote administration will require a modification of the
    default, but make sure you have at least "Allow @ LOCAL.
  2. When you tried to add a user with lppasswd were they in the lp group? If not
    add them and try again. Also if you changed root’s password at some time that
    may need to be changed with lppasswd. (I assume that when you install, the
    installer adds the root password to the lppassword file, but I’m not positive
    of this.)
  3. lppasswd requires passwords to be at least 6 characters long and include both
    alpha and numeric values. It should complain about that but perhaps for some
    reason it just denied access.

Not sure if any of this will help, but it’s worth a try.

P. V.
Cogito cogito ergo cogito sum.

for username: root
for password: use your root password

worked for me.:wink:

hey ja2… that did it… thanks…