Ctrl + backspace on Gedit

So finally clean-installed Leap 15.1 with Gnome.

I noticed the Ctrl + backspace function to delete whole word instead of single character seemingly disappeared from Gedit, though Ctrl + left/right arrow still works.
How can one get it back?

Is it also possible to enable it for Terminal emulator?

Firefox still has Ctrl + backspace thing as normal.


Just checked here and ctrl+backspace works fine? I don’t think it’s possible for gnome-terminal…

If you create a test user, does the ctrl+backspace issue duplicate?

With a new test user created, issue indeed duplicates.

Any help please?

Well the only places for GNOME key configuration is dconf-editor, Settings -> Devices -> Keyboard and the GNOME Tweak tool. But since it’s duplicated then it’s something system wide and not desktop related, which those tools I mentioned apply.

Is this a pure GNOME install or do you have other desktop environments installed?

Pure GNOME install, no other DEs.
And it’s from default openSUSE repositories; I don’t add the GNOME full one.

Are you running Wayland? If so switch to Xorg and see if it changes…

Yes, that was it:

Thanks very much.
Problem was: cat /etc/sysconfig/displaymanager says in last line it’s supposedly using “Xorg”.
In the login window, before actually logging in I clicked the “gear” icon, and first 3 options are GNOME, GNOME classic, GNOME on Xorg. This time I explicitly chose the 3rd one, and issue solved! I guess the first option is the new default “Wayland”…

Issue which caused the confusion: either in “GNOME” and “GNOME on Xorg”, /etc/sysconfig/displaymanager says “Xorg” in the last line.

So, how can one know which display manager is currently in use?
This seems important.

Thanks very much again.

The default is wayland these days…

Run the command;


How is it that there’s still no fix for this on Wayland after years?

Excuse me, what exactly did you mean?

I mean, on Leap 15.1, at least in Gnome it’s still true, but not in KDE.
In KDE I found default is X11 with a clean Leap installation.

Yes wayland is the default for Gnome, have no idea for other DE’s :wink: