Ctrl + Alt + F1 gives black screen

Hi :wink:

I’m used to install from Tty using ctrl+alt+F1 : i close my user session and then i use Ctrl+Alt+F1 and from there i log in as root to install .
Do you do the same ?
Is this good practise ?

In Leap 42.2 it does not work though : when i Ctrl+Alt+F1 i can’t see anything but a black screen, Using F2 gives the same.
How come i can’t see anything ? How i can solve this please ?
I can come back to the menu session with Ctrl+Alt+F7 though. Then Plasma session , i3 or icewm sessions work ok.

Thanks :wink:

I wouldn’t say it is bad practise. I probably would login as a normal user and then use

su -

but as this is complete local (no network involved) that might be overkill.

BTW, I normaly start from a local KDE session as a normal user and then use YaST. Again I think that is save enough (as long as nobody looks over your shoulder).

You do not see anything, but can you nevertheless type things? Well I guess you can type, but do you see what you type?

Hi,

I actually duped to some repositories (X11 and kernel standard) and rebooted, be it linked or not, then it was working ok again :=)
i wanted to check if i could actually see something being writen on the black screen in Tty… and then saw it was ok :slight_smile:

Fine it works again. And thanks for reporting back.

I have the same problem as manchette_fr.
To run the Nvidia installer, I have to stop the X server.
sudo init 3
<ctrl> <alt> F1
login as root
start installer
This always worked fine.

Since I’ve updated to openSUSE 42.2, <ctrl> <alt> F1 brings up a blank screen without any prompt.
I’m using Xfce desktop.
How can I shut down the X server and switch to a system console login?

I am not sure if it has anything to do with the problem, but I would do this different (the sequence).

  • log out all users from the GUI;
  • Ctrl-Alt-F1 to the console (which then in the problem case would go wrong);
  • login as root;
  • init 3 (but maybe even init 1);
  • do what should be done in that runlevel;
  • init 5 or reboot.

Main difference as I see it is that you (as I read your post) do init 3 from a terminal window in a running user GUI logon, where I prefer first to minimise GUI usage first.

Both will work though I think,

Thanks for your quick reply.

Since I’m back home on monday, I’ll tell you then, if it has worked.

I did a fresh install of Leap 42.2, Ctrl-Alt-F1 works fine.
After updating all my repositories, same as before.

  • log out all users
  • Ctrl-Alt-F1
  • login as root
  • init 3 => prompt disappears and Ctrl-Alt-F1 doesn’t work anymore

The only repository which is not from “download.opensuse.org” is “ftp://ftp.halifax.rwth-aachen.de/packman/suse/openSUSE_Leap_42.2”.

That the prompt first disappears when gong initt 3 is logical That Ctrl-Alt-F1 does not function any more in init3 is also logical, because it is a function of X-windows and that is stopped.

But you should get a new prompt, ot a new login.

Ok, we will not come any further.
Since I earn my money with Linux GPU programming, I have no choice but to re-install openSUSE 42.2 and disable all my repositories until the bug is fixed.

After studying the SUSE documentation https://www.suse.com/documentation/sles-12/book_sle_admin/data/cha_systemd.html, I found a workaround.

  • login as root
  • systemctl set-default multi-user.target
  • reboot

Now the system boots into text mode (System V’s init level 3)

  • login as root
  • install driver and do whatever you want
  • systemctl set-default graphical.target
  • reboot (or init 5)

Now the system boots again into graphical mode.

Xfce user here init 3 brings me to a blank screen then <ctrl> <alt> F1 brings me to the login prompt,
but doing <ctrl> <alt> F1 while in init 5 brings me straight to a login prompt. This is with openSUSE Leap 42.2

The post you cite was somewhat inaccurate, sorry (see next posts).
After a fresh installation of Leap 42.2, switching from graphics to text mode and back works fine. Only after I have updated my 42.2 repositories, it is no longer possible to switch from graphics to text mode because I do not get a login prompt anymore.
But the workaround I described is completely ok for me.

Reading the NVIDIA documentation gives:
–no-X-check : do not check for a running X
–no-nouveau-check: do not check whether the nouveau driver is loaded.

I’ve been using these options for numerous times and did not run into trouble doing so. The NVIDIA driver installs and works ( after a reboot )