cracking audio

Since I upgraded my system from Leap 15.3 to Leap 15.4 (new install), I hear cracking noises when playing audio. The audio plays normally, but with cracking noises.
This occurs when playing a file from my computer (mp3, mp4) and when playing for instance YouTube via Firefox.

I have all the Packman Multimedia files installed.

hwinfo --short lists a.o. the following sound devices:

sound:
nVidia GK208 HDMI/DP Audio Controller
C-Media Electronics CM6501

Does anyone know a solution for this problem?

Kind regards,

Thijs Bennis

Please start by providing some definitive audio hardware and system information.

Update inxi with

sudo inxi -U

then do

inxi -Aa

Report back with the output.

Assuming that you are using pipewire, then it may be necessary to adjust the sample rates in pipewire.conf. This could be done globally (custom /etc/pipewire/pipwire.conf), or for a given user in ~/.config/pipewire/pipewire.conf

Reference:
https://wiki.archlinux.org/title/PipeWire#Changing_the_default_sample_rate

Crackling symptoms and possible remedies discussed here:
https://forum.manjaro.org/t/howto-troubleshoot-crackling-in-pipewire/82442

Dear deano_ferrari,

Thank you for your reply.

Fist I tried the two commands you asked me.

sudo inxi -U

That gives this output:

Starting inxi self updater.
Using tiny as downloader.
Currently running inxi version number: 3.3.07
Current version patch number: 00
Current version release date: 2021-10-11
Updating inxi in /usr/bin using main branch as download source…
Validating downloaded data…
Successfully updated to main branch version: 3.3.20
New main branch version patch number: 00
New main branch version release date: 2022-07-27
To run the new version, just start inxi again.

Starting download of man page file now.
Updating inxi.1 in /usr/share/man/man1
using main branch branch as download source
Downloading man page file…
Download successful. Validating downloaded man file data…
Contents validated. Writing to man location…
Writing successful. Compressing file…
Download, install, and compression of man page successful.
Check to make sure it works: man inxi

So inxi is updated to the latest version.
Then the second command:

inxi -Aa

That gives:

Audio:
Device-1: NVIDIA GK208 HDMI/DP Audio vendor: ASUSTeK driver: snd_hda_intel
bus-ID: 1-4:3 v: kernel chip-ID: 045e:0779 pcie: class-ID: 0102 gen: 1
speed: 2.5 GT/s lanes: 8 bus-ID: 05:00.1 chip-ID: 10de:0e0f
class-ID: 0403
Device-2: Microsoft LifeCam HD-3000 type: USB
driver: snd-usb-audio,uvcvideo
Device-3: C-Media CM6501 type: USB driver: snd-usb-audio bus-ID: 2-7:2
chip-ID: 0d8c:0201 class-ID: 0102
Sound Server-1: ALSA v: k5.14.21-150400.24.11-default running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.49 running: no

I see I use PulseAudio instead of PipeWire. I think I changed to PipeWire when trying to solve the problem with the audio (without success).

I hope this gives you an idea what I have to do next.

Kind regards,

Thijs Bennis

See if the following helps…

https://wiki.archlinux.org/title/PulseAudio/Troubleshooting#Glitches,_skips_or_crackling

For PulseAudio check settings default-sample-format, default-sample-rate, resample-method in file /etc/pulse/daemon.conf.
Also you can post this file here with CODE tags.

What output you’re using?

Dear Svyatko,

The settings are as follows:
default-sample-format = s16le
default-sample-rate = 44100
resample-method = speex-float-1

I use Digital stereo (IEC958) output for CM6501.

Kind regards,

Thijs Bennis

You’re using S/PDIF to output sound onto external device?

Check power saving settings.

Yes, I use S/PDIF to two external speakers. I can switch to ‘speakers’ (analog stereo) but that gives no improvement.

My power mode setting is balanced.
The power saving settings are:
turn the monitor off after 10 min inactivity.
Automatic pause after 15 min inactivity.
Disabling these settings makes no difference.

Did you try the advice in post #4?

Yes, I am trying the solutions in that article, until now without success.

Hello:

The output of the inxi command indicates that it uses the 2 audio servers, that is, the one that uses alsa or pulse depends on the application (although by default it indicates alsa).


Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a348
    class ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
    v: kernel pcie: speed: 2.5 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:0fb9
    class ID: 0403
  Sound Server-1: ALSA v: k5.3.18-150300.59.87-default running: yes
  Sound Server-2: PulseAudio v: 14.2-rebootstrapped running: yes
  Sound Server-3: PipeWire v: 0.3.24 running: no

If you use optical fiber or coaxial RF cable, the DC Current component. is removed in order to modulate the signal.
I don’t know how the clicks will be, if they are sporadic, it could be a coding error, if it is continuous it could be distortion, I think it could be possible to lower the audio level on the PC and raise it on the amplifier, isn’t that the cause? what is distorting? .

You can also delete and reload the driver, and select it automatically (that in yast), then go to others and Define the card
Another would be to edit the one you have and select automatic.
Could you rule out the crackles, using another output, for example an analog one, if it goes well, discard the encoding (in fiber it is rare that it makes noises due to poor contact, so it rules out that it originates from clicks, but not that it is distortion).
Anyway, not hearing it, I don’t know what it could be.

Best regards .

Sorry for my bad English

For PulseAudio use

resample-method = copy

Or use ALSA for sound output.

Check power saving settings in BIOS.