CPU0 usage pegged at 99%

Just recently my cpu widget started showing CPU0 at 99% all the time. It seems like it was some normal upgrade, as I haven’t change anything in my Leap 42.2 lately. Oddly nothing has slowed down at all on my i3 system. “top” (as root) shows kworker that is running at 99%. Htop doesn’t show kworker at all, but does show CPU0 at 99%. “System Activity” shows kworker, but running at 13-25%. My computer isn’t speeding up any fans or showing any signs or over-working or heat.

What is going on? Why am I getting conflicting readings? What are real and what aren’t? What is kworker and what if anything do I do to manage it? Why did this just start happening recently? (I do the normal system upgrades that Leap tells me to do.)


May be doing some background housekeeping… Like file system indexing.
Besides CPU activity, do you also have excessive disk activity?
If related to disk activity, you can install and run iotop to see processes related to your disk activity.
What is your memory usage, could you be using swap?
Check your network usage as well, maybe you’re downloading and/or installing updates.


Thanks! I’ll look into some of those.


Both values are real, they are not conflicting, just a different “scale”.

The process uses 99% (or probably 100%) of one CPU core (CPU0).
Apparently you have 4 cores, so the overall load is 25% (i.e. 100 divided by 4).

Thanks for the help everyone. Before I could explore as suggested it stopped doing it. It appears that it was running something in background. I’m not sure what would take a week to run in background.


File indexing LOL.

Possibly KDE Baloo.
Btrfs could be a candidate but, it’s unlikely that it would need a week to initialise the system partitions.
[HR][/HR]I’ve been investigated the KDE Baloo delivered with Leap 42.2:

  • During the initial initialisation phase, and / or with new files, on an older AMD 4-core CPU (~2 GHz) laptop with a new 1 TB SSHD, KDE Baloo indexes files at the rate of about 20 000 files per hour (about 300 files per minute).
  • By default, KDE Baloo indexes only those files it can find under $HOME but, including ‘.’, ‘…’, and all the other directories in the chain up to ‘/’.
  • By default, KDE Baloo does not index the files in the “hidden” directories – ‘.local/’, '.config/, ‘.cache/’ and so on.
  • By default, KDE Baloo does not index any directories to be found on devices automatically mounted on the USB interfaces.
  • By default, KDE Baloo is tightly integrated with Akonadi – there are 2 configuration files which appear if the user has anything related to Akonadi activated.
  • Catch 22: If you mount anything via NFS and especially NFS auto-mount and, if the NFS mount points are not explicitly excluded in the user’s KDE Baloo configuration then, Baloo will index everything it can find in those directory trees – at the rate of about 20 000 files per hour, if the network connection is fast enough . . .

KDE Baloo’s activity can be checked in the KDE Information Centre – the “directories excluded” can be checked via the KDE “System Settings”.
The following user CLI commands may be useful:

  • “balooctl status”.
  • “balooshow -x <path and file name>”.