CPU usage by systemd-udevd

After latest update (Tumbleweed 201803318), systemd-udevd is using allot of cpu.
Reboot doesnt help.

I guess there may be some bug in the latest kernel: 4.15.9-1-default

Im use KDE.

Can someone confirm this?

Updated to 20180318 earlier today and I’m not seeing any abnormal CPU usage from systemd-udevd.

Whilst inactive, system is around 97-98% idle.



Today i updated again latest updates.

ronsim@localhost:~> uname -a
Linux localhost.localdomain 4.15.11-1-default #1 SMP PREEMPT Mon Mar 19 19:55:59 UTC 201
8 (a1db525) x86_64 x86_64 x86_64 GNU/Linux

OpenSUSE Tubleweed 20180324

What is happening with Systemd-udevd? It still eating CPU, but now it also appears more of it in processes-list and they are eating memory :-o

Now my Tubleweed is up to: 20180424 with Kernel 4.16.2-1-default.

Does it also happen with a new user?

Anything interesting from systemd-udevd appearing in the journal?

Still not seeing the problem myself using TW 20180425 and can’t offer any suggestions I’m afraid.

Googling for “systemd-udevd high cpu utilisation” https://www.google.com/search?hl=en&as_q=systemd-udevd+high+cpu+utilisation gives quite a few hits, maybe something of relevance there?

I testet with a new user and yes the problem is still there. If i look in KSysInfo one of the CPU is stuck to 100%.
I have i suspicion that there is some problem with the Synaptic Touchpad-driver. The touchpad is acting strange and if i search on Google, there is some article about Systems-udevd and Synaptic driver.
I will try to remove the driver and connect i usb-mouse to see if this change anything.

Yes, I am seeing this problem.

I only see it on one system. Other Tumbleweed systems are fine.

At present I have one systemd-udevd process at around 100% processor time, and another at around 40% processor time.

Touchpad seems to be normally responsive with Icewm (where I can’t turn it off). I have it turned off for Plasma.


I seem to have the exact same problem. udevd using a lot of processor, maxing out the CPU usage and getting the fan at full speed.

The problem was present with previous versions of Tumbleweed for a few weeks/months. I have just installed the latest Tumbleweed (20180704), rebooted the PC and this is still a problem.

Any advise on what to do to get rid of the issue?

Thanks a lot in advance,


I mentioned in reply #7 above, that I am seeing this problem.

I did file a bug report - Bug 1092246

Feel free to add comments to that bug report.

In my case, it appears to be bluetooth related. And I don’t actually use bluetooth on that laptop. So I disabled bluetooth in BIOS settings, which solved my problem for now. But the problem reappears if I enable bluetooth support once again.

A quick internet search suggests that udevd problems can be identified by running udevdadm as follows

udevadm monitor

It also seems that people have suspected and “fixed” (I wonder how certain their fixes and conclusions are) a wide variety of potential causes… including GPU, USB devices, I/O devices, PCI devices…
Which in a way illustrates how versatile and important udev is in a system (It’s one of the main ways to detect devices and then take some appropriate action).

If you can identify what device might be causing all that activity,
Then maybe a follow up search can focus on udevd and that particular device.