Could not find kernel image: gfxboot

Hello all.
I’ve been trying to get a live stick of OpenSUSE 11.2 running and I continuously get a script of
could not find kernel image: gfxboot”
running down the screen.
Any other version of Linux will run fine off this same USB and I have not seen this error cited anywhere on these forums or Google.
Can anyone help?

24 hours later and nobody can help me out?

What medium are you using to create the live image, kiwi, SUSE Studio?

AFAIK, gfxboot isn’t used anymore, there should be a grub entry
something like;

gfxmenu (hdx,y) /message

Which is built into the initrd image for whatever configuration you
set it to for the graphics and then run mkinitrd.

PS, Welcome to the forums :slight_smile: remember we are all just volunteers here
and viewers may not have seen this before, so a bump of the thread
helps to make it visible :wink:

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 8 days 0:09, 3 users, load average: 1.29, 0.71, 0.45
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15

howeasy wrote:
> 24 hours later and nobody can help me out?

-=welcome=- to the forum and to openSUSE…sorry you are having
trouble…but, you can help yourself by providing us some insight into
your problem…since all our crystal balls are out of service we could
try to guess all the details that are missing in your two post, or you
might try filling in some of them, for example:

-how did you make this bootable USB stick? that is, did you use these
instructions ? if not, then
which did you use?

  • where did you get your 11.2 image from, was it or was it from somewhere else?

  • did you download a LiveCD or DVD

  • did you download it to a Linux file system?

  • once you had your 11.2 image did you md5sum check it prior to making
    the USB stick…the sum you obtained was it exactly the same as the
    one provided on

  • if you open the usb stick in a file manager, what does it look
    like…that is: is it one file ending in .iso or is it a series of
    folders…is one of them named “boot”? in the boot directory is there
    one or more files with the name vmlinuz[some numbers]? what are the
    exact names of those files?

you say this USB has worked with other versions…how many? were they
all Debian based, or Red Hat like…or, my real question is how much
experience do you have with SLES/SLED/openSUSE ?

and, you wrote “I have not seen this error cited anywhere on these
forums or Google.” but i just found 24 hits on precisely “could not
find kernel image: gfxboot” and almost 2000 hits by removing the
quotation marks…

  • which of those have you tried which did and not fix your problem?

  • what other steps have you taken?

the best way to get help is to provide the info we need to try to
start figuring out why you are having a so very unique problem

DenverD (Linux Counter 282315)
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

I think it is a problem with windows version of: unetbootin-windows-442

I tried win32diskimager and it worked fine. I was able to enter the operating system but wasn’t able to resize and create another partition. This tool is still alpha and I think it is still buggy. Although I can boot, I can not access the USB drive from windows (it requires it to be formatted) which suggests a corrupted file system

On some forums they suggest that windows unetbootin copies empty vesamenu.c32

If I find something I’ll post again

Window will not read a Linux files system. Don’t you know Windows is th only OS in the world??? rotfl!

As terbaite said, this seems to be a bug in unetbootin that only seems to affect opensuse (at least versions 11.2 and 11.3), win32diskimager works perfectly.

Hi @ all you fellows, please forgive my ignorance, but my copy of win32diskimager copies only .img images. What I’ve downloaded from is in an .iso format, which doesn’t seem to be able of converting (easily at least).

Could you please, if it is not too much trouble, explain how did you made it?

Thanks in advance, cheers!

I just read in Bugs:Most Annoying Bugs 11.3 dev - openSUSE :

openSUSE 11.3 RC1

* Accessing LVM partitions is not possible - Bug #598193 "udev deletes device nodes".
* Hal is not started for the first boot after complete install Bug #613898 - for KDE desktop this means : no detection and automounting of removable devices, the battery widget is non-functional etc. It also **means for KDE users that they can not make a workable LiveUSB from the .iso file** by the usual "dd" technique. workaround: sudo zypper in hal ; sudo /sbin/insserv haldaemon
* Suspend theme not yet branded Bug #610908

Interesting thread. I am a one-time fairly serious Suse user who has been mostly off Linux for several years. Current problem:

  1. Have an opensuse .iso (after all, most Linuxes deliver as ISOs)
  2. Want to install it on a usb drive.
    (as others have pointed out above, being familiar with other Linux distros, this is usually a no-brainer process involving unetbootin or something similar)
  3. Did unnetbootin to write USB, which fails for reasons I am not very interested in.
  4. Looked up SuSe advice, found ImageWriter notes, tried that.
  5. Hmm, Imagewriter’s view of the universe is that the only input is .raw files (as in “WTF is a .raw file?”)
  6. So, I dunno, is the message here “get Ubuntu”? OpenSuse has good reviews, unliked Kubuntu, and I’d like KDE (not the odious, IMO, Gnome GUI). But: no obvious way to USB the generally-available .iso files. Any suggestions?



AFAIK just changing iso to raw in the file name will allow Imagewriter to work. Never tried myself.

It seems the dd method is the most reliable SDB:Live USB stick - openSUSE


  • unnetbootin cannot write USB with 11.3. This is out of question. (For me)
  • In the Imagewriter’s Open dialog, replace the .raw file type with an *. That should make isos appear on screen, if not, move one level up and then back. Worked for me.
  • The dd method works ok, I guess in any case. Except mine, where my netbook’s bios probably does not support (usb)booting from opensuse 11.3.

Well, to be fair:
Older versions of Opensuse worked ok for usb live booting. If one bunred these isos, he could see a folder-tree which included the folder media1, or so. In 11.3 (I think after the hybrids) this is not the case. In this image (openSUSE-Edu-li-f-e-11.3, hybrid) notice the 2.5G’s file and the “missing folders”.

My netbook is a Viewsonic VNB101, with InsydeH20 D0.05T45.55.03 and Intel Atom cpu n280.

I also experienced the same problem on an Emachines e525 laptop with Insyde bios, too.

My conclusion:
After the adaption of the hybrid method in the live isos, Opensuse is not installable in CD’less Viewsonics VNB101 and others alike.

openSUSE-Edu-li-f-e-11.3 just needs dd, unetbootin method is not required as DVD iso is also USB image(hybrid)

dd if=imagename.iso of=/dev/sdX bs=4K (where sdX can be sdb or sdc depending on how many disks are already in the PC, check with fdisk -l). Umount the stick before doing dd.

It is not missing any folders, the technology openSUSE uses is much different than other distros, we use clicfs and new hybrid feature of syslinux.

I’ve had the same error message going over and over.
I tried it with 12.1 Gnome & KDE and 12.2 KDE with Lili, all of them were 64bit.
The 32bit 12.1 Gnome worked with lili, so I’m thinking something about the architecture might be an issue.
I’ve had similar problems with JoliOS (it’s based on ubuntu 10.04 lts x86) but it was only because I plugged it into an usb3 instead of 2.
I have given up on ubuntu familiy OS’s because of proprietary video driver issues.
My hardware specs are:
Dell N5110, i7 2760QM, nVidia GT 525M, 8GB 1333Mhz DDR3, Intel HM67 chipset.
I just made a 12.2 beta KDE x64 with suse studio img writer and I’ll give it a go. The x86 versions of OpenSUSE only see 3 out of 8 GB of memory and I’m not quite excited on using PAE.
I’ll be back with reply if it doesn’t work.

I tried 12.1 64 and 12.2 Beta1 64 with unetbootin, both failed with the message:

could not find kernel image gfxboot

Scrolling repeatedly.

I then tried to use suse imagewriter and it worked perfect first time. (12.2 Beta 1)
This is surely a bug with unetbootin’s way of handling the .iso. I don’t have enough knowledge to usefully report this to them , perhaps someone else could test and report the bug to them…
(I used an .iso of Linux Mint last week, with unetbootin, it worked fine.)

I have raised a bug with unetbootin, although I suspect the problem stems from openSuse’s idiosyncratic way of presenting the .iso’s, compared to other distro’s.

in my case,i want to accomplish pxe boot and auto-install sles 11 on a machine.after I finished setting up the server, the same error with you occured on the client my pxe default configuration file ‘/tftpboot/pxelinux.cfg/default’, there was a row with the content :‘ui gfxboot bootlogo message’,after I commented this row with ‘#’, the pxe client boot successfully.