Corrupted home folder: Resolution Error

Happy United States Independence Day for those who celebrate it!

I have an issue with my $home folder. On my main account, I installed a program that messed with the resolution. That program has been taken care of through nomodeset boot commands. However, henceforth (not including nomodeset) I cannot access that main account without the screen shorting out as the loading lightbulb fades in and the following message popping up on my Dell 27 Monitor:

“The current input timing is not supported by the monitor display. Please change your input timing to 3840x2160, 60Hz or any other monitor listed timing as per the monitor specifications.”

Testing on a separate forum thread has revealed the following:
Nomodeset in the boot instructions will provide a low-resolution screen of the main account.
I can access the login screen, a separate account, and any of the Ctrl+Alt command line terminals without any display issues.
This leads us to conclude that the $home folder of the main account is somehow corrupted and needs resetting.

I have removed the cache data from the $home folder to no avail. I have no major personal information on this OS and can reset, but I’d like to see first if I can recover this $home, or at least this OS.

How do I reset/reinstall $home settings? Any help would be appreciated!

All you’ve told us is you have a Del 4K that isn’t working on TW at 4K, and you’re in recovery mode by using nomodeset. Nomodeset is only for enabling a repair environment. It doesn’t fix anything.

You’ve given no information on what your home directory might contain, nothing about your software environment (X11 vs Wayland, Gnome vs Plasma vs XFCE or something else), or your GPU, or what connects your 4K Dell to your computer, items critical to solving video issues.

While not logged into your main account or any other GUI, you can destroy pretty much all GUI settings by deleting ~/.local/, ~/.cache/ and ~/.config/, but this is a quite drastic move, nearly equivalent to a new user or OS installation. If you wish to fix it, create a new user, and use it to try to replicate the issue. If it works, you can compare contents of various files in ~/.config/ to try to isolate where the problem lies, if the problem is actually specific to your normal user. If problem replicates in a new user, then logs can be perused and/or susepasted for our perusal, once we know the parts you didn’t share. Something serious would be indicated by dmesg | egrep ‘aile|Call Trac|egfaul’ or getting logs from an immediately prior boot made without using nomodeset by running journalctl -b -1 | egrep ‘aile|Call Trac|egfaul’. (-b means a single boot; -1 means boot immediately prior to current). If using X11, Xorg.0.log should exist either in /var/log/ or in ~/.local/share/xorg/. (EE) lines after the first mean trouble.

Normally inxi -GSaz would tell us much of what we need to know, but it’s somewhat crippled when nomodeset is employed, or not run from within a GUI environment. Yet, it would be a place to start providing information to work with.

@QJ , @mrmazda is right. We need a little more information so that we can get a better picture of the situation.

The following information would be particularly helpful:

  • inxi -GSaz
  • Does it occur on Wayland and Xorg? (switch on login windows)
  • Which display manager is used here (gdm, sddm, lightdm, …)?
  • What’s the name of the tested program and source?

Danger, remove ~/.local/ isn’t a good advise/example! In dependency to the used applications it contains more than just configuration files. Deleting ~/.local/ may remove your photo gallery or Email database for example. Just for the sake of completeness, so no one should try this without a fresh backup!

Is there a ~/.xprofile file existent in your main user home? If so, please show us the entries of it and try to rename it temporary: mv ~/.xprofile ~/.xprofile.out . Perhaps your foreign application has created it with some weird settings. Most of the time it is not needed.


Apologies for the delay; Fourth of July and all!

“inxi -GSaz” yields the following:

Kernel: 6.9.5-1-default arch: x86_64
bits: 64 compiler: gcc v: 13.3.0
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/boot/vmlinuz-6.9.5-1-default
splash=silent mitigations=auto quiet
security=apparmor nomodeset
Desktop: KDE Plasma v: 6.0.5 tk: Qt
v: N/A info: frameworks v: 6.3.0
wm: kwin_x11 tools: avail: xscreensaver
vt: 2 dm: SDDM Distro: openSUSE
Tumbleweed 20240621
Device-1: Intel CoffeeLake-S GT2 [UHD
Graphics 630] vendor: Dell driver: N/A
alternate: i915 arch: Gen-9.5
process: Intel 14nm built: 2016-20
bus-ID: 00:02.0 chip-ID: 8086:3e98
class-ID: 0380
Device-2: NVIDIA GP108 [GeForce GT 1030]
vendor: Micro-Star MSI driver: N/A
alternate: nouveau non-free: 545.xx+
status: current (as of 2024-06;
EOL~2026-12-xx) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-2021
pcie: gen: 1 speed: 2.5 GT/s lanes: 4
link-max: gen: 3 speed: 8 GT/s
bus-ID: 01:00.0 chip-ID: 10de:1d01
class-ID: 0300
Display: x11 server: X.Org v: 21.1.12
with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X:
loaded: modesetting unloaded: fbdev,vesa
alternate: nouveau,nv,nvidia gpu: N/A
display-ID: :0 screens: 1
Screen-1: 0 s-res: 800x600 s-dpi: 96
s-size: 211x158mm (8.31x6.22")
s-diag: 264mm (10.38")
Monitor-1: Unknown-1 mapped: None-1
res: 800x600 hz: 60 size: N/A
modes: 800x600
API: EGL v: 1.5 platforms: device: 0
drv: swrast gbm: drv: kms_swrast
surfaceless: drv: swrast x11:
drv: swrast inactive: wayland
API: OpenGL v: 4.5 vendor: mesa
v: 24.1.1 glx-v: 1.4 direct-render: yes
renderer: llvmpipe (LLVM 18.1.6 256
bits) device-ID: ffffffff:ffffffff
memory: 14.98 GiB unified: yes
API: Vulkan Message: No Vulkan data

  • I use X11, not Wayland.
  • I’m not quite certain which display manager I use.
  • The tested program derives from “Ankama Launcher-Setup-x86_64.AppImage”, specifically by downloading the Ankama Launcher from the Ankama website, downloading and launching the game “Wakfu”, and adjusting the introductory display to (I believe) Full screen.

There is no ~/.xprofile file, but there is a ~/.profile file. Does this produce a similar result? I won’t change it yet out of caution.

Thank you for your help and your patience.

If there’s anything else you’d like, please let me know.

Normally, Plasma users have no need of either a .profile or an .xprofile file. Neither should create a low resolution problem, but considering you have one, I’d eliminate either and both. Troubleshooting tests to start with are:

  1. prologue: testing while booted using nomodeset negates useful tests. First order of business is determine what’s required to get booted without it. Do you still have a 6.8 kernel to try? If yes, does it change any behavior?
  2. login to a non-Plasma session. IceWM should be at the ready. If not, it’s simple and fast to install, and very lightweight. Full 4K in IceWM means it’s not a driver or X problem, but a Plasma or personal settings problem. 800x600 in IceWM usually means driver trouble, very common among Optimus hybrid graphics (Intel + NVidia GPUs) users.
  3. try a Wayland session instead of X11. Same problem? If not, report what you observe.
  4. try a different user login to see if the same limitation applies. The answer is a report whether the DE and/or your personal settings are at fault, or something more fundamental, such as kernel driver and/or display driver and/or Mesa.
  5. Inxi reports an older TW version 20240621 with matching kernel. What kernel was in use before this problem started, 6.8.x? Were you ever running a 6.9.x kernel OK? If not, very likely this is an NVidia driver issue that a fresh upgrade to 20240708 and 6.9.7 followed by newer Optimus/NVidia drivers could solve.
  6. collect and share the logging information discussed in post #2.

As long as you’re using nomodeset, you’re running in crippled mode, unless the NVidia driver installation instructions you followed requires it.

According to his first post, he only has these problems with one system user. Therefore, I suspect that this “Ankama Launcher” has saved something in the user profile which leads to an incompatible resolution or frequency.

What’s in your ~/.profile?

cat ~/.profile

# Search for "xrandr" in multiple files
grep -i xrandr /home/user/.*

What’s with your second Monitor? Was the monitor not connected at that time?
Min./Max. Values could be interesting like my example:

  Monitor-1: DP-2 model: Dell U2722DE serial: <filter> built: 2021
    res: 2560x1440 dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23")
    diag: 685mm (27") ratio: 16:9 modes: max: 2560x1440 min: 720x400

I am not on KDE. @mrmazda Do you know where the last chosen screen resolution is stored in KDE?

Nomodeset doesn’t just block the KMS drivers required for competent graphics behavior. It also limits video output to the default monitor connection.

Given I normally have no use for and thus disable Kscreen*, I don’t see any ~/.config/kscreen* file, which is where I would expect to see it. The graphics configuration I do I try to, and usually do do, globally, which is not its purview. If I find something I boot in near future that has it I’ll try to remember to update this.

Howdy, everyone! After a lot of trial and error, I found out that it was indeed a kscreen error.

For some reason, my “refresh” rate in “.local/share/kscreen/outputs/[long character string]” was set to 59.95613098144531, and my resolution was set to 3200X1800, which is what I’d originally set in the mistake. I changed them back to 60 and the appropriate resolution, respectively, and I write to you now from that console.

Some things I found in my discoveries: when my OS starts up in that resolution, those resolution settings are sent and added to “.local/share/dolphin/dolphinstaterc” and “.config/plasma-org.kde.plasma.desktop-appletsrc”. Both of these store all the resolutions you’ve used since activating your OS, unless they are deleted. The resolutions you currently use will regenerate even after they are deleted whenever the display is activated, as they are not the origin that prescribes what the resolution will be.

If you guys have any future advice for posterity, I’d love to pin that as the solution.