Copy & Paste doesn't work reliably

Hi,

Few months ago I rebuilt my server/workstation completely so new mboard+mem, CPU (Ryzen 1900x) and gfx card (Radeon 500 series). SATA cards remained the same. Took out wifi-card (was not in use) and also 2nd Eth card (mboard has two Gigabit-Eth ports). Previously I used Intel’s integrated GFX but Ryzen Threadripper didn’t have integrated gfx so I had to install dedicated card for this. Running Tumbleweed (fresh installation) with KDE.

The problem is strange and haven’t been able to figure out what is causing it - copy & paste doesn’t work reliably i.e. when pressing copy it doesn’t always perform copy but requires 2nd pressing. Not sure if paste is affected but copy definitely is. This applies also to cut. And doesn’t matter which application I use.

I can see from the clipboard application when pressing ctrl+c that nothing comes to the clipboard until I press second time. A bit earlier the problem was more severe (i.e. few updates before) and seemed to be related to the uptime of KDE i.e. the longer KDE had been running, less reliable copy and cut operations were. This was very annoying with Dolphin when trying to cut files from a folder to move them to another place. You could see a flick of icon change of files (greyed out when ctrl+x was pressed) but immediately returned back to normal. Keeping ctrl+x pressed down for repeat icons starting flicking between normal and greyed out. Release of ctrl+x usually led to normal icons but every now and then remained greyed out and then it was possible to paste them to another location. After restart of KDE this problem was not there but within hours it reappeared. There was no difference if I pressed ctrl+c/x or selected same function from the pop-up menu.

I’ve tried playing with clipboard app settings but nothing seems to help out.

When googling about the issue there seems to be others with similar problems but solutions they had have not worked for me or they have been using different clipboard application/distro etc.

Any idea what is the problem and more importantly how to solve it? I don’t want to change from KDE to something else. KDE serves my needs the best so far.

I think I’ve seen this lately ( cannot reproduce at the moment ), and had one customer reporting this ( on holidays now, so … ). Please report at bugzilla.opensuse.org

This might be related to klipper(KDE cipboard application) not always selecting the most recently copied text.
You could try unchecking the ‘ignore selection’ option in the configuration options(right click clipboard on task bar)
This sometimes helps if you’re switching between xterm and desktop applications frequently.
This problem is one of the few hassles I’ve had with KDE but it can be really annoying and I’m sure will dissuade some people
from using what is a great Desktop environment.

I don’t run into it too often, but GUI frameworks (Desktops mostly) can sometimes be buggy and we should remember that CTL-C for copy and CTL-V for paste are actually ports from the MSWindows world, the original Linux keystroke combos (IIRC) are

CTL-Insert Copy
Shift-Insert Paste
Shift-Delete Cut

You might try those keystroke combos to see if they work…
And if the problem can be reproduced reliably to create a bugzilla report.

TSU

I always stick to X:
Mouse LeftButton-down at begin (or end) of text, move to end (or begin) of text, release button. This copies the texdt “under the middle-button” (and in KDE also to the clipboard).
Left-click on place where to insert, middle click. This pastes.

No keyboard needed.

Tried this setting and at least with Dolphin it doesn’t fix the problem but somehow changes it a bit. First press of ctrl+x to a folder adds something to the clipboard (? icon). This cannot be pasted as a folder but as clipboard content. 2nd press puts the folder to clipboard and then paste works.

Simple text copying seems to work but it’s difficult to say with a short test only. I’ll test more with text as well. Something is anyhow still broken.

Edit: Text copying fails as well so no improvement unfortunately.

Unfortunately I use Windows at the work and copy&paste is in use there a lot. Changing this habit (ctrl+c/x/v) to something else - despite being a native implementation - does not really work in practice, at least not for me. Thx for the suggestion though.

Filed a bug report.

Issue is still present and seems that the reported issue (https://bugzilla.opensuse.org/show_bug.cgi?id=1146018) is not dealt at all.

Decided to give Gnome a go but that didn’t solve the problem either i.e. same copy and cut issue remains. Actually appeared faster than in KDE. Gnome seemed much lighter than KDE in operation but I still prefer KDE…

Nothing has happened to the reported bug either so I don’t know what is the point of the bug tracking system.

Wayland seems to be too unstable to be usable still so have to stick to traditional Plasma. Gnome with Wayland seemed to be stable but KDE is not yet. Full Wayland was a way worse.

Could this be related to Gfx card somehow - or to AMD chipset? Previously I’ve been using Intel (and before that AMD) chipset + integrated gfx in CPU without any such issues.

Replying since I’ve had a very similar problem that I just managed to work around. I’m on tumbleweed with KDE desktop.

My problem was that ctrl+c would put stuff in the “Clipboard” status icon application thingy. But ctrl+v would not paste it unless I copied it again using ctrl+c.

My solution was to increase the “Clipboard history size” setting from 1 to 2. I’d set it to 1 since I don’t really want there to be a log of what text I’ve been copying, but it seems that it’s bugged when set to 1, at least on my system (tumbleweed latest version as of now).

Doing copy and paste is not a difficult task may be some problem has been occurred in the hardware . You can check with hardware specialist otherwise there are lot of experts guidance available online who provide best support.