Constant sunbright screen even though I'm using default graphics drivers - Nouveau

I’m not able to change my laptop’s screen brightness by any method.
Keyboard shortcuts don’t work. Fn + Left/Right Arrow doesn’t do anything. Somehow Ctrl + Alt + Left/Right Arrow works but only a floating notification regarding changing brightness pops up but actually brightness doesn’t change.
Same way, KDE system settings>Power Management>Screen Brightness does the same.

My laptop config -
Acer Aspire V3 - 571G - Intel Core i5-3230M with NVIDIA GeForce 710M graphics card.
I’m using openSUSE 13.3 running KDE with default graphics drivers. I haven’t installed any additional proprietary drivers till now.

Have you made any changes tof the keyboard layout in KDE? Now I use XFCE but at least there some of the laptop layouts, including Acer, were listed as Portable Asus, Portable Acer and a few more, so you would’n find them under Acer, I suppose other desktops could use the same list.
Certainly you are not using 13.3, probably 13.1 and BTW this machine could be an Optimus system, please post the output of this command:

/sbin/lspci | egrep 'VGA|3D'

Try setting the value manually, for example:
echo 50 > /sys/class/backlight/acpi_video1/brightness

I have Acer Aspire V3-771G with openSUSE 13.1 and by default I had 2 services for display brightness:

systemctl status systemd-backlight@acpi_video1
systemctl status systemd-backlight@acpi_video0

My problem was that right after startup when you sould see a login screen I had a blank screen.
After providing password it would reset to normal screen brightness, or I could turn it up with keys Fn + Right.
Some research results offered to adjust GRUB CMDLINE to add “acpi_backlight=vendor” but I did not like that after that I had only 11 (or 10) values for display brightness - 0 to 100 in steps of 10.
Googling further provided an answer to mask the acpi_video0 service so I masked the “systemd-backlight@acpi_video0” service.
It resolved my Aspire’s backlight problems perfectly.

Best regards,

/sbin/lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M] (rev a1)

Yes I’m using 13.1

cat /etc/os-release
VERSION="13.1 (Bottle)"
PRETTY_NAME="openSUSE 13.1 (Bottle) (x86_64)"

Sorry, I replied late, I bricked my laptop. Bricked my laptop after BIOS update - Install/Boot/Login - openSUSE Forums

Maybe you have already tried, but this worked for me in every Linux distros: :smiley:

Well I didn’t see your post before checking out this method Fix Brightness Control Not Working for Ubuntu & Linux Mint else I would have tried your method first.

The method on itsfoss worked on Ubuntu but couldn’t believe this could also work on opensuse.

In a terminal type -

ls /sys/class/backlight/



shows up.
First go to root. Then


sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf
sudo kate /usr/share/X11/xorg.conf.d/20-intel.conf

Enter following command in the .conf file

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"EndSection

Save and exit. Log out and log in again. Brightness control should work now.
rotfl! Don’t know how it works.

Can anyone compare which one is better method.

I have an aspire 5750g and after an update to the 3.17 kernel, which I needed for other puposes, brightness didn’t work for me in no way as in your case.
Now I’ve tried the itsfoss method: Didn’t work.
And then your method with ‘20-intel.conf’ : Worked perfectly. Thanks a lot ! Even the the Fn keys work now.

Navigate to /etc/default/grub and add to GRUB_CMDLINE_LINUX=

 acpi_osi=Linux acpi_backlight=vendor

Resave your changes and run:

# grub2-mkconfig -o /boot/grub2/grub.cfg

Shutdown and restart your laptop so the changes take effect.

I did a default install of 13.1x64 on my HP envy 17-j130us (intel HD 4600 graphics) - I needed to set nomodeset during boot to avoid the backlight issue - and almost everything works except the HDMI port and the brightness adjust keys. I can’t seem to adjust the brightness using any of the knowledge I’ve found here - but I know something is missing…

HPE-OS131:/home/patti # /sbin/lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
HPE-OS131:/home/patti # dir /sys/class/backlight
total 0
HPE-OS131:/home/patti #

This is just a stock video install (nouveau). I tried manually adding the backlight .conf file to /usr/share/X11/xorg.conf.d/, but then my system wouldn’t finish booting.

I see a Linux HD4600 video driver on the Intel website, but it says that most Linux distros already have a driver for Intel. Maybe the “acpi_osi=Linux acpi_backlight=vendor” is all I need to do? Can I add that from YaST? I don’t like trying to command-line GRUB2 and I don’t know how to “roll back” the change if it renders the system non-bootable.

<<confused>> Can anyone point me in the right direction?

Thank You!

Why do you think it has dual graphics and using nomodeset? AFAIK it’s just intel, not intel/nvidia?

In the boot options (Yast -> bootloader -> kernel option) try;

acpi_osi=\"!Windows 2012\"

And remove your no modeset etc.

Thanks for the reply, Malcom, I’ll give that a try. I tried the acpi_osi you suggested, but I also had nomodeset at the same time - so I need to try it without nomodeset. I originally installed nomodeset in order to be able to have the OS13.1 installer work (as I understand it from googling, this is a “backlight” issue - but I am not a smart woman). This is the sweetest computer I’ve ever had, it would be a shame if I couldn’t get the graphics running right. :frowning:

You can also add the other one as well, but yes you will need to remove nomodeset. I have had the backlight issue with HP ProBooks (Fn keys not working to increase/decrease brightness) but reported as a bug and all got fixed.

Malcom - I can add that line in YaST, but if OS13.1 screen then won’t work, then I will need to recover by removing it from the optional parameters line using a command-line control of GRUB2, and I don’t really know how to do that.

I think the way is by editing /etc/default/grub line.

GRUB_CMDLINE_LINUX_DEFAULT=" nomodeset resume=/dev/disk/by-id/ata-Samsung_SSD_850_PRO_1TB_S252NXAG607006A-part6 splash=silent quiet showopts acpi_osi=\"!Windows 2012\""

then running:

grub2-mkconfig -o /boot/grub2/grub.cfg

Then reboot - is that correct? How do I get to the command line to fix?

I should delete that last post - I googled and discovered the “e” key during boot so I removed the “nomodeset” and left the “w*ndows” command, and that fixed both the brightness keys and the HDMI port. YAY!!!

I also tried looking for an Intel driver which would support compositing and 3D stuff, but that appears not to exist as it does for AMD and NVidia cards.

Thanks again!