connman is not working properly with normal user privileges

Hi , I’m facing some problems with connman
the most annoying is that i can’t configure the network without being root , i can excute connmanctl as normal user but it doesn’t function , i get this error message :

Error getting services: Rejected send message, 3 matched rules; type=“method_call”, sender=“:1.54” (uid=1000 pid=3622 comm=“connmanctl “) interface=“net.connman.Manager” member=“GetServices” error name=”(unset)” requested_reply=“0” destination=“net.connman” (uid=0 pid=1308 comm=“/usr/sbin/connmand -n “)Error getting peers: Rejected send message, 3 matched rules; type=“method_call”, sender=”:1.54” (uid=1000 pid=3622 comm=“connmanctl “) interface=“net.connman.Manager” member=“GetPeers” error name=”(unset)” requested_reply=“0” destination=“net.connman” (uid=0 pid=1308 comm=“/usr/sbin/connmand -n “)Error getting technologies: Rejected send message, 3 matched rules; type=“method_call”, sender=”:1.54” (uid=1000 pid=3622 comm=“connmanctl “) interface=“net.connman.Manager” member=“GetTechnologies” error name=”(unset)” requested_reply=“0” destination=“net.connman” (uid=0 pid=1308 comm="/usr/sbin/connmand -n ")

i tried making a group and adding my normal user to it and changing the ownership of connman and connmand group to that new group >>> no difference in result
also tried the same thing with the config files installed by connman in etc >>> no change

how do i run connman as normal user without problems , i don’t think a network manager should have root privileges

connman is not a normal openSUSE program. I don’t see it in the base repos. (maybe in TW??) So where did you get it from and why do you think this will work in openSUSE???

Networkmanager and wicked are the two normally used. Both require some root interaction. (Netwrorks are a system thus root operation). wicked is configure in Yast and does require root. NM is user space but some settings require root.

I checked. It is in Tumbleweed repos, though not installed in my system. The descriptions says that it is intended to manage the network on Internet appliances, so it is probably not intended for an ordinary desktop user.

yes , i got it from tumbleweed repos. ,
i used networkmanager since the beginning of my linux days till recently , i suffered from it’s slow wifi and bad signal until i used wicd , wicd was much better speed-wise but android Studio didn’t start because of it , so i switched to connman a few months ago and it was very good , a bit tricky to get it working at first but once it’s working it’s much better than the other two for me[size=4]

I use connman in slackware without root permissions , i think the problem here may be related to the firewall implemented in opensuse ( i may be wrong ), and i don’t have experience with firewalls [/size]

it’s originally intended for embedded systems because it’s better in starting time and energy efficient (battery consumption) , i use it in my laptop and i just love it

Could you please refrain from formatting your posts like you’ve done so far. Please post plain unformatted text and output between CODE tags. IMO your current style is horrible and makes your issues completely unreadable, i.e. think of the people out here trying to help and having to read this.

Thanks for the note; small text get my eyes tired , and i don’t like other people eyes get tired as well , but I’ll leave this reply in small font size for you if that’s your personal preference :slight_smile:

You can always scale up your web page view (CTRL +) to suit.

I can’t see any advantages with using connman over NetworkManager (or wicked for a static server environment), but in an effort to assist I had a look at the packages displayed here…
https://pkgs.org/download/connman
I’m using Leap 15, so added the utilities repo like this

zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/network:/utilities/openSUSE_Leap_15.0/ opensuse-network-utilities

then installed connman and connman-client packages to perform basic testing. I stopped/disabled NetworkManager.service and then enabled/started connman.service. After a few seconds I had wired (DHCP) connectivity again.

I note that the CLI interface is via connmanctl, and the permissions allow it to be run as a regular user…

 # ls -l /usr/bin/connmanctl
-rwxr-xr-x 1 root root 115656 Sep 25 07:13 /usr/bin/connmanctl

I have no problem running this as user, so I’m not sure what problems you encountered specifically. I don’t plan on keeping this network management framework for long.

Thank you for your help,i really appreciate it
i tried something and just found a solution
from tumbleweed repo there is a package called "connman-nmcompat " i installed it and it solved the problem for me

Thanks for the update. I note that package “Provides NetworkManager compatibility for Connman (Connection Manager).”. So, you’re using this with NetworkManager?

Anyway, good to read that it’s working as expected.

no , not with network manager , i don’t think i will ever use NetworkManager again , this package enable compatibility for NetworkManager programs that are not aware of connman (they don’t know if you are online or not ) i installed it to solve a problem with firewalld which keep saying "Failed to get connection from network manager "
the package solved the root privileges issue but the firewall problem still on , i don’t know how , probably a bug

Thanks for the further clarification. I’m not sure how it helps with the privileges issue though. I’m currently using connman without it.