Connecting to windows shared folder with rw permissions

Hi guys, I’m trying to figure out how to do this right … without success :smiley:

My problem, is: I have a machine running on windows 10, with some shared folder “sharedfolder” and I gave to “myNetUser” the permission to read and write. Now I’m trying to mount my shared folder on my OpenSuse machine but I have no permission to write on that folder, when I use:

sudo mount -o username=myNetUser,password=thePassword // /mnt/sharedfolder

In my linux machine the user is “linuxUser” … if that’s a problem (as it’s different from “myNetUser”)

The “strange thing” is that if I use dolphin and I go to network > samba network and I put I can access the windows machine folder and write on it … but how can I mount it? and how to auto mount the folder at OS startup?

Thanks, for any help about it :slight_smile:


  • Explicitly specify the smb protocol in your mount command
  • Verify the Workgroup/Domain name is specified correctly (ie careful with the camel case), if the Client’s Hostname doesn’t naturally pass that, then specify in the username, et name@domain. Your client’s SAMBA config may be providing this automatically.

Share logs on the Server can usually provide a clue exactly what the error is.


To begin with, I am not a Windos user and not a Samba user.

But when it is working when it is mounted by Dolphin, why do you not look how it is mounted then and copy that to your fstab entry?


and search to the list, I bet you can identify it.

Hey guys!

TSU, I tried to figure out the “Explicitly specify the smb protocol …” part and I supposed it would be something like smb://192.168… but it doesn’t worked (considering that one as the way to do it)

So I made some more test (as dolphin can do it!!), and found a way to make it works for my “linuxUser”:

sudo mount -t cifs // /mnt/sharedfolder -o username=myNetUser,password=thePassword,uid=linuxUser

hcw, I’d like to understand how can I see the way Dolphin mount the shared folder. Where it is supposed to be? Where should I search for it?

Thanks a lot guys!!!

… as Henk said, after you mount it in Dolphin, simply drop to a terminal and issue the command:


You then will see a list of the mounts and the options they are loaded with.

Ok! I was assuming that mount cannot go without any option or flag!

That’s great! Thanks!

Well, as with any command you use, you should at least check what it is used for mainly and maybe even in more detail by reading:

man mount

But the main question is not if you now understand what we advised you to do, but if you did it and if it helped. And maybe even show what you got, so we can offer advise on what you see and how to interprete it.