Connecting Nokia 6300 phone with gammu/wammu: Unknown, busy or no permissions

Hello there,

I know, this is an old technology, but my 11 years old mobile phone sick, broken screen.

For few days I try to connect to my phone with gammu (ver 1.39.0)/wammu (ver 0.44) but even with a lot of reading I failed.
My goal it to collect the data, at least the phone-book.

I run Linux box Opensuse 15.0. My phone is Nokia 6300 broken screen but I succeed to connect it through usb<>miniusb to my computer.
I get:
[FONT=arial]~> lsusb
Bus 009 Device 005: ID 0421:04f9 Nokia Mobile Phones 6300 (PC Suite mode)
~> dmesg
[10544.800648] usb 9-2: new full-speed USB device number 4 using ohci-pci
[10545.001508] usb 9-2: New USB device found, idVendor=0421, idProduct=04f9
[10545.001513] usb 9-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[10545.001516] usb 9-2: Product: Nokia 6300
[10545.001518] usb 9-2: Manufacturer: Nokia
[10545.055731] cdc_acm 9-2:1.1: ttyACM0: USB ACM device
[10545.058160] usb 9-2: bad CDC descriptors
[10545.058421] usb 9-2: bad CDC descriptors
~> gammu-detect -b
device = /dev/ttyACM0
name = Nokia Nokia_6300
connection = at

Computer setup:
~> groups
users dialout
~> getent group | grep users
~> ls -l /dev/ttyACM0
crw-rw---- 1 root dialout 166, 0 Sep 7 08:54 /dev/ttyACM0

Maybe this next I should change something but I don’t know what and how
~> ls -la /usr/bin/gammu
-rwxr-xr-x 1 root root 376504 Feb 16 2018 /usr/bin/gammu

I even tried to add a file in */etc/udev/rules/ *directory, file name: 99-phone.rules
SUBSYSTEM==“usb”, ATTRS{idVendor}==“0421”, ATTRS{idProduct}==“04f9”,
MODE=“0666” , SYMLINK+=“ttyACM0”, GROUP=“dialout”

Maybe I don’t need this rule as I am the only user in my home computer.
Should I leave or remove it?

When I try with wammu with the wizard: Guided conf > USB cable > Nokia phone > AT based > Generic AT > ttyACM0
I get the error message
Description: Error opening device. Unknown, busy or no permissions.
Function: Init
Error code: 2

I have read “Did you check that you actually have permissions to access the device?”
I don’t know how!

Could someone help me?
Thanks for your help

Nota: Gammu mailing list seems to be abandoned

You need to look at switching it to storage mode, rather than modem mode with usb_modeswitch. Else take it to your phone provider and see if they can collect the info for you.

I didn’t mention that I can connect in storage mode and can copy some folders with Nautilus (Caja):
Music files
Received files
Video clips

but not the phone-book
I think the only way to get it is in PC Suite mode.

Thanks for you answer
Another idea?

Create a Virtual win machine to run the software on to extract the info? Or maybe wine?

Don’t you think it is a permission issue?

I have read that gammu/wammu is not working with wine.

I wouldn’t think so since it’s working in storage mode, if the contacts are there then it’s a different issue like the application talking to it (database?). I would imagine you can transfer the contacts via bluetooth, but since the screen is damaged, can’t see what you are doing. Can’t you just go to your phone provider and ask them to get them off and take a USB device for them to put it on?

In storage mode, the phone is mounted like a USB drive and I use Nautilus (in fact caja Mate) but in PC mode I use gammu/wammu. So maybe a property is not good in appli or config?

I think your (or me?) are confusing the two modes, PC mode AFAIK is to allow the phone to act as a modem to connect a pc to the internet via your phone.

So what can you access on the phone via Gammu, what can you access on the phone via Wammu, if nothing I suspect your model phone is just acting as a modem.

When I connect the phone in storage mode, I have “Nokia 6300” mounted in Nautilus but with gammu-detect -b, I get

~> gammu-detect -b
device = /dev/ttyS0
name = Phone on serial port 0
connection = at

device = /dev/ttyS1
name = Phone on serial port 1
connection = at


to [gammu 31], not the name of the phone. And wammu can’t detect the USB port used.
I can see the SIM card and the folder Gallery, I wrote in a previous post. Unfortunately not the phone-book

When I connect the phone in PC mode, I get what I wrote in the first post. Wammu can detect the USB port /dev/ttyACM0
AFAIK, from my reading, storage mode can’t read some phone data like message, book, only PC mode can read all phone, SIM and SD data.
Wammu should be able to read the phone-book in the GUI.
In fact I am stuck at the identification, just after detection with the error message "Error opening device. Unknown, busy or no permissions.".

I have read “Did you check that you actually have permissions to access the device?”
This is why I think a permission issue.
I don’t know how to check that. Any idea?

Since the serial side of permissions is the dialout group fire up YaST Users and add yourself to the dialout group, save, logout/login and see if that helps.

I did that 2 days ago and reboot

~> groups
users dialout

This morning, I placed gammu/wammu in the group dialout as well

~> sudo chown root:dialout /usr/bin/gammu

then stop and restart the app. => no luck!
then with my username instead of root => no luck!

In this thread here, poka wrote

You have to give goods permissions to gammu:
chown root:gammu /usr/bin/gammu
usermod -a -G gammu rafael

I don’t understand what is the purpose of usermod. What do you think?

That’s just adding the gammu group to the user rafael, so via YaST users add your user to the group.

So, I don’t know what to do now…:’(

Since you can see parts of the phone but not the phone book then maybe permissions must be set on the phone to allow remote access. How to do that with a broken screen???