Connect to internet through company network


I freshly installed opensuse Gnome 11.2 version and having troubles connecting to internet. I have dual boot on my computer - MS Windows XP and OpenSuse Gnome. No problem connecting to internet from the windows version.

I believe the part of the problem connecting to internet from the open suse is because my computer is within company network.

The ip address is:
default gateway is :

I have already ran the network manager and input all information that was need but without luck.
What would be a standard procedure to set up network under above mentioned circumstances?

I appreciate your response.


Who gave you these addresses?
Did you enter the correct subnet mask?

Also, how come, you got a DHCP address?


Thanks for reply. The addresses I got from the command console and by typing ipconfig/all. It gave me everything I need.

Subnet mask is I reentered information couple times and even reinstal opensuse couple times. I also tried to set up the network during the installation process but it does not work.

Again, I believe setup needs to be different once the computer is within private (company) network. But don’t know how to set it up.

Again, I will appreciate any information to get it running. Thnak you.

If the address was obtained automatically by DHCP in Windows, you can do the same thing in Linux too. You don’t have to feed in all those details there. Just use it to use DHCP settings.
Once that is done, go to a terminal and see if it has really obtained the IP address and routing information.



Well thanks so much for your response. I really appreciate it.

Anyway, now I have a little icon that says 'Wired network connection 'Autho eth 0 active’but when I open my mozilla and type something like, at first it shows ‘looking up’, then ‘connecting…’ but it never connects to it.

What else needs to be configured for it to run??

Probably you need to set your web browser to use the company web proxy. Many enterprises don’t allow direct surfing, but require you to go through a proxy. You could try to autodetect the proxy setting, for Firefox: Edit > Preferences > Advanced > Network > Connection > Autodetect proxy. If that doesn’t work you’ll have to ask your sysadmin what the URL of the company proxy is and fill it in.


Thanks so much!!! I used our company proxy and it works. Hehehe…happy person right now. :wink:


Excellent. Enjoy Linux.

Keeping on the same concept, I have a question/problem that goes to the step beyond getting the browser working. During the installation of 11.2 we added the system to our Windows domain and I can browse all the machines in the network, etc. I can even connect to our VPN from home wiht this notebook (yay!). We use an ISA server for our VPN and for our outbound proxy. I cannot for the life of me get the system to go through it for things like updates, etc. I’ve tried with both the Yast Proxy configuration tool as well as the “Control Center” Network Proxy without success. The ISA server claims that it’s not being passed credentials although I’m hard-coding them (although I’d rather not have to).


Hi John,

I have exactly same problem as you and often getting ‘ERROR 407 proxy authentication required’. Meantime the proxy settings (from Yast) are tested successfully, can connect to opensuse updates via Firefox but can’t run ‘online update’ through Yast. I have a feeling the whole thing needs to bypass company security and proxy settings but have not clue how.

I just randomly came across ‘cntlm’ that supposed to take all proxy into your hands and currently testing it for Windows but it is another headache to figure out how to properly configure the whole thing. Will keep you posted and vice versa let me know if find out something.



Hi Lubica,

I can’t imagine that we are alone with this. If I find something or get it figured out I’ll definitely let you know. The only thing that is getting through our proxy is Firefox. Nothing else (the system, Evolution with it’s own settings, etc.) is getting through. From what we can see in the logs, the credentials are not being passed to the ISA server. Hopefully we’ll figure it out, or someone that’s been there and gotten it to work will respond. Unfortunately, I don’t think that cntlm is going to be a viable option for me, but we’ll see.


Hi John,

Ok came to something. Forget about the cntlm. Make sure you have correct repositories (update configuration repositories).

Then open terminal, login as root (su and then password), and type ‘export ZYPP_ARIA2C=O’, after that type ‘yast2 -i’. This should invoke software management update.


you login as root, type ‘export ZYPP_ARIA2C=O’, then zypper dup. Your update should start this way as well.

It has something to do with ‘bad’ aria. So at some point find online update Aria (aria2-1.8.0). It should fix the problem with online update.

Good luck :slight_smile:

Hi Lubica,

Great! I just downloaded and installed the update. The repository where it’s located wasn’t in my list for some reason, but is now. I’ll try it tomorrow when I’m back on the network in the office and let you know.

Thanks for the update!

No luck. I tried playing with curl directly. I can get it to go through the ISA proxy regardless of what I use for a password, if I specify anyauth for the authentication method. I tried some of the authentication methods directly, such as ntlm and basic, but it only worked when I use anyauth. I don’t know what the system proxy uses as a method. Anyway, I’m still digging. This is really strange. It really shouldn’t be this difficult, you know?

I can not get it to work… Have to check with the security group and see if they can see what is going on :wink:
Here is what I did:

export ZYPP_ARIA2C=O

yast2 -i

I still get this:
Download (curl) error for ‘’:
Error code: HTTP response: 407
Error message: The requested URL returned error: 407


Have you tried to update directly in konsole using these commands:

  1. export ZYPP_ARIA2C=O
  2. zypper dup


I found this article online and someone had the same trouble with earlier version of opensuse. You can give it a try

Yast and Curl error - HTTP 407 ? -

I suppose you can connect to all the update links via Firefox.

Also I found this article: [opensuse-factory] Defunct package management stack behind proxy with au](

Hope any of these will help. Let me guys know.

Good luck :slight_smile:

Nada for me… YUM does not appear to be there unless I am reading it wrong (always possible). Interesting that the system does not appear to auto mount the DVD drive and tells me there is no media… I am begining not to like 11.2



Honestly, then I don’t know the solution to your problem.:frowning: I am a beginner to opensuse. Just trying to advice with what I have learned so far.

I assume your computer is the part of a company network. Can you bring your machine home and try updating it this way? I believe there would be no need for proxy to be configured properly. I think.


I’ve also run into a problem running updates on 11.2 from behind a proxy requiring authentication. Firefox runs find and prompts for proxy authentication when needed. I tried updating Aria to 2-1.8.2 and ran yast2 -i with no success. zypper dup also ran into problems but all it says is “failed to download.”

After going through the yast log in /var/log/YaST2/y2log I think I found the problem: yast calls aria to do the actual download and passes the proxy server address, but NOT the proxy authentication information. I grabbed the command from y2log, added the authentication stuff manually and ran it on the command line and it worked! The trick now is how to force that information to be passed to aria. I tried changing environment variables, etc to no avail.

My Suse box is a VMWare virtual machine, so theoretically I can take it home and run updates, but the point is I shouldn’t have to do that. I may try Suse 11.3 or an entirely different distro, though we run Novell stuff at work and it’s kind of nice to keep it all in the family so to speak.

I too have this problem. I tried editing /etc/sysconfig/proxy to include the authentication inforamation in the proxy strings [e.g. http_proxy=http://user:pass@proxy.server:80] and noticed that the next aria call did contain this information. It did no good, though, as I still couldn’t download the pagkages file: CAUGHT: Failed to download /suse/setup/descr/packages.en.gz from Index of /distribution/11.2/repo/non-oss

aria2c --version

aria2 version 1.5.2
Copyright (C) 2006, 2009 Tatsuhiro Tsujikawa

** Configuration **
Enabled Features: BitTorrent, GZip, HTTPS, Message Digest, Metalink
Hash Algorithms: md5, sha1, sha256

This information offered in case it helps with the debugging.