Configuration VNC from yast failed.

Hello all…

I’ve tried to configure VNC access via yast in opensuse tumbleweed, but it failed.
After setting flag “enable VNC access” in VNC configuration window, yast try to save configuration and failed with all my X session, and after this i am in console.
After reboot all works fine, except VNC configuration - it is unchanged from previous state.

I can paste some logs here, but i need to know which will be useful.

Is it a known bug, or i should report it to bugzilla?
If it is a known bug, are any workarounds exists?

The YAST setup tool automatically sets up and configures a common configuration for vncviewer and the java applet (typically running in a browser), and you should select the button for “Allow Remote Administration.” The first time this is run, this should install a number of required xorg packages (Is this why you’re failing?)

Documentation for troubleshooting exists in a number of places, this is one. Verify your configuration file enables whichever display configurations you want.
**Useful openSUSE community documentation **
in particular I recommend you doublecheck the configuration file, you should see only the first display enabled for the vncviewer, and then the java applet configurations.


If the YAST tool returns an error,

  • You should post your distro version, which can be returned by the following command
uname -a
  • You should identify your Desktop
  • You should post any error that displays, either copy and paste using the code tags in your Forum editor (#) or do a screen capture or photo and post. I’m not sure what you might mean by “all my x session” - Remote x sessions can be different than a local session, and you can’t configure multiple x sessions using the YAST tool alone (You can edit the vnc config file manually afterwards to enable this and more).