conected to router but no internet

Looking at some of sd3782’s replies again, give me the impression that he has other pc’s running on the network - we know he uses a laptop to reply here.

And then out of the blue, it struck me!
I remember from when I had cable, the cable router gives an ipaddress via dhcp and this is not on the private 192.168.xxx.xxx ranges. The trouble is that this also logs the mac address of the first nic you use to connect to it and won’t let you connect with a different nic.
This meant that I had to do some nic swapping when I put in my smoothwall box and got the local network running.

I would wager that 192.168.1.1 is the ip of another pc on the network and not the router’s ip.

sd3782:
The laptop you are using for your replies - what os is it using?
If windows, open a command line and type ipconfig /all and you should get all the relevant details.
Was this perhaps also the first pc you used to connect to the internet?

Hmm, two systems with the same IP address. Could be it.

Hi, thanks again for all your help. Unfortunately not been able to use this laptop for the last couple of days (the only laptop on which the internet works), but now I’m back to trying to resolve my internet connection.

This working laptop is a Mac. I’m pretty sure it is on the network as 192.168.1.3 and my Linux laptop is on as 192.168.1.2 (I know this because of the ‘Attached Devices’ on the router web interface. My laptop is obviously connected because it is displayed as LINUX-PGQI).

When you say you logged into the router, how did you do this - via a web browser and typing in the ipaddress 192.168.1.1?

Yes,I use firefox to access the router at “http://192.168.1.1/start.htm”.

I remember from when I had cable, the cable router gives an ipaddress via dhcp and this is not on the private 192.168.xxx.xxx ranges. The trouble is that this also logs the mac address of the first nic you use to connect to it and won’t let you connect with a different nic.
This meant that I had to do some nic swapping when I put in my smoothwall box and got the local network running.

I would wager that 192.168.1.1 is the ip of another pc on the network and not the router’s ip.

sd3782:
The laptop you are using for your replies - what os is it using?
If windows, open a command line and type ipconfig /all and you should get all the relevant details.
Was this perhaps also the first pc you used to connect to the internet?

This Mac laptop was indeed the first machine that I had connected to the network when it was first installed, but I have had both laptops working on here for 5 months. It was only last week that my Linux connection stopped working.

Is there any logging in your router, where you could see why your packets are skipped (or routed in the wrong direction) by the router.

There is logging on the router and I’ve turned on Site Blocking - the only way I can get it to display useful information. So when I visit a site on this laptop (Mac), I get the message:


[Site allowed: www.google.com] from source 192.168.1.3 Wednesday, Sep 09,2009 23.11.56

But when I try to access google from my Linux laptop (the laptop on which I’m viewing the router log through firefox), I get nothing. Nothing appears in the log. Absolutely nothing, so unfortunately no help there!

Some other information about the router that might help (taken from the router web interface):

LAN TCP/IP Setup
IP Address: 192.168.1.1
IP Subnet Mask: 255.255.255.0

Use Router as DHCP Server: "YES"
Starting IP Address: 192.168.1.2
Ending IP Address: 192.168.1.51

I’ve also tried reserving the address 192.168.1.2 for my Linux laptop using the MAC address, but this doesn’t help (has no effect - it already had IP 192.168.1.2 anyway).

So in summary, my laptop is definitely connected to the router (192.168.1.1) using IP address 192.168.1.2, but there is nothing in the log when I try to connect to an outside website.

Any more help and advice will be greatly appreciated. Thanks in advance,

Sam

The only other things I can think of to ask are:
What router do you have, does it have a make/model name?
If your router allow both the Mac at 192.168.1.3 and linux box at 192.168.1.2 to connect simultaneously, can you ping each other?
On the linux box, are you using a network manger or ifup? I a connection manager, try setting it to ifup.
Another thing to try is to perhaps set the linux ipaddress to 192.168.1.52, say and try.

If you can login to the router, then your NIC must be working.
AFAICS you still have a config issue in the router.
If you use address reservation then use it for all devices, so there is no confusion and each device has a specified IP on the LAN.

What router do you have, does it have a make/model name?
If your router allow both the Mac at 192.168.1.3 and linux box at 192.168.1.2 to connect simultaneously, can you ping each other?
On the linux box, are you using a network manger or ifup? I a connection manager, try setting it to ifup.

It’s a NETGEAR Wireless-G Router “WGR614 v9” router. Yes I can ping this Mac laptop from my Linux laptop and vice-versa.

I was originally using Network Manager, but I’ve tried using ifup too, but with no success.

Another thing to try is to perhaps set the linux ipaddress to 192.168.1.52, say and try.

I set address reservation on the router for my Linux laptop to have 192.168.1.51 and tried again. I can ping successfully between the laptops again, but I still can’t access the internet from my Linux box.

I’m going to take my laptop into work and see if I can connect to the internet there, to hopefully determine if it’s definitely a problem with my laptop, or perhaps something with the router. I’ll keep you posted.

Thanks again all,

Sam

Just a thought:
You said earlier that you can ping an outside ipaddress but it seems you can’t resolve a name.
Some routers don’t pass on the gateway and dns server addresses to the dhcp client.
Check in yast>network> to see that the gateway and dns are set correctly.
Even with dhcp enabled, it will allow you to set gateway and dns.

@whych. Sorry, but because of the long thread you lost something: he can NOT ping anything on the internet. So it is not just a DNS serrver problem, there is no outside connnection.

Henk, in post 17 he says he can ping the dns.

sd:
Looking at the setup doc for the router, I think it could be a router problem. The router has its own firewall and it allows you to block internet access to cards that are not listed.
Try turning the firewall off and allowing all traffic through.
I think we have established that networking works on the linux pc, so if the gateway and dns is set correctly, it must be a router problem.

I am sorry if I am a bit lost, but I asked him to ping 130.57.4.15 in Post #10. In Post #11 sd3782 tells it does not work. In Posts #15 and #16 this is repeated. Then in Post #17 it seems to be possible to ping to ‘some’ Internet addresses.

Now could this be solved? Can we ping IP addresses (and maybe even connect a browser to 130.57.4.15) because then it is a DNS problem.

Like you say, it’s all a bit confusing.
But looking at the router manual, it has a network blocklist that will only allow listed network cards external access, hence the suggestion to turn off the router firewall.

The only other thing we haven’t tried is a traceroute to an ipaddress.
Perhaps traceroute to an ip on the internal net and one to an external ip will tell us where it gets dropped.

Yes, forgot completley we have traceroute. Hello sd3782, do you know traceroute? Use it instead of ping and see what we get. I am realy curious.

Thanks again for your replies.

The confusion is that I can ping the DNS successfully, but that is the only outside host I can ping. Or so I thought when I started writing this reply…

I’ve tried ‘traceroute 130.57.4.15’ and got the following result:


traceroute to 130.57.4.15 (130.57.4.15), 30 hops max, 40 byte packets using UDP
Unable to look up.........

OK, so I use the -n flag to avoid DNS lookup, which otherwise fails for everything. Now I get the following:


 1  192.168.1.1 (192.168.1.1)  0.835 ms   0.741 ms   0.683 ms
 2  10.231.40.1 (10.231.40.1)  6.869 ms   5.599 ms   8.286 ms
 3  81.100.0.109 (81.100.0.109)  8.062 ms   8.040 ms   7.873 ms
 4  212.43.162.57 (212.43.162.57)  8.645 ms   23.894 ms   19.572 ms
 5  195.50.91.69 (195.50.91.69)  7.181 ms   7.707 ms   7.437 ms
 6  4.69.139.97 (4.69.139.97)  7.533 ms   10.637 ms   12.396 ms
 7  4.69.137.70 (4.69.137.70)  80.894 ms 4.69.137.66 (4.69.137.66)  80.633 ms   80.409 ms
 8  4.69.134.70 (4.69.134.70)  81.016 ms 4.69.134.78 (4.69.134.78)  86.059 ms   92.152 ms
 9  4.68.16.5 (4.68.16.5)  86.453 ms 4.68.16.133 (4.68.16.133)  87.018 ms   81.850 ms
10  4.68.127.150 (4.68.127.150)  79.116 ms   76.715 ms   79.142 ms
11  12.122.131.138 (12.122.131.138)  167.708 ms   164.091 ms   163.232 ms
12  12.122.1.2 (12.122.1.2)  155.805 ms   156.015 ms   153.407 ms
13  12.122.2.53 (12.122.2.53)  155.868 ms   162.838 ms   158.638 ms
14  12.122.31.85 (12.122.31.85)  155.083 ms   155.106 ms   155.798 ms
15  12.122.30.25 (12.122.30.25)  156.679 ms   155.855 ms   155.416 ms
16  12.123.156.5 (12.123.156.5)  180.372 ms   181.498 ms   172.828 ms
17  12.127.106.34 (12.127.106.34)  162.825 ms   162.023 ms   162.886 ms
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

I’m afraid it doesn’t mean much to me. So I tried to ping some of the above. I can still ping the router on 192.168.1.1, but the following were interesting:


PING 10.231.40.1 (10.231.40.1) 56(84) bytes of data.
From 10.231.40.1: icmp_seq=3 Packet filtered
From 10.231.40.1 icmp_seq=3 Packet filtered

I got the above the first time I tried, but then every other time I get nothing back.

… and successfully pinged 81.100.0.109

… and successfully pinged 212.43.162.57

… and 195.50.91.69 … and 4.69.139.97 (it would be easier to list of the above I can’t ping.)

They are: 10.231.40.1 (see above), 12.122.131.138, 12.122.1.2, all the rest beginning 12, except for 12.123.156.5, which I can ping with success.

A bit confusing, but I hope that this may shed some light on the problem.

In other news, it’s certainly not a problem with the router, because I have tried this in my office and at a friends house (where I have connected to the internet before) and was again able to ping the routers, but not connect to the internet.

Sam

sd3782
If you try and open the router homepage at 192.168.1.1 with firefox with eth0 running, will it allow you to connect?
If it does, try resetting the router and its firewall to allow all connections (ie, turn the firewall off) and try again.
It looks like something in the router settings is blocking your access.

I would also turn off the router dhcp and set a manual ipaddress and network for eth0 and try again.
(This means you have a dumb router that will allow all traffic to connect to the outside.)
If you have another pc (ie the mac laptop) connected to the router as well, you should be able to see it from the linux box and vice versa as well. This would mean the internal net works fine.
You should also now be able to reach the outside world.
You can start tying down the access once it all works.

Thanks to Henk and whych for your help, but I’m going to re-install Linux and go back to the start. It’s annoying because it took me ages to set up sound and DVD, etc. But I should be able to do it quicker next time and I’ll take plenty of back-ups.

I feel like I’ve tried everything, the internal network is fine, but it’s not anything to do with the router, because it doesn’t work on any of the other networks I’ve tried, at work, or friends’ houses.

But it’s good to know there is plenty of help out there when I need it next.

Thank you.

Not sure if this is the same issue, but for me the /etc/resolv.conf file does not change or get updated when I connect to different networks. I have to manually run dhcpcd wlan0 to get resolv.conf to reflect my new location dns. I’m working figuring out why.

I know this thread is old, but I am having the exact same problem. I can connect to the router after I boot, but the internet doesn’t work at all. If I type “dhcpcd wlan0” into the terminal the internet works until I next reboot. How can I do this automatically without having use the terminal? This computer is going to be for my computer illiterate mother, so simple is good!

Also I don’t know that this is related, but the update applet won’t work with the message of “PackageKit Error no-network: Cannot refresh cache whilst offline”. Using YaST to do it manually works after I type dhcpcd wlan0 into the terminal.

Thank you for any help on the matter :slight_smile:

Check that you are getting a nameserver address. If you are getting your ip address from the router, check the router is set up to supply a nameserver and gateway address. (Usually set to the router address).
Try pinging 195.135.221.134 (ftp.opensuse.org). If you get a reply, it means you have no nameserver set.

I tried pinging that ip in the terminal, but got this as a response: “Network is unreachable”

Thank you very much for your help whych.

This is a fresh install which seems strange. I have a windows computer that connects fine to this router. Also, I can access the router login page from the Linux computer. Later today I’ll take it to a friends and see if it connects to his network.

If you can reach the router then it’s a network setup problem.
If you are using a wired connection, go to yast2>hardware>network and set it to ‘traditional with ifup’. Quit and then go back and set the gateway and dns addresses.
(you can get these from the windows pc by opening a command window and typing: ipconfig/all.
Make sure the linux box has the same network range as the router.
You should be able to get the router to pass these settings to you when the network dhcp starts.