conected to router but no internet


I’ve seen lots of other issues similar to mine on this forum and others, but had no joy in resolving this problem.

I can connect to my router web interface, using both wireless and ethernet cable, but cannot connect to the internet with either.

I can’t ping any IP address or hostname.

When I type route into the terminal, I get:

Destination Gateway     Genmask       Flags Metric Ref Use Iface
default UG    0      0   0   eth0 *  U     1      0   0   eth0
loopback    *      U     0      0   0   lo
default       UG    0      0   0   eth0
default       UG    0      0   0   eth0

There are extra ‘default’ destinations in there, because of things I have tried from other posts.

I have had internet working. It was working for months, but it all stopped working when I installed Skype, vpnc and kvpnc (VPN Client GUI).

I don’t know if this is just coincidence. I did get connected to my VPN, but shortly after installing Skype, everything outside my local network (i.e. internet and VPN) stopped working.

I’m writing this from another laptop on the local network, so the internet obviously working fine - just not from my own laptop.

I’m running openSUSE 11.1 (i586), KDE 4.1.3 “release 4.10.4”. And in “sysinfo:/” it says Network Status: “You are online”

Like I said, internet doesn’t work for both ethernet and wireless. Can’t ping anything. I can access router web interface at

Any help would be greatly appreciated!

Thank you.

Try this:
Disable IPv6 - openSUSE Forums

Hi, thanks for your reply, but that didn’t help. Any other advice?

It was working for months, it’s only just stopped working for the last couple of days.



The first ‘default’ route must be deleted. It being the first one it is used (and it is wrong) and not the other two (which are correct and equal to each other, so only one is needed).

Why has got a metric of 1 - usually this would be zero. Are you sure you don’t have a problem with your internal firewall blocking everything?
Also appears 3 times.

OK, thanks all for your help, but still no joy.

I have restarted, and the output of route, with no messing around to it, is as follows:

Destination Gateway     Genmask       Flags Metric Ref Use Iface *  U     1      0   0   eth0 *  U     2      0   0   wlan0
loopback    *      U     0      0   0   lo
default       UG    0      0   0   eth0

I don’t know what the metric is or why it’s non-zero where it is. Any more advice? Any ideas why it just stopped working two days ago?


What IP do use to login to the router

This is still strange, bercause now wlan0 emerged with was not in your original story. Normaly only one NIC accesses one network. You have two NICs connecting to

While I admit that it is a bit strange that the metric is used here, I am not sure if it matters. In any case we should first be certain that the routing table is correcet, so please tell us more about the popping up of wlan0.

I use to login to the router web interface.

I don’t know why the wireless wlan0 was there in the route table. It’s not there anymore… although when I click on the NetworkManager tray icon, it says my eth0 (DHCP) and wlan0 are connected, but shows the picture of the ethernet cable.

So now it’s just:

Destination Gateway     Genmask       Flags Metric Ref Use Iface *  U     1      0   0   eth0
loopback    *      U     0      0   0   lo
default       UG    0      0   0   eth0

Also, it takes a long time to return the routing table when i type in route. In fact when I type ‘time route’, it takes real 0m45.039s. Is that normal?

Thanks again for all your help.


The routing table now looks nice. But try get rid of all references to wlan0 so it does not return somewhere.

About the long time of route: Does this also happen with route -n? Because *route -n *does not consult DNS and when DNS is a problem it takes time to time out on every IP address in the routing list.

And what about trying to ping to This is the IP address of, but of course the using the IP address DNS is not consulted.

‘route -n’ returns immediately, so I guess there’s a problem with DNS. But ‘ping’ doesn’t work. Prints:

PING ( 56(84) bytes of data.

And gets nothing back.

What hcw is trying to say is that you can’t have 2 nics running at the same time in the same machine that are on the same network.
In your case, the ethernet card and the wirelass lan can’t both be on at the same time. If the wired lan is connected, the wireless must be off and vice versa.
This explains why your routing table looks different when you have wired or wireless running.
Since you use the same gatway for both wired and wireless, try going to yast>network devices>net settings and set it to use ifup and exit.
Now go back and set the router and dns addresses in the network settings.
when done, try a ping again and see if it works with the wired net.
If there is no network bring it up manually a root in a terminal and type ifup eth0 or eth1 depending on the name of the wired net and try again.
If all is well, you can enable the network manager and use it to enable lan or wlan.

OK, so I set it to use ifup, exited, and went back into Network Settings and set the default gateway (on the routing tab) to

I tried to ping and got nothing back, so I tried ‘ifup eth0’ and got the following:

    eth0      device: Marvell Technology Group Ltd. 88E8071 PCI-E Gigabit Ethernet Controller (rev 16)
DHCP4 client is already running on eth0
IP address:

And ‘route -n’ returns the following, which is very different to before:

Destination Gateway     Genmask       Flags Metric Ref Use Iface U     0      0   0   eth0   U     0      0   0   eth0     U     0      0   0   lo       UG    0      0   0   eth0

Any other advice? Thanks in advance,


OK so the network card (eth0) is set to with as gateway. The 169… is the default private address range for when no network is set and shouldn’t be there.
Leave eth0 set at 192…2/24 andm make sure that the wireless card is set as ‘not configured’. Now reboot.

When you log back in, try pinging the gateway - it’s always good to test your local net first to see if it’s working.
If the network is working, you can now start on setting up the wireless.

What you show us looks allright.

The ‘ifup eth0’ did give a message that it is allready up using address (with the corrects mask), exactly what we wanted and expected.

The route to is to the so called zeroconf network. When you want to know what it is look it up in Wikipedia. In short we do not need it and it is not in our way.

The routing table is correct.

Now the ping to did not work, but did you try the first part of the route, to the router?


When that does work, you can reach the router. And when the ping to outside does not work, there is something wrong with the router.

Yeah I can ping OK. But not outside.

So do you think it’s something wrong with the router? But I’m using the same router right now from this different laptop.

Thanks in advance,

OK, so you’ll have to forgive my ignorance here, but I’ve been investigating further and found the following, which may or may not be of any help at all:

I’ve logged into my router and found the the DNS is ( and I can ping it.

I’ve found that the DHCP server is and I can ping it.

The IP address (of the router I presume) is and I can ping it, but that’s no surprise.

My linux laptop shows up under the ‘Attached Devices’, again no surprise.

It just doesn’t make any sense to me that I can’t connect to the internet!!

When you say you logged into the router, how did you do this - via a web browser and typing in the ipaddress
I gather then that you can ping the router at from the linux box, so your interneal network is set up correctly.
The router is returning the isp’s dns and dhcp server addresses. In other words, when the router is booted, it connects to the isp and uses dhcp to get and address on the isp’s network.
So the dns server addresses you need are: Primary and secondary
Put this into the network settings in yast>network devices along with the gateway address.
You should now be able to resolve domain names - ie
(As a test, try pinging
The wired network should now all be working.
Now to unplug the wired network and try the wireless net.
Does your router allow/offer a dhcp server option for wireless?
If so, enable it and try setting the wireless connection to use dhcp and then bring it up and repeat the ping tests. (If no dhcp server, use a different unique ipaddress on your 192.168.1 range)

Just had another look and a whois lookup for your dns servers cones up as ntl cable.
I seem to remember when I had ntl cable the ntl cable router was on the range. Just check this.

@sd3782. Thanks for all the info.

It just doesn’t make any sense to me that I can’t connect to the internet!!

I agree, but we carry on!

As long as the ping to an outside IP address does not succeed, the setting of DNS sserverss, etc. is not wrong (when we in the end hopefully have the connection we need them), but does not help very much with a solution.

Is there any logging in your router, where you could see why your packets are skipped (or routed in the wrong direction) by the router.

Of course also look at whychs’ suggestions. Now that your internal routing is OK we need all help we can get :slight_smile: