Completed install, now I’m booted into just a GRUB console

I made a post earlier about my being stuck on “loading basic drivers”, but a new title was necessary. After 58 minutes(!), it managed to load the basic drivers and proceeded to the installation screen. The installation completed but I’m now having a more serious issue:

I get booted into just a GRUB console:

When selecting a boot device at start, I for some reason see Debian still there as an entry. Even though I deleted it with this guided install of TW. I’m only using one SSD and replaced Debian with TW. Here are the entries:

In BIOS settings, this is the only boot order:

But then there’s “extra” settings for this aka “BBS priorities” showing all the entries:

After I disabled the third option, which was Debian, I’m now only presented the options of opensuse and opensuse-secureboot. If I choose secureboot, I get booted into the empty GRUB console after I get prompted to enter passphrase for hd0,gpt3 (I think it’s the root password).

If I choose the regular opensuse option, it shows a secure boot violation:

If I disable secureboot and choose the regular option, I’m once again asked for the passphrase, but then it also shows some errors:

Anyway, I enabled Secure Boot back and the “current situation” is that if I select the opensuse-secureboot boot option, I boot straight into the GRUB console. If I choose the regular boot option, it just shows a security boot violation. That’s it.

What do I do? My BIOS is UEFI. And during the TW installation, I confirmed it showed EFI/UEFI or whatever before the final step. But clearly something is messed up since for some reason the Debian boot entry is still there. I don’t have any OS installed at the moment, so I can’t really use a different system. All I have is the TW USB which for some reason took 58 minutes to “load the basic drivers”.

Here’s the proposed partitioning that should be about what I did to my SSD. But this is before I did guided partitioning to enable encryption and increased SWAP size. But that’s the only thing I changed, so it should be something like this:

I’d really appreciate your help! Thanks in advance.

Which means grub could not find its configuration file.

No, it is not root password, it is passphrase for your LUKS encrypted partition, whatever you used during installation. grub fails to access it which explains why it stops there. What made you think it should be root password?

You entered the wrong passphrase again.


Wow, I blame sleep deprivation. After entering the LUKS password, it boots successfully. However, I have a few final questions about this if you don’t mind answering. As a noob, I really appreciate your time!

  1. Do you know why the Debian boot entry still exists? Does it indicate a problem? Should I/is there any way to remove it from the entries other than just hiding it from the “BBS priorities” in my BIOS like I have? Every time I’ve replaced a distro in the past, the entry of my previous distro has never stayed. It has always replaced.

  2. Is it normal that there are two boot entries for openSUSE: opensuse and opensuse-secureboot? I boot into the opensuse-secureboot one. I haven’t tried the “regular” one. Is it just because I have Secure Boot? (My Secure Boot works fine, I enrolled my NVIDIA driver successfully.)

  3. When I boot, I select opensuse-secureboot, and then I have to enter my LUKS password. If I fail it, it proceeds to an empty GRUB prompt. If I succeed, it then takes me to the actual GRUB boot menu where I can boot into Tumbleweed. After that, I’m asked to enter my LUKS password again. And then it boots into the login screen. Is that normal, that I have to enter my LUKS password twice, and that it brings me to an empty GRUB prompt if I fail? On my previous install, I only had to enter my LUKS password once and after selecting Debian in the GRUB boot menu.

  4. When I open Dolphin, there are two entries for my harddrive:

… and I’m wondering if it’s related to the GRUB thing? Or if it’s an indication that my install/partitioning has been scuffed in some way?

Overall, just worried that my install/partitioning setup has been scuffed in some way with the Debian entry still being there/duplicate drive entries in Dolphin/have to enter LUKS password twice etc. If it matters, it took 56 minutes for the “loading basic drivers” step, until it proceeded to the installation screen.

Thanks in advance!

Before you need to make sure that there are no leftovers from Debian in /boot/efi or it will get added to the boot order again…

Because it is stored in system NVRAM, why do you expect it to go away?

You may try efibootmgr from within Linux or your BIOS may offer some way to delete boot entry (all BIOSes I have seen did).

No. It implies that you installed openSUSE bootloader twice with different settings (e.g. installed openSUSE twice).

You did not provide any information allowing us to answer this question. grub will pass passphrase used to unlock root to initrd so root should be unlocked automatically. Any other encrypted device has to be unlocked explicitly. Screenshot you posted implies that there are at least two encrypted devices.

Can you name the system that does it? And even if BIOS scans ESP for executable files, how should BIOS know that it is Debian?

There were cases (don’t know if it was in this forum or for another distri), efibootmgr still listed a deleted entry after refresh. This happens when there are leftovers from the distri in /boot/efi/efi (and the name of the distribution is written in this directory…have a look there). This is the case for some Debian/*buntu derivates, that they don’t properly clean up after deletion…
After cleaning the traces in /boot/efi/efi and deleting the entry via efibootmgr, also the entry in BIOS will disappear…

I found it again:

I opened /boot/efi/EFI (is there supposed to be 2 EFI folders?) and there’s a “debian” folder there. Do I just delete the debian folder or do I need to delete it with efibootmgr? Just to confirm. This is what my /boot/efi/EFI looks like:

Yes, that is correct.

First you need to remove this directory /boot/efi/EFI/debian
After that you can remove the entry via efibootmgr (see the linked tutorial how to show boot entries and deleting a particualar debian one…).

1 Like

Every time I’ve replaced a distro in the past, the entry of my previous distro has never stayed. It has always been replaced. I don’t know why the installer would choose to keep the debian folder in /boot/efi/EFI?

I’ve only ran the openSUSE installer once, so I don’t know why it would be installed twice. And why opensuse needs two entries.

Here’s my fdisk -l:

Disk /dev/sda: 232.89 GiB, 250059350016 bytes, 488397168 sectors
Disk model: Samsung 850 SSD
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier:

Device         Start       End   Sectors   Size Type
/dev/sda1       2048   1050623   1048576   512M EFI System
/dev/sda2    1050624   2050047    999424   488M Linux filesystem
/dev/sda3    2050048 455737343 453687296 216.3G Linux filesystem
/dev/sda4  455737344 488397134  32659791  15.6G Linux swap

Disk /dev/mapper/cr_root: 216.33 GiB, 232285798400 bytes, 453683200 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/mapper/cr_swap: 15.57 GiB, 16719715840 bytes, 32655695 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Does any of this explain why there are two duplicates of my SSD in Dolphin? Is my entire install just scuffed then with all the duplicates in GRUB & Dolphin? I only have one SSD. I really don’t know how to approach this as a novice. Thanks!

This is maybe a quirk in dolphin but nothing to worry about. You are using LVM (this is one entry in dolphin) and additionally LUKS encryption (this is the second entry in dolphin). As i’m using neither LUKS nor LVM i can’t reproduce this (i don’t even have a VM with such a setup for reproducing this…)
Maybe another user with LVM/LUKS/Plasma combination here can comment on this…

Yep, dolphin quirk. You can hide one of the ntries:

Thanks! I hid the unnecessary entries in Dolphin, m -rf’d the debian folder from my EFI and removed the entry with efibootmgr. I just hope my partitioning is all fine. My fdisk -l looks fine, I think?

Currently, my only boot entries are opensuse and opensuse-secureboot. I only use the secureboot one to boot. That should be normal right, since I use Secure Boot? arvidjaar said it’s “not normal”, and that it e.g. implies openSUSE has been installed “twice”. I don’t understand his answer since I’m not very knowledgeable.

And when I boot with opensuse-secureboot, the process is as follows: I have to enter my “passphrase to decrypt the master key” and if I type the wrong encryption password, it takes me to an empty GRUB console/prompt. If I type the correct encryption password, it takes me to the actual GRUB boot menu where I can select Tumbleweed etc. Then it boots and I’m asked to enter my encryption password again, and if correct it takes me to the login manager. I just want to ensure that this process is also normal, because on Debian I never had to enter my encryption password before loading the GRUB boot menu. Only after. Maybe someone who uses encryption can answer this?

Also, during installation, I only selected encryption but I left LVM unchecked. So it’s strange that you say I use LVM.

I’m super happy with openSUSE so far and want to stay but I just want to ensure my install was done properly and didn’t scuff somehow. In case I get recommended to reinstall, I’d rather do it now while it’s still fresh. And I still don’t understand why it took 56 minutes to get past the “loading basic drivers” stage, which adds to my concern that something got scuffed. I verified the checksum of the ISO so that’s wasn’t the cause, and dd’d the ISO to my FAT32 USB twice just to be sure.

If you or someone is able to assure me on these points I’d really appreciate it! Thanks. :smile:

When I first installed openSUSE 12.3 for UEFI booting, I got two entries. But that was a long time ago. Recent installs, I only see “opensuse-secureboot”. However, on one computer (a Lenovo), the BIOS puts back that old “opensuse” boot entry, so I put up with it being there.

Yes, this is normal when “/boot” is part of the encrypted root. You can avoid that initial grub prompt for password if you use a separate unencrypted “/boot”. However, that is not advisable when “btrfs” is used for the root file system. Your Debian system probably used an unencrypted “/boot” as a separate file system.

I don’t understand that either. It has not happened here. Apparently your installed system does not have this 56 minute delay, so perhaps this was a temporary glitch. Or perhaps the installer misidentified some hardware and waited for a timeout.

Thanks a lot! Hopefully I’m all clear then in terms of partitioning/GRUB etc. And I don’t mind the encrypted boot process, I just wanted to make sure it’s normal.

Based on the 56 minute “loading basic drivers”, or anything I’ve mentioned here, do you recommend reinstalling with a fresh USB “just in case”? Or should I be good? I’m not having any issues except for the worries I’ve mentioned, like debian staying in my /boot/efi/EFI/ and such. I’m just worried that my install was hurt/incomplete in some way.

FYI, my USB stick only has 10MB/sec read and 5MB/sec write. But maybe that wasn’t the problem, since I’ve installed Debian, Fedora and Gentoo without any such delays.

There’s no need to reinstall. Your current setup seems to be working well.

1 Like

Alright, thanks! I don’t have any other questions. :smile:

shim-install calls grub2-install --no-nvram.

Could you post efibootmgr -v from this system? Once after you deleted this entry before reboot and once after reboot.

Yes, sounds similar to what Neil describes. Note that auto-added entry is unactive and should not be used for boot though.

I already told you that this is not normal if we are speaking about root filesystem.