compiz fusion icon

I was looking for compiz fusion icon for 11.2 gnome desktop. Is there a package for it.

I have a feeling it’s more a kde package, but I could be wrong
Check here
Compiz Fusion - openSUSE
There is a gnome oneclick which will add all the gubbins
But read this too first: Installing and Configuring Compiz

It works on Buntu gnome. It is a great help really when we switch windows decorator and as such.

I have used it too. I agree.
My search says it’s here
Index of /repositories/X11:/XGL/openSUSE_11.2

I see that is added in Ian’s instructions or the Oneclick

Found it at Index of /repositories/X11:/XGL/openSUSE_11.2/x86_64

Thanks!

Got the icon but it wont show up anywhere, tried search but it failed too.

In a terminal do

fusion-icon

that’s a guess

This is what i got -

david@linux-zsof:~> fusion-icon

  • Detected Session: gnome
  • Searching for installed applications…
  • No GLX_EXT_texture_from_pixmap with direct rendering context
    … nor with indirect rendering, this isn’t going to work!
    Traceback (most recent call last):
    File “/usr/bin/fusion-icon”, line 57, in <module>
    from FusionIcon.interface import choose_interface
    File “/usr/lib/python2.6/site-packages/FusionIcon/interface.py”, line 23, in <module>
    import start
    File “/usr/lib/python2.6/site-packages/FusionIcon/start.py”, line 64, in <module>
    env.set()
    File “/usr/lib/python2.6/site-packages/FusionIcon/environment.py”, line 140, in set
    if not self.Xgl and self.glx_vendor == ‘NVIDIA Corporation’:
    AttributeError: Environment instance has no attribute ‘glx_vendor’

It works on buntu with same hardware. Wonder what is biting it in suse.

Have 64-bit and Nvidia. BUT I use KDE. I am also getting errors when trying to use the fusion-icon. Any particular reason you need it?

Here’s my output:

fusion-icon
 * Detected Session: kde
 * Searching for installed applications...
 * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
 * Using the GTK Interface
 * Starting Compiz
Traceback (most recent call last):
  File "/usr/bin/fusion-icon", line 58, in <module>
    choose_interface(try_first=options.interface)
  File "/usr/lib/python2.6/site-packages/FusionIcon/interface.py", line 89, in choose_interface
    import_interface(chosen_interface)
  File "/usr/lib/python2.6/site-packages/FusionIcon/interface.py", line 35, in import_interface
    __import__('FusionIcon.interface_%s' %interface)
  File "/usr/lib/python2.6/site-packages/FusionIcon/interface_gtk/__init__.py", line 3, in <module>
    import main
  File "/usr/lib/python2.6/site-packages/FusionIcon/interface_gtk/main.py", line 213, in <module>
    init()
  File "/usr/lib/python2.6/site-packages/FusionIcon/start.py", line 34, in init
    wms.start()
  File "/usr/lib/python2.6/site-packages/FusionIcon/util.py", line 154, in start
    run(self[self.old].killcmd, 'call')
  File "/usr/lib/python2.6/site-packages/FusionIcon/execute.py", line 41, in run
    exitcode = subprocess.call(command, stderr=subprocess.PIPE)
  File "/usr/lib64/python2.6/subprocess.py", line 444, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib64/python2.6/subprocess.py", line 595, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1092, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

I’ll try installing Gnome and see what I can get in there. Will report back

Take Care,

Ian

Ian,

Compiz on suse works well in kde, with gnome it slows down the system. I’ve already made some modifications in order to avoid crashes. Fusion-icon is a great help for switching over to emerald and metacity. I wish it works with 11.3 in near future.

Compiz on suse works well in kde
You know a plain kde install does not have Compiz?! But uses native kwin.
I have tried Compiz myself recently and it worked fine in kde and gnome (This was in 11.3), but I didn’t ADD anything, just used the defaults from install.

Fusion-icon is useful for switching windows manager. On kde it works well but in gnome it wont show up. For other copiz setting I use simple css manager.

Like I said. I had a feeling it was used for kde