compiling imwheel

I am willing to install imwheel to get my mouse buttons work. It seems
that there is no repository containing imwheel for Opensuse, and I found
it also on the wishlist.

So I downloaded the source, extracted it and ran ./configure, but then
I got this: -Error: IMWheel depends on the X11 libraries-

Here’s the full text: ‘nopaste.biz - the classic style pastebin.’
(http://nopaste.biz/59872)

What do I have to do to get it working?


tar0n

tar0n’s Profile: http://forums.opensuse.org/member.php?userid=18423
View this thread: http://forums.opensuse.org/showthread.php?t=403263

I just recently compiled imwheel and I had the same problem. If I recall
correctly I used:

Code:

./configure --prefix=/opt/kde3

to get it to work correctly. You can check what your prefix is to add
to the config by entering:

Code:

kde-config -prefix

in a konsole window. This can then be added to your config. I’m running
openSUSE 11.1 with KDE4 so of course if your using Gnome this may be
different.


Gumper

Gumper’s Profile: http://forums.opensuse.org/member.php?userid=321
View this thread: http://forums.opensuse.org/showthread.php?t=403263

Well, unfortunately I am using Gnome… :’(


tar0n

tar0n’s Profile: http://forums.opensuse.org/member.php?userid=18423
View this thread: http://forums.opensuse.org/showthread.php?t=403263

Do you have the xorg-x11-devel package installed?


kdemello

kdemello’s Profile: http://forums.opensuse.org/member.php?userid=1583
View this thread: http://forums.opensuse.org/showthread.php?t=403263

Gumper;1917202 Wrote:
> I just recently compiled imwheel and I had the same problem. If I recall
> correctly I used:
>
> >
Code:

> > ./configure --prefix=/opt/kde3

> >
>
> to get it to work correctly. You can check what your prefix is to add
> to the config by entering:
>
> >
Code:

> > kde-config -prefix

> >
>
> in a konsole window. This can then be added to your config. I’m
> running openSUSE 11.1 with KDE4 so of course if your using Gnome this
> may be different.

The --prefix option tells configure where to install the software when
‘make install’ is executed. It doesn’t tell configure where to find
libraries. According to ./configure --help, the --x-includes= and
–x-libraries= would probably be the relevant options.

That said, if the xorg-x11-devel package is installed (as it is on my
system) then ./configure will succeed without needing to specify the
location of the X11 libraries.


kdemello

kdemello’s Profile: http://forums.opensuse.org/member.php?userid=1583
View this thread: http://forums.opensuse.org/showthread.php?t=403263