Code::Blocks IDE GNU compiler missing


I am running Tumbleweed with the latest updates.
Recently I have installed Code::Blocks IDE (for programming) and I ran into a problem. The problem is that the GNU compiler for the IDE might be missing. The program cannot find the directory path that it must take in order to find the compiler.
The error is:

Environment error
Can`t find a compiler executable in your configured search path`s for GNU GCC Compiler

Tried the set the program to default settings and use the “auto-detect” to find the GNU compiler but I had no luck.

How can I fix this problem?

Best Regards;

Generally speaking,
This is a path error in the source code.

But, it’s likely someone has already packaged it up so you don’t have to deal with its errors…

If that’s not exactly what you’re looking for, search for “blocks” instead.


Did you install the GNU CC compiler? It is not installed by default.

When you start developing better install one or more Development Patterns
(YaST > Software >Software Management, then from the View menu: Patterns. Then scroll down to Development and at least install Basic).

You did install gcc right?? It is not installed by default :wink:


I have installed it from here:

I think I have installed the compiler (not sure, that error doesn`t come up anymore when I start Code::Blocks). However came across a new problem. As soon as I open a project or make a new project (e.g. console application), the program either shuts down or just simply stops responding.

Best Regards;

Are you starting from the command line?? If not try it should show reason for errors


When I start codeblocks, as soon as I open the main.cpp the program stops responding, I can move the window but I cannot write any code.

Best Regards;