Cinnamon desktop fails to load

I recently started having issues with Cinnamon not loading correctly. When I login (I’ve tried both GDM and lightdm) I get a mouse cursor and the wallpaper shows up, but no panel or anything. Right clicking the desktop does nothing, keyboard shortcuts do nothing. I can get into a terminal using ctrl+alt+F2, but not sure what to troubleshoot from there. If I login to Cinnamon (software rendering) it seems to work fine, so maybe there’s a graphical or driver issue? I’ve been running Cinnamon for months and just recently started having the problem. Please help!

I also have GNOME and i3 installed, but those have been installed for awhile with no issues so I don’t think they’re the issue.

Here’s a printout of my system info:

  Host: opensuse Kernel: 6.0.8-1-default arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.1 Desktop: GNOME v: 43.1 Distro: openSUSE Tumbleweed 20221126
  Type: Desktop System: Micro-Star product: MS-7C02 v: 1.0
    serial: <superuser required>
  Mobo: Micro-Star model: B450 TOMAHAWK (MS-7C02) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.D0
    date: 11/07/2019
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master
    charge: 100% (should be ignored) status: discharging
  Info: 8-core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+
    rev: 2 cache: L1: 768 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 2481 high: 3700 min/max: 2200/3700 boost: enabled cores:
    1: 2200 2: 3700 3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 3700
    10: 2200 11: 2200 12: 2200 13: 3700 14: 2200 15: 2200 16: 2200
    bogomips: 118383
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel arch: GCN-4 bus-ID: 26:00.0
    temp: 53.0 C
  Display: wayland server: v: with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: X: loaded: amdgpu dri: radeonsi gpu: amdgpu
    resolution: 1: 1920x1200~60Hz 2: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 22.2.4 renderer: AMD Radeon RX 580 Series
    (polaris10 LLVM 15.0.5 DRM 3.48 6.0.8-1-default) direct render: Yes
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 3-1:2
    bus-ID: 26:00.1
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 28:00.3
  Device-3: C-Media XIBERIA type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.8-1-default running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.60 running: yes
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 21:00.0
  IF: wlo1 state: up mac: 6c:6a:77:3f:b5:42
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 22:00.0
  IF: enp34s0 state: down mac: 00:d8:61:ab:28:6a
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-5:3
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 1.58 TiB used: 58.39 GiB (3.6%)
  ID-1: /dev/sda vendor: A-Data model: SU635 size: 223.57 GiB
  ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB
  ID-3: /dev/sdc vendor: Crucial model: CT240M500SSD1 size: 223.57 GiB
  ID-4: /dev/sdd vendor: LITE-ON model: CV1-8B256 size: 238.47 GiB
  ID-1: / size: 221.07 GiB used: 58.35 GiB (26.4%) fs: btrfs dev: /dev/sda2
  ID-2: /boot/efi size: 511 MiB used: 35.7 MiB (7.0%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 221.07 GiB used: 58.35 GiB (26.4%) fs: btrfs
    dev: /dev/sda2
  ID-4: /opt size: 221.07 GiB used: 58.35 GiB (26.4%) fs: btrfs
    dev: /dev/sda2
  ID-5: /var size: 221.07 GiB used: 58.35 GiB (26.4%) fs: btrfs
    dev: /dev/sda2
  ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) dev: /dev/sda3
  System Temperatures: cpu: 49.5 C mobo: N/A gpu: amdgpu temp: 53.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 916
  Processes: 395 Uptime: 0h 12m Memory: 15.56 GiB used: 2.24 GiB (14.4%)
  Init: systemd Compilers: gcc: 12.2.1 Packages: 26 note: see --rpm
  Shell: Bash v: 5.2.9 inxi: 3.3.23

Hmm… almost 2 weeks, over 130 views and no one has a suggestion on what could be causing this? I’m happy to provide any additional info that might be helpful.

Tried a different test user could be corrupted settings.

That didn’t help unfortunately. I still just have a mouse cursor and wallpaper but nothing else.

I did notice something a couple of days ago that could be an issue. I ran an update that included a kernel update. Quite a few times a message came up saying:

No such key “screensaver-uses-logind” in schema “org.cinnamon.desktop.session” as specified in override file “/usr/share/glib-2.0/schemas/org.cinnamon.desktop.session.gschema.override”; ignoring override for this key.

Could this be part of the problem?

I hate to keep bumping the thread, but surely someone has a few ideas as to what could be keeping Cinnamon from loading properly. I’ve never had an issue like this before and have no idea what to try next. Please help if you can!

I guess there’s not many Cinnamon users here, or those there are also have no ideas.

Perhaps try asking over at the Cinnamon section of Mint’s user forum? Cinnamon - Linux Mint Forums