Chromium can't play h.264, even though chromum-ffmpeg is installed

Chromium seems to be unable to play h.264 video, as shown here, even though I have chromium-ffmpeg installed.

Same here…on both Leap 42.1 and Tumbleweed…chromium is broken all the time >:(

it’s not just chromium-ffmpeg, ffmpeg needs to be from packman, the packman repo (especialy on TW) needs to have a higher priority then the oss repo,
have you done a full vendor change to packman?
tell us your repo list

zypper lr -d

Chromium works for me on 42.1 (although I rarly use it) as LEAP does not use zypper dup for updates the packman priority is not as important but you still need to do a full vendor change to packman so what’s your repo list?

zypper lr -d

actually, it seems that something is broken in Chromium 54.xx
I noticed a media site I visit started choking after the update to 54.xx.
Youtube reports the same as the OP for me in regards to h264 support.

Rolling back to Chromium 53.xx fixes the problem - the media site I visit plays fine and youtube reports h264 support.

Chrome 54.xx does not exhibit the same problems

Packman does seem to have some trouble keeping up with Chromium.

I have set the Packman repo to a higher priority and done a full vendor switch to it.

I tried that now and I’m getting the same result, h.264 works in Chromium 53, but not in Chromium 54.

I faintly remember reading that the version numbers for chromium and chromium-ffmpeg must be exact matches. At least for OpenSuse 13.2 that is not the case at the moment. Chromium is at 54.0.2840.59-131.2 while chromium-ffmpeg ist at 54.0.2840.59-132.1. I don’t know if that is significant enough to cause the breakage…

I’m pretty sure that should be good enough. The part after the hyphen doesn’t matter with respect to whether they match, as far as I know.

Opensuse LEAP 42.1 - KDE - Plasma 5

I solved this problem by installing the Google website package: **google-chrome-stable

**Two modes for installation:

1 - Add the Google repository in YaST2 -> Software Repositories -> Add -> Specifc URL:

Repository Name: Google Chrome

After add repository, click Refresh -> Refresh All Enable -> OK (Configured Software Repositories screen)

YAST2 -> Software Management -> Search package -> **google-chrome-stable

**You will now have two Google browsers installed on your system:

1 - Chromium from Opensuse (chromium) - icon blue - version 54.0.2840.90

2 - Chrome from Google (google-chrome-stable) - icon red, green, yellow - version 54.0.2840.90

By adding the repository of Google, it will also be added to possible installation packages:

google-chrome-beta - version 55.0.2883.35-1

google-chrome-unstable - version 56.0.2906.0-1

2 - Another way to install google-chrome-stable package:

Download the Google website the RPM package:

After install, test the MP4 file:

In the google-chrome-stable browser (Google repository), you will view the video.

In the chromium browser (Opensuse repository) in KDE, will appear the window to “Save” the video

Google Chrome Help Forum:

Is the x86_64 rpm no longer provided or does this need fixed?!topic/chrome/eo1vNgTCPoM/discussion

It’s a known problem in openSUSE’s chromium package:

The next update should fix it, if you don’t want to wait you can install chromium from the network:chromium repo for now.

Btw, according to the bug report, v55 will start to use the system’s ffmpeg, so the chromium-ffmpeg package will be obsolete then… (which should rule out problems caused by different versions of chromium and chromium-ffmpeg)

System: Leap 42.1 - x64 - KDE

This procedure must be done with the Chromium web browser closed (not running).

The web browser Chromium Version 55.0.2883.75 must have all packages (installed) related to ffmpeg in the Packman repository.

I had a problem with the sound (no sound MP4 video) in Cromium version 55.

The problem was that the package libavcodec56 - version 2.8.8-22.1 (FFmpeg codec library) was installed through the repository (Main Update Repository).

With this package, the sound codec is not enabled on Chromium 55.

In this case, you have to select another package called libavcodec56 - version 2.8.20161206.16c0d8a-1.2 - Packman repository.

YAST2 -> ffmpeg (search field) -> libavcodec56 (package view - select this package) -> TAB Versions -> 2.8.20161206.16c0d8a-1.2 from vendor

There is a definition in the chromium.spec file (line 536) that tells Chromium to use the FFMPEG audio and video codecs if it is from the Packman repository.

If it is not from the Packaman repository, the video or audio codec is not used.

Define the Chrome branding in order to get libffmpeg on packman that supports all codecs

The proprietary codecs just force the chromium to say they can use it and

offload the actual computation to the split, otherwise the chromium

won’t be able to load the codec even if the library can handle it

myconf_gn+=" proprietary_codecs=true"
%if 0%{?packman_bs} || %{with system_ffmpeg}
myconf_gn+=" ffmpeg_branding=“Chrome”"

MP4 video test audio and video codec:

If you need Flash (Adobe) for audio and video FLV or online radio station using flash, install the package -
Flash-player-ppapi - Adobe Flash PPAPI Plugin - from Packman repository.

flash-player-ppapi - Adobe Flash PPAPI Plugin

This package contains Adobe’s Flash Plugin for the PPAPI supporting Web browsers, like Chromium.](

The Chromium-ffmpeg package has been depreciated, Chromium now uses the system ffmpeg, changing single packages will accomplish nothing you need to do a full vendor change to the packman repo
tell us your repo list

zypper lr -d

or better yet start a new thread as your problem has little in common with the OP’s

There is no problem in my post but a solution for who made the change from Chromium 54 to Chromium 55 (LEAP 42.1 Software Updates).

This is a continuation of the wolfi323 post on the discontinuation of the chromium-ffmpeg package.

Even with the switch to the Chromium 55 version, if the user does not pay attention that all packages should come from the packman repository, then some codecs may not work.

Yes, Chromium 55 no longer uses the chromium-ffmpeg package. It now uses the ffmpeg system. But only use the system ffmpeg if it is from the Packaman repository (all packages installed).

Why create a new topic if the subject remains the same (LEAP 42.1 Chromium can’t play h.264)?

The symptoms are the same. But the problem is different. The earlier problem was due to a bad chromium update.

In any case, if your issue is now resolved, then that’s good enough.

That’s not completely true though.
It now always uses the system ffmpeg.

But if you do not install the ffmpeg libraries (libavcodec et al.) from Packman, they will not support certain (“restricted”) codecs like mp4.
This affects basically any media player though, not just chromium.

That’s the main point to getting full multimedia support in openSUSE: add the Packman repo and install the ffmpeg libraries from there, as the ones that are included in openSUSE are “crippled” for legal reasons.
It is advisable to do a full switch to Packman though (as I_A wrote), not just switch single packages. This assures that really all necessary packages come from Packman and have full codec support.

No, Firefox 50.1.0 and Google Chrome 55.0.2883.87 (64-bit) (Google Repository) work without problems even with the libavcodec6 package coming from the Main Update repository.

The problem was really only with Chromium 55.

That is the problem. I already had the Packman repository added on my system.

Somehow, in updating the ffmpeg packages, LEAP 42.1 used the libavcodec6 package from the Main Update repository instead of Packman. And that caused the problem.

I only shared the tip if any new users had this same problem. That’s the reason I post this tip.

as I said no single package fixes things Chromium 55 plays h264 video’s fine for me even on youtube see the stats for nerds part of my screenshot bellow
tell us your repo’s

zypper lr -d

if you’ve done a full vendor change to packman you shouldn’t have any multimedia packages from the update repo
you’ve got mixed packages I don’t know how that happened the only solution is to do a new full vendor change to packman

Do not use Youtube videos to test codecs.

Real test.

1 - Change libavcodec56 package Packman Repository to Main Update repository. Yes, one single package.

libavcodec56 - 2.8.20161206.16c0d8a-1.2 - Packaman repository

libavcodec56 - 2.8.8-22.1 - Main Update repository

2 - Make a real test with MP4 vídeo.

3 - Make sure the audio codec is working correctly.

In my system, no sound. Only video (image).

Returning to the Packaman repository, audio works correctly. Yes, one single package.

Well, Google Chrome has all built in, it doesn’t use the system’s library.
They can do that because Chrome is proprietary, closed-source software.

That doesn’t mean that what I wrote was wrong.
Basically any (open source) media player uses ffmpeg and its codecs, and will be unable to play certain codecs if you don’t install the packages from Packman.

I’m not completely sure about Firefox, previous versions used gstreamer (which you also need to install from Packman to have full codec support), but I do think it also uses the system’s ffmpeg now.
Firefox is not a “media player” anyway though… :wink:

The problem was really only with Chromium 55.

No, the same problem would be with everything that uses ffmpeg.

That is the problem. I already had the Packman repository added on my system.

Adding a repo will not install any packages.
You need to do that manually.

Somehow, in updating the ffmpeg packages, LEAP 42.1 used the libavcodec6 package from the Main Update repository instead of Packman. And that caused the problem.

There is no libavcodec6 (yet).

But yes, the libavcodec57 from the Main update repository is crippled for legal reasons, as mentioned.

You need to replace it with Packman’s for full codec support (and not only for chromium).
And again, you should better do a full switch to Packman (as recommended again and again here in the forums), and not just switch single packages (unless you perfectly know what you are doing).

If you already installed libavcodec57 from Packman, the package management will not switch back to the one from the Main Update repo automatically, unless you tell it explicitly to do that.

Yes, one single package can make the difference in full codec support working or not.
And that’s exactly the reason why it is being recommended to do a full switch to Packman.

And it doesn’t mean that switching one single package is enough after a fresh installation to have fully working multimedia…