Chrome9 vga driver; HP 2133

Ok, here is the problem…step by step

  1. download/install the driver via YaST (chrome9) (ok)

I searched chrome9 driver at the openSUSE build service, found 2 repos…
xorg-x11-driver-video-chrome9 and via-chrome9-kmp (because i didn t know what is the right i installed both…(is this maybe the bug???) the 1-click installation was well done…)

  1. Logout of your GUI/DE session and use the command ctrl+alt+F1 to get to the console login. (ok)

  2. Login as root user. (ok, the mod changed to root user)

  3. Run the commands; Code:
    init 3 <enter> (ok)
    sax2 -r -m 0=via <enter> (faild)

i get the answer: “your current configuration will not be read in”
“Sax: no X-Server is running”
“Sax: will start own server if needed”

init 5 && exit <enter> (but i get no answer)

I had no idea how to get out of the terminal…so i finali push the button and the system shut normally down…
after starting second time the pc…i wanted to look if the 3d or the 2d is working…but when i start sax in yast it changes into the console modus for a short time and when i tip something it gets back to gnome…whats this?? :\

If you ever in that situation, re-run the commands, except use vesa
instead of via in the sax2 command eg;

sax2 -r -m 0=vesa

Those are the correct two drivers :frowning: Can you uninstall them when you
get back to the Gnome desktop and then try the unichrome ones not
chrome9. Then if that doesn’t work, there is the openchrome one (in a
different repository).

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 1:02, 1 user, load average: 0.12, 0.18, 0.11
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

to run unichrome…the same commands but:
sax2 -r -m 0=unichrome
to run openchrome:
sax2 -r -m 0=openchrome
is that right?

i will first test openchrome…i read in a linux newspaper that via in future will work with openchrome…maybe openchrome just supports chrome9 chips…i would be just happy when 2d will work…vesa is so slow for watching videos with good resolution…

If you have installed it, yes I use that one on my via pico system.

/usr/sbin/hwinfo --gfxcard

23: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_1106_3157
Unique ID: VCu0.8VBJIn3K3k3
Parent ID: vSkL.S16qDHSKEeD
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: "VIA CX700/VX700 [S3 UniChrome Pro]"
Vendor: pci 0x1106 "VIA Technologies, Inc."
Device: pci 0x3157 "CX700/VX700 [S3 UniChrome Pro]"
SubVendor: pci 0x1106 "VIA Technologies, Inc."
SubDevice: pci 0x3157
Revision: 0x03
Memory Range: 0xa0000000-0xbfffffff (rw,prefetchable)
Memory Range: 0xdd000000-0xddffffff (rw,non-prefetchable)
Memory Range: 0xde000000-0xde00ffff (ro,prefetchable,disabled)
IRQ: 16 (47973 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: "pci:v00001106d00003157sv00001106sd00003157bc03sc00i00"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #13 (PCI bridge)

Primary display adapter: #23

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 3:27, 2 users, load average: 0.31, 0.62, 0.93
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Where did you find the openchrome file? I can see the unichrome and chrome9 files, but that was all.

It’s in this repository;

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 6:12, 1 user, load average: 0.21, 0.37, 0.33
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

i tried to get chrome9, unichrome, openchrome to work…
i used the commands:
sax2 -r -m 0=via
sax2 -r -m 0=unichrome
sax2 -r -m 0=openchrome
…but every time the same negative answer:

it doesn t work… :’(

if i want or not…actually i have to stay by vesa and wait for the next generation of drivers…:wink:

I think the unichrome one is also via, so you may need to unistall the
chrome9 one.

Looks like it may still be a waiting game… :frowning: You could look at the
openchrome/via site to see if any source updates are there. Then you
could look at the openchrome src rpm and try to build against that?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 7:13, 1 user, load average: 0.16, 0.28, 0.33
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

I m confident that chrome9 will be supported in the future…the first netbook (samsung) is now buy(ible) (what a bad english;))…thats the first netbook with the next generation via nano cpu (performance is a lot better than intels atom)…and the only vga chip for this hardware is at the moment chrome9…:wink:
I will have a look if a new driver is around…i think it will be a openchrome…

It is very late for me, so I will only say a couple of things:

I think someone suggested uninstalling the ones you are not using. Did you do that? I have not looked at the file sets but it is possible that some files conflict and so you might not have a full driver set installed. Try unloading them all and install them only one at a time. In fact, you might want to try “rpm” instead of yast2 and use the “–force” option to make sure that all the files get installed.

Aside from that, there is one thought that might give you some comfort: From what I have heard, the 2.6.28 Kernel that was released last month (early December 2008?) was supposed to include Via support. I do not know exactly what is supported, but I expect that the HP-2133 Via chips are probably covered. I think that some of the VX800 stuff is in there too.

Sometime in the next 4 - 6 months, there should be some major Linux distributions using this kernel, or an even later version. I have not looked past OpenSuSE 11.1, but maybe the next SuSE Enterprise might have it? I do not know what the policy there it. It might just be the same kernel as OpenSuSE 11.1. Definitely 11.2 will have it when it comes out. Anyway, even the drivers do not get working in 11.1, I expect there will not be much longer to wait.

I have some information that might be interesting:

Apparently, at least 1 of the drivers does not show up properly in the usual system documentation, but it works anyway. That is to say, you will still see a “vesa” driver, but it will be patched to be a Via Chrome 9 supporting driver. Try this:

“Control Panel -> Graphics Card and Monitor”

Look and see if there is a “3D” support checkbox with a check mark in it.

If so, you might have Via support and “3D” is active.

In the “root” account try “glxgears” (from a terminal). Also try it under another account. “root” will probably give you about 2x the speed of other accounts. If you only get around 20 - 30 frames in 5 seconds, then you are running VESA, but if you are around 300 frames in 5 seconds, you have acceleration.

You mean that the the new kernel will support in the furture VIA out of the box or only the chrome9 driver?
I have tested a lot of ways to bring my chrome9 chip to work…but at the moment it finally doesn t work!

What ever…im confident that the new openchrome driver will work (when it comes out…in the future!)

thx for help;)

It sounds like you know more about Via chips than I do, so maybe you can tell me that. Here is a link to an article about the changes in the “28” kernel:

If you check the last page (page 8) of the article there is a list of the various changes. Search that page for “via” and in the graphics section you will find “viafb” and also in the hardware monitoring “viapro”.

Seems like it will be supported… Thats nice, really nice!:wink:

have you found a solution? where you found the drivers for this grafic card? thank you very much!:wink:

I have had limited success with the openchome or unichrome drivers. I tried manually hacking the suse 10 driver from the via site into the suse 11 kernel (i.e. looking at the script and copying the files manually) also with limited success.

with openchrome
3D does not seem to work - glxgears runs - it spins the gears but the rest of the system is frozen - keyboard is completely locked up. The mouse still works though. 2D is slow, this is apparent when scrolling on a konsole

with via/chrome9 or SuSE 10 drivers
3D does not work - glxinfo runs but glxgears freezes up the system as above without displaying the actual 3D window

I have never got direct rendering: yes with either SLED or openSUSE.

I’m currently trying “chrome9” and “unichrome” as the driver line in xorg.conf

I was hoping to be a part of the 11.2 debugging effort, but it looks like I will not have time for it. This version will have a Kernel that should have all the Via graphics support we discussed previously. Has anyone been trying these yet?