I have python-SQLAlchemy-0.7.2-2.1.3.x86_64.rpm installed & the docs for it. I’m stumped I had a hard time finding the package. I found it in the Factory oss repo am I missing something as childsplay can’t find it. This is what I get when I run it in terminal. I even tried terminal as Super User and I get the same error. How does the Education group get this package to run? I originally posted this in applications and was refered here.

wye4@linux-zr4c:~> childsplay
2011-12-25 13:10:43,084 - schoolsplay.SPDataManager - ERROR - No sqlalchemy package found
Traceback (most recent call last):
File “/usr/lib64/python2.7/site-packages/childsplay_sp/”, line 41, in <module>
import sqlalchemy.exceptions as sqlae
ImportError: No module named exceptions
Traceback (most recent call last):
File “/usr/bin/childsplay”, line 118, in <module>
import childsplay_sp.SPMainCore as SPMainCore
File “/usr/lib64/python2.7/site-packages/childsplay_sp/”, line 59, in <module>
import SPDataManager as SPDataManager
File “/usr/lib64/python2.7/site-packages/childsplay_sp/”, line 45, in <module>
raise Exception

There is a patch to to fix this from Debian bug 638747 ;

---	2010-05-20 07:44:00.000000000 +0200
+++ /tmp/	2011-08-21 16:23:21.870061695 +0200
@@ -38,7 +38,7 @@

import sqlalchemy as sqla
-    import sqlalchemy.exceptions as sqlae
+    from sqlalchemy import exc as sqlae
import SQLTables
except ImportError:
module_logger.exception("No sqlalchemy package found")

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.0-1.2-desktop
up 9:46, 3 users, load average: 0.08, 0.06, 0.10
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU