Chess game 3D mode issue

:question: I’ve a question about Chess game 3D mode. How do I run 3D mode in Gnome’s chess game? My Gnome chess game is from openSUSE x64 DVD, and it can run 2D mode. My graphics card is nVidia GTS 250, and it perfectly is running Compiz. While I select 3D mode in chess game, it will show a dialog “… display problem …” something.

What is the exact error shown in that dialog?

Sorry, some of words are Traditional Chinese, because i’m from Taiwan. The dialog shows “Unable to enable 3D mode”.

I read that dialog box, and I noted Ubuntu Linux users have reported the same problem, where a solution for Ubuntu was reported here: Turning on 3D Chessboard in Feisty » Mike’s Planet

I think for openSUSE, that means you should ensure you have installed from the official OSS repository (assuming you are using official repositories)

  • python-imaging
  • python-opengl
  • python-gtkglext
  • gtkglext

You may need to restart your desktop afterward (I don’t know if this is the case).

Thank you very much. :slight_smile: