Character/Encoding (Turkish/Türkçe) Problems in 11.2

Hi everyone,
I have been waiting for 11.2 for a long time and i think it is worth the wait. However, I have a problem, which reduces the usability for me. Turkish characters in some file names (especially copied from windows) and in some applications show up as question marks. If it was only files copied from windows, it wouldn’t be much of a problem, but, when I reopened a file I created in openoffice under opensuse 11.2, the Turkish characters were replaced with question marks. Additionally other people see my name with strange characters in the mails I sent from kontact. Is there a setting to change to correct this error? I tried unchecking use UTF encoding in yast language settings but it resulted in a worse situation. Any suggestions please?

One possibility is a font problem. Fonts only contain some of the characters in the Unicode sequence because it is so long. Where the recipient does not have the exact font that you used, the software makes a substitution and that may be the cause of the problem.

That doesn’t explain the problem you had with OpenOffice unless you saved it, for example, in a Microsoft format and so it changed the file to a Microsoft font and then did not make the reverse change when you reloaded it.

Try sending an email to a friend who you know has exactly the same fonts as you and then an email with a font that you know your friend does not have and see if that is the cause of the problem.

Well, you might be right, because the problem with the office occured when I saved as .doc and reopened the file. However, using different fonts (dejavu sans, or Times New Roman) did not change the end result. When I reopen the file, I get strange characters looking like Runes.

I have had a look at what both dejavu and Times Roman offer and both of them have a large number of missing characters in the first 512 codes of the Unicode sequence which is where I assume Turkish is located.

It is possible that you may have to install a specifically Turkish font to get a reliable response. If you know someone who is using Pardus, it may be worth asking them what Pardus has installed as it uses KDE like openSUSE.

Hello john_hudson, thanks for your response. I don’t know where the Turkish characters are located on the UTF sequence, however, I tried your offer and found several true type fonts whcih have , installed it using font installer. In the fonr installer/manager I can see almost all fonts showing Turkish characters, when I use the font in openoffice writer, I can see the characters, however when I save as doc and reopen the file, I see elven runes. I guess either I need to change some settings or I have to wait for some updates. If there is nobody having a similar problem, then I guess this is a problem related to my particular setup.

Today I noticed something else. When the screensaver is activated, I need to log in again. At the login prompt my name is shown with strange characters in place of the Turkish characters. I am using KDE but I guess the problem is not specific to KDE.

On Fri, 20 Nov 2009 14:26:01 GMT, kvncylmz
<> wrote:

>Today I noticed something else. When the screensaver is activated, I
>need to log in again. At the login prompt my name is shown with strange
>characters in place of the Turkish characters. I am using KDE but I
>guess the problem is not specific to KDE.

The screensaver is still inside KDE. Try setting KDE default fonts.

I have the same problem with, in my case for Georgian unicode characters. After reopening file saved as .doc they turn into question marks. Obviously this is a bug :slight_smile:

Setting KDE default fonts did not seem to solve the problem, however, somehow, some of the problem is gone :slight_smile: I don’t know, exactly what did solve it but the screensaver dialog is now showing correctly, and also my mails seem be displayed (and sent) correct. The problem with the office seems to be related to “doc” filter, if I use docx, there is no problem. This might be a bug.

I don’t know how you changed the other settings that you finally messed with innate KDE fonts, but I discovered that this issue is mainly because of openoffice and most probably java fonts. Don’t know any solution yet, but this happens only and only when you export an openoffice document with Turkish characters into a MS Office document type. So far I found solution of exporting openoffice documents as PDF files. I know it is not the way it is intended but… still you have something that you can actually print or share. Considering the funny looking non-linux friendly, linux drivers supplied printers :stuck_out_tongue: (How I luve thee Canon printers without proper Turkish user-manual or crippled translated manuals…)
Meh… This became more rant than finding solution. Anyways, long story short, what I recommend is to export your documents as PDF files. I can’t remember exactly but I believe there shouldn’t be any problem with proper MS Word written documents from Windows OS. Hope had any help out here.

My best bet for a fix, try to thinker with Java fonts, and if you can replace those fonts with Windows fonts.

Uhm… I think I have found the problem. To fix this problem you need to change the how originally openoffice saves the files. I guess it is bug relating to character sets with the new 3.x series, probably because of compression or something.(I’m still hoping that it is the solution though.)

To fix the saving files in .doc format and seeing weird characters you need to do as follows (Sorry if these are wrong setup for english version, I’m using Turkish version, will put Turkish below):

Settings -> Options -> Load/Save -> General
From this tab: You must change “ODF version” from “1.2 (recomended)” to “1.0/1.1 (Openoffice 2.x)”

Araçlar -> Seçenekler -> Yükle/Kaydet -> Genel
Buradan: “ODF biçim sürümü”'nü “1.2 (tavsiye edilen)” den “1.0/1.1 (Openoffice 2.x)” e çevrilmeli.

Hope it works like this without problems

Alparb, thanks for your suggestions, however, changing the mentioned settings did not solve the problem. I also tried installing sun’s java and using it but the problem still continues. I don’t know whether playing with java font settings (/etc/java/ would solve the problem. I have found somewhere that passing the parameters -J-Dawt.useSystemaaFontSettings=on to java might solve the problem however, java does not recognize these and passing them through openoffice settings did not help also…

Well, an upgrade to openoffice shortly after my first messages seems to have solved the problem with office. Most of the problem with my files are also gone, but names of many files created under windows and whose names contain Turkish characters are still problematic. I keep seeing question marks or strange characters.