Changing sys parameters

After running su and entering my password i don’t seem to be able to run either:

echo 1 > /proc/sys/net/ipv4/conf/all/mc_forwarding
sysctl net.ipv4.conf.all.mc_forwarding=1

both give permission denied errors. Adding this line into /etc/sysctl.conf doesn’t set it either.

Can someone tell me how to change this parameter, or at least explain why as root i still get a permission denied? I’ve looked for a gui interface to this, but haven’t come up with anything.

Any ideas anyone!?

Because that’s only a readable value, plus don’t forget the -w option
when using sysctl.

You could try adding to your /etc/sysctl.conf file and rebooting…

I’m thinking you may have to set the option in the kernel config and
recompile :frowning:

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3 days 15:15, 2 users, load average: 0.32, 0.11, 0.08
GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14