Changing resolutions of boot & shutdown screens


I recently got a new widescreen monitor, and while I have been able to properly set the resolution within KDE 4.1, I’m not sure how to change the resolution of the boot and shutdown screens. I don’t want to change the theme, just its resolution.

I tried the following command

mkinitrd -s 1680x1050

and I didn’t get any boot screen at all.

On a side note, how do I permanently get rid of the penguin boot screen on start up, and other Christmas-y things? (santa hat on vlc icon…)

Thanks for your time and assistance

IIRC the Xmas penguins will go away shortly by themselves. The dev’s have a date parm that toggles it on this time of year. I’ve seen it, just don’t remember where it is offhand.

To change to a different bootsplash (and shutdown, it’s the same) resolution, I expect you checked this Custom splash screen - openSUSE. Did you see this note:

(Small note: Display needs to be in 16bpp mode for the bootsplash to work, make sure grub options are set correctly. aka vga=794 for for 1280x1024)

This refers to the vesa framebuffer which is the kernel graphics driver used until the X server loads - and what you configured into the initrd (the initial ramdisk image the kernel uses when it first boots, that’s where the bootsplash is built in). As the above explains, in addition to the initrd, the kernel needs to be given the vesa mode when booted. You can try this from the boot menu in Boot Options (it will override what is currently in the boot configuration file). Type this:


However, for all of this to work, your graphics card must support this resolution framebuffer. Do this as root in a terminal:

hwinfo --gfxcard

And it may tell you. However, the data is not always reliable. That’s because the chip may support a certain framebuffer resolution, but not the card’s bios (The chip and the card are not made by the same manufacturer; the former could be nvidia, the latter MSI, etc.) or vice-versa. If 1680x1050 doesn’t work, you might try something else close with the same aspect ratio (probably 1440x900) that looks like it is supported and the screen may stretch to your monitor.

Good luck.

Occurred to me later . . .

The penguins are in the grub boot menu splash screen. That is completely separate from the bootsplash that begins after the boot has begun (which is the same as shutdown).

Thanks a lot mingus :slight_smile:

You’re welcome! :slight_smile: