Changing Desktop Layout Causes Plasma Crash


I’m running SUSE for the first time and I’ve done pretty well getting things going including my Nvidia drivers, color management, Fancontrol and sensors etc. I like YaST and things have different names than I’m used to, but I’m figuring it out. I’ve ran into a problem with switching from “Folder View” to “Desktop Containment”. After clicking Apply to apply the layout changes I have a black screen with a pointer and Conky. It appears that Plasma is dead and I can’t get it to restart from a ctrl+alt F2 console and none of the Plasma hotkeys work.

I’ve been running Linux/KDE for years. I was running Mageia 5 with KDE 4 and am pretty familiar with things, but Plasma 5 and SUSE are both new to me. I’m running a fully updated Tumbleweed and everything seems to be working except changing Plasma desktop layout. I don’t know where to look for Plasma errors etc. I might not have something installed, I’m not sure, but when switching back to Folder View it crashes again and I have to ctrl+alt backspace to get back out of it again. I don’t think I’ve configured anything that would be causing this. Any help would be appreciated.

I don’t think I have had that happen. I do remember it happening with KDE4.

The thing is, that I make those changes once, and never again until I want to rebuild the desktop configuration. So I might not remember whether I had to logout and login again after changing the layout.

However, you seem to be having more frequent problems. It might be related to support for your graphics card. (I have Intel graphics).

Thanks for the reply. It does it every time and I don’t know where to look for clues and I’m not sure I’m trying to restart it properly. It hit ctrl+alt+F2 and get a console.

I read to do:

killall plasma-desktop


kstart plasma-desktop

When I kill everything it says nothing is running and I forgot exactly what kstart said but it was no screen available I believe, but I do have a pointer. There is no way to copy it so I’ll have to take a better look at it. It didn’t hint at where to look, like a missing file or anything, always nice when it does.

I switched layout to hide the icons and take a screenshot and that’s how I found the problem. I was going to send a screenshot to a friend who is also switching to Tumbleweed. There is a few of us switching at the same time.

Thanks again and I will report the cause if I find it. I’m thinking Conky or icon previews or something. It does affect it whether you’re switching to Desktop Containment or to Folder View. It seems to me that it’s in the switching, not the content of any particular layout, but maybe Conky is the cause.

Ok, I found out a lot on that trip to the dark side! :wink:

It does switch layouts and when switching to the Folder View layout you see it for a second before it disappears. I was able to bring up krunner with alt+F2 and open consoles etc. I ran some commands to restart Plasma and was able to open Kate and save the output.

As root:

# killall plasma-desktop
plasma-desktop: no process found
# killall plasmashell
plasmashell: no process found
# kstart plasma-desktop
kstart(12612) main: Omitting both --window and --windowclass arguments is not recommended 

As normal user:

# plasmashell
QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
"Session bus not found
To circumvent this problem try the following command (with Linux and bash)
export $(dbus-launch)"
# kstart plasma-desktop
kstart(11605) main: Omitting both --window and --windowclass arguments is not recommended 

kstart plasmashell
No protocol specified
No protocol specified
kstart: cannot connect to X server :0

# kstart plasma-desktop
No protocol specified
No protocol specified
kstart: cannot connect to X server :0

# plasmashell
No protocol specified
No protocol specified
qt.qpa.screen: QXcbConnection: Could not connect to display :0
Could not connect to any X display.

Throughout all of this I could use the keyboard to rotate the cube and it had a top and bottom, but no sides. Also, when I left Conky running, it was visible so X is running. It tells me no Plasma processes are running but will not start a new one. This all makes it appear that when it changes layout that it does change it and I do see it but then it crashes after the layout change and restart of Plasma. I am assuming the layout change includes stopping Plasma, making changes, and restarting it, then Plasma crashes. The really odd thing is that you can use any layout because when you kill everything and log back in, the layout works fine. It only crashes when you change the layout. I sure appreciate any help and hope this provides more clues. Thanks again.

I’m going to look up how to force reinstall of certain packages without removing them. I used to do it with “urpmi --replacepkgs packagename” and I’m not sure how it works in SUSE. It seldom worked but it did sometimes.

The obvious work around, is to avoid changing the layout :stuck_out_tongue:

Have you tried using Activities? I have two activities defined. The one that I mainly use is configured for the “Desktop Containment” layout. My other activity is configured for “Folder View”. Switching between the two activities does not seem to cause problems.

I’ve seen these phenomena reported before. In a number of cases the wrong update technique was used, i.e. the plasma updater applet, or ‘zypper up’. Tumbleweed’s only supported update mechanism is through ‘zypper dup’. If you have not used ‘zypper dup’, first run this command and see if things improve.

Looks like you are trying to run plasmashell as root.
It needs to be run as the logged in user.

Regarding the crash, I think I saw a fix for a crash when changing the layout flying by, but I’m not sure at the moment if it is in 5.12.5 already that got released yesterday.

Thank you everyone. I found a bug report about this issue and it has been fixed but we haven’t received it yet.
I assumed I had a problem that was my fault and yes, I was updating wrong. I didn’t know you couldn’t use the update icon in the panel.
For now I did as nrickert suggested and made an activity with a different layout and that works.

Here’s the bug report I found.

Ah yes.
That’s in plasma-framework, not Plasma itself.
Will be part of KDE Frameworks 5.46.0 then, to be released on May 12th.

I’ll add a patch to the openSUSE package though so that you get it earlier, would probably good to still get it into Leap 15.0 I think.

PS, you can try the plasma-framework* packages from here and see if the fix works for you:

I somehow cannot get Plasma to crash in the first place… :\


Ok, thank you. I didn’t want anyone to go to any special trouble but if it has to be done anyway, then I understand. Everything seemed to work so good that I assumed someone had seen the problem and it would be a simple fix, or at least a known problem and it was in the end. I’ve ran the same distro for about 20 years. It was Mandrake, then Mandriva, and then Mageia. I’ve looked around a lot but never ran anything else. I’ve been looking all through TW and wow, it’s a lot different than what I’ve been running but so much the same. I’m interested in keeping up with software a little more and I’m not real fond of those “release” days.

I like the idea of updating and never having to deal with a release. I understand Plasma is a work in progress, I was around for KDE 2>3 >4 and now Plasma. I’ve never ran another desktop either, I just love KDE. I’ve been playing with TW and I decided to reinstall it because I did update with the applet and I want to be certain I’ve got a good foundation. Due to that I can confirm that a fresh install has this problem and it remains even after doing the updates the right way without Pacman enabled.

I appreciate the assistance and I’ve really dug into this. I usually do that to learn where things are and hopefully help me if I have a serious problem that I can’t avoid. I have a couple of friends who had never used Linux but switched to Mageia about 8 years ago because I gave them a DVD. If I switch, they want to switch because I’m basically their tech support. They want to run what I do so I’ll know about it if they have a problem.

I’m really impressed with YaST and TW overall and I’ll avoid these small issues I’ve found. Since you can’t get it to crash then I assume it’s something about my package combination/hardware or drivers. I’m betting my Nvidia driver because I do have some flicker after resuming from suspend. I can probably fix it by installing the driver the hard way but I’ve done that many times with the ATI driver so I’m comfortable with that if I have to. I noticed DKMS is available but Mageia had it installed. I didn’t have to set it up so if it needs configuration I’ll have to read up on it. I do like the way it compiles at boot for the kernel you’re using. I read a review of Mageia and the guy seemed surprised by that, so I assumed it wasn’t real common.

I think I’m good to go with a good stable system and I know how to update properly etc. I do need to read a lot more about some of the SUSE tools like Zypper etc. As I said, if I have a problem I like to go for broke and learn along the way, especially on a clean install that I can easily get back to. I also have good backups so I don’t have to worry about that. My friends don’t poke around at all. They just run it and update it so they should be ok, but I’m going to talk to them about Leap. If something were to happen I don’t want to have to fix 3 or 4 computers at the same time when I can’t figure out my own. I understand that TW has a little more risk than Leap. Me, I’m ready but way far behind on Plasma etc, but I’ll get it. I used “M” for 20 years so I plan to stick around a while if this works out for me. I’m not a distro hopper at all. I want a good solid install that I can learn to maintain and stick with it. And thanks again.

TW is bleeding edge, so sometimes you bleed ;). I’ve read about issues with TW+nvidia proprietary drivers, it seems the installer from nvidia, that you have to install “the hard way™”, is sometimes behind TW, requiring patching, etc. A lot of people don’t have a problem, apparently, but others do.

If you want a stable system, like a work box, LEAP is the way to go IMO. And with LEAP 15 around the corner, it will be basically the same as the current TW, so you won’t be too “behind” for some time. And the KDE updater applet works, so well that I’ve been using yast software updater less and less.

P.S.: I have three computers with LEAP 42.3, KDE/Plasma and nvidia GTX 1050, GTX 650 and GT 710 each, all running the proprietary blob without issues. Others have intel and amd graphics.

Well, it wouldn’t necessarily have to be done as Tumbleweed would get the latest versions anyway.

But I decided to do the extra work to have this fix in Leap 15.0 as well (which currently is at the same level as TW regarding KDE Frameworks and Plasma), which is to be released in 2 weeks and is in package freeze already (KF 5.46 will be released to late to still get it in).

Adding a patch is quite simple really (if it applies cleanly at least), so this was not much work anyway.
You did most of the work by finding this patch… :wink:

It’s on the way to TW already btw, should be in the repos in the next few days.

OK great, I’m glad it wasn’t total waste of my time. It sort of felt that way when I found it was a known bug that was on its way to being fixed. I’m still learning about Plasma 5 file locations etc. I was looking into changing what used to be KDM themes but is now SDDM themes. I know I can switch to KDM and I’ll read up on this stuff. I really like having a list of users as in the MIB Ossigeno Ultimate KDM theme:

That’s been my favorite login theme since I found it and I’ve used it for years. I don’t want to go to far off topic here, so I’ll leave it at that so others don’t miss that the original issue will be fixed shorty. Nice meeting you and thanks again. I think I’ll go see what I can learn on the forum, I’m sure it’s packed with info.

Thanks for the info. It seems it’s straightened up a bit and I installed the Nvidia drivers though YaST. I’m using a GTX 760 and I’m used to Mageia. It has an X server install in Mageia Control Center and compiles and installs the driver at boot. This is a little different for sure, but I’m comfortable with it, so far. I have Leap in a VM on Mageia 5, then I heard about TW. I think TW is going to be ok, I just won’t do major updates until a few post that it’s working for them. Right now I have Nouveau DRI wanting to install. I removed it thinking it might be my flicker after wake problem, and apparently it’s not, so I don’t want to install it and trash my Nvidia driver that is working.

I’ve got it running pretty good so I need to read a bit to see what’s safe and what isn’t. I read the Nouveau stuff was blacklisted. But if it re-installs I’m thinking it’ll un-blacklist itself, not sure. I’d really like to stick with TW so I don’t have to deal with total upgrades.

I don’t agree here. Like with Leap, yes, some users have issues with the proprietary drivers on Tw. But, relatively few people. Tw has it’s own repo and from what I’ve seen that works well. And bleeding is not necessary: if the NVIDIA driver fails, boot the previous kernel and you’re back in business, or boot the previous snapshot ( even better ).

You have to confess that the likelyhood for problems is bigger on TW though.
In particular, it quite reliably happens that the latest (released) nvidia drivers suddenly won’t work at all anymore after a major new kernel update (remember 4.16.0?).

You’d need to patch the drivers manually in such cases, or wait for a new release and continue to use the older kernel (which may not be installed any more, if there have been a couple of updates meanwhile) or maybe update the driver to some beta version.

The packages in the repo do normally contain patches for the latest kernels if necessary, but that may not necessarily be the case immediately when the kernel is released (again, remember 4.16.0?).

It’s not really recommendable to use TW when you rely on 3rd party drivers, stating something different is just lying IMHO.

Booting a different kernel (won’t help with an incompatible Xorg update…) or snapshot can help you get back a working system, sure, but you should at least be aware of that.

This has been fixed in the Plasma 5.12.5 update on 5/13/2018.
It will change layouts without issues.

No, as I wrote, this will be fixed in KDE Frameworks 5.46.0 (in plasma-framework).

But I added the fix to our current openSUSE plasma-framework package (so that it will also be part of Leap 15.0), and that update was part of the same snapshot:

==== plasma-framework ====
Subpackages: plasma-framework-components plasma-framework-lang

  • Remove outdated calendar.svgz from the Air and Oxygen themes to
    fix showing event markers in the calendar (boo#1091832)
  • Add Air-Oxygen-themes-Bump-version.patch to raise the version of
    these 2 themes, otherwise Plasma would reuse existing caches
    rendering the above fix ineffective
  • Add patches to fix window thumbnails on Nvidia:
  • 0001-Revert-windowthumbnail-Use-gamma-correct-scaling.patch
  • 0002-Revert-windowthumbnail-Use-mipmap-texture-filtering.patch
  • Add Dont-alter-memory-management-to-hide-an-item.patch to fix a
    possible Plasma crash when changing the desktop layout

Anyway, glad to hear that your problem is indeed fixed. :wink:

Ok, well, it is working. I’ve found a lot of small problems in TW but they trace back to the work being done on Plasma. I’ve came to the conclusion that my wake from sleep video flickering is not my driver. If it was, it wouldn’t work right after booting, and after waking up running kwin_x11 --replace fixes it. That didn’t work before yesterday’s update but it’s working now and is a good work around, for now. It keeps me from having to logout. I’m on my way to update that thread.